Jump to content

PS4 no subtitles


Go to solution Solved by Luke,

Recommended Posts


Hi, I am trying to watch movies on PS4, everything works great but no subtitles (external srt) are displayed. I have tried to turn them on and off with no luck. I have tried many movies that work great in android and the browser.


I have:



Software ver. 4.50

Emby server Version

Ubuntu linux 16.04.2


I include an example of the specs of a movie not displaying subtitles and server logs...


Any help is greatly appreciated!




Link to comment
Share on other sites

  • Solution

Thanks @@supermau, I can reproduce. This is definitely a bug caused by a recent ps4 system update. The video player is being fed the subtitles but just isn't rendering anything. To work around it I've added some custom rendering for now using our own presentation, and we'll re-evaluate the built in rendering after future system updates.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...