Jump to content


Photo

NAS Folder Permissions for Saving Metadata in Media Folders?

Metadata folders permissions server network attached storage NAS QNAP

Best Answer Happy2Play , 11 March 2017 - 11:30 PM

This option is a per Library setting now.  Go to Dashboard-Library-select each library and ensure the option is enabled.

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 gochiefs88842 OFFLINE  

gochiefs88842

    Advanced Member

  • Members
  • 108 posts
  • Local time: 02:17 AM

Posted 11 March 2017 - 11:16 PM

Long-ish question, *hopefully* easy answer: I recently upgraded from several external hard drives to a QNAP NAS.  After testing the QNAP Emby app server performance, I preferred the old Windows-based server overall and thus the new QNAP is purely operating as the NAS, not the server (hence this forum).  That being said...

Similar to a question I had awhile back here, after changing my library media folders to the new NAS folders, I am again having difficulty saving metadata into local media folders (rather than in a generic "metadata" folder in the server files).  When I add new content, the metadata is successfully being saved somewhere else (unknown location, log attached, tried to refresh "The Accountant" movie metadata).  Not only do I instead want the metadata saved in the media folders, but wherever it's actually being saved is seemingly eating up scarce storage on my OS/server hard drive (small SSD).  

 

According to QNAP, I have enabled permissions for 'everyone' (see attached Capture #1) for my media content. Windows, however, is much more challenging as to confirming these network folder permissions. Unlike when using my external hard drives and simply assigning 'everyone' full R/W permissions through Windows Explorer and then applying these changes, Windows won't let me change these same settings for the QNAP folders, apparently giving full deference to QNAP's security settings and not allowing me to make any changes within Windows; I have navigated everywhere in the Windows folder permission settings and any changes I try simply won't stick, instead reverting to QNAP's overriding "special permissions" (see Capture #2). 

 

How do I get metadata to save directly in the media folders of the NAS?  Thanks in advance for any input!

 

 

Attached Files



#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 12:17 AM
  • LocationWashington State

Posted 11 March 2017 - 11:30 PM   Best Answer

This option is a per Library setting now.  Go to Dashboard-Library-select each library and ensure the option is enabled.


  • gochiefs88842 likes this

#3 gochiefs88842 OFFLINE  

gochiefs88842

    Advanced Member

  • Members
  • 108 posts
  • Local time: 02:17 AM

Posted 11 March 2017 - 11:53 PM

Thanks, Happy2Play--that fixed it for me!  It looks like on a library refresh, an xml and a poster file were added to the movie folder. Artwork like thumbs and background weren't, but I'm guessing Emby is finding those wherever it saved them in the server file before making the change you suggested.

 

Two quick follow-up questions: (1) Do you think artwork such as thumbs and disc art will show up in folders automatically for new content?  And (2) can you tell from my previous server log where that other metadata was saved to?  I'd like to delete it to save hard drive space...

 

Thanks.



#4 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 12:17 AM
  • LocationWashington State

Posted 12 March 2017 - 12:03 AM

Do you think artwork such as thumbs and disc art will show up in folders automatically for new content?

Those images are linked to another setting "Download images in advance" as per library.  If not enable they will only be downloaded as needed (on demand).  You have ensured they are selected images, right?  Dashboard-Library-Metadata-use content type drop-down for each type-expand Images setting
 

can you tell from my previous server log where that other metadata was saved to?  I'd like to delete it to save hard drive space...

Well they should be in "C:\Users\username\AppData\Roaming\Emby-Server\metadata\library\xx\xxxxxxxxxxxxxxxxxxxxxx". The number is the medias itemid number.


Edited by Happy2Play, 12 March 2017 - 12:03 AM.


#5 gochiefs88842 OFFLINE  

gochiefs88842

    Advanced Member

  • Members
  • 108 posts
  • Local time: 02:17 AM

Posted 12 March 2017 - 12:15 AM

Ah, I understand.  I wasn't using any apps, just going through the web server, so now I understand the advance vs. on-demand nature of the new library settings.  Thanks again!







Also tagged with one or more of these keywords: Metadata, folders, permissions, server, network attached storage, NAS, QNAP

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users