Jump to content

emby server on Raspberry pi kodi


Recommended Posts

Hi guys,

 

i am new to this, i have 3 Raspberry Pi at home

 

  • 1 as a server that always stays on, this has my external hard drives plugged in and connected to my network by a Ethernet Powerline. 
  • the other 2 raspberry pi's are in my bedroom and living room and link to the hard drives over the network again by Ethernet Powerlines.

The problem with this set up is that there are all individual libraries. i did try UPNP a while back but the library was too big and was really slow at loading al the artwork etc.

 

I am running openELEC on all devices although i think i will install libreELEC now as it has Emby built in.

 

My question is, is there a way to instal the Emby Sever onto my Raspberry Pi so this can always stay on? (i can only find how to may a raspberry with kodi a client) i don't really want to install the server on my Mac or home PC as i wouldn't want this to be on all the time, or does it not need to be on? Can i install the server and link the hard drives through the network to it then turn off my PC?

 

Just a little confused about how to work the set up.

 

Any feedback would be awesome - would be nice to get it set up with all the feature Emby offers like watch statuses syncing across all my devices.

 

Dark Kent

Link to post
Share on other sites

sorry I've only ever used open elec so new to debian

 

once I've booted i need to go to the terminal and input this code?

 

wget -qO - http://download.opensuse.org/repositories/home:emby/xUbuntu_14.04/Release.key | sudo apt-key add -

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04/ /' >> /etc/apt/sources.list.d/emby-server.list"
sudo apt-get update
sudo apt
-get install emby-server

 

thanks

Link to post
Share on other sites

thanks for the help so far

 

i got an error when installing

 

Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 225.
Segmentation fault
E: installing Assembly /usr/lib/cli/nunit.core.interfaces-2.6.3/nunit.core.interfaces.dll failed
E: Installation of libnunit-core-interfaces2.6.3-cil with /usr/share/cli-common/runtimes.d/mono failed
dpkg: error processing package libnunit-core-interfaces2.6.3-cil (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of libnunit-core2.6.3-cil:
 libnunit-core2.6.3-cil depends on libnunit-core-interfaces2.6.3-cil; however:
  Package libnunit-core-interfaces2.6.3-cil is not configured yet.
 
dpkg: error processing package libnunit-core2.6.3-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnunit-util2.6.3-cil:
 libnunit-util2.6.3-cil depends on libnunit-core-interfaces2.6.3-cil; however:
  Package libnunit-core-interfaces2.6.3-cil is not configured yet.
 libnunit-util2.6.3-cil depends on libnunit-core2.6.3-cil; however:
  Package libnunit-core2.6.3-cil is not configured yet.
 
dpkg: error processing package libnunit-util2.6.3-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnunit-console-runner2.6.3-cil:
 libnunit-console-runner2.6.3-cil depends on libnunit-core-interfaces2.6.3-cil; however:
  Package libnunit-core-interfaces2.6.3-cil is not configured yet.
 libnunit-console-runner2.6.3-cil depends on libnunit-core2.6.3-cil; however:
  Package libnunit-core2.6.3-cil is not configured yet.
 libnunit-console-runner2.6.3-cil depends on libnunit-util2.6.3-cil; however:
  Package libnunit-util2.6.3-cil is not configured yet.
 
dpkg: error processing package libnunit-console-runner2.6.3-cil (--configure):
 dependency problems - leaving unconfigured
Setting up libnunit-framework2.6.3-cil (2.6.3+dfsg-1) ...
* Installing 1 assembly from libnunit-framework2.6.3-cil into Mono
Segmentation fault
Use of uninitialized value $_ in scalar chomp at /usr/share/cli-common/runtimes.d/mono line 275.
Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 225.
Segmentation fault
E: installing Assembly /usr/lib/cli/nunit.framework-2.6.3/nunit.framework.dll failed
E: Installation of libnunit-framework2.6.3-cil with /usr/share/cli-common/runtimes.d/mono failed
dpkg: error processing package libnunit-framework2.6.3-cil (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of libnunit-mocks2.6.3-cil:
 libnunit-mocks2.6.3-cil depends on libnunit-framework2.6.3-cil; however:
  Package libnunit-framework2.6.3-cil is not configured yet.
 
dpkg: error processing package libnunit-mocks2.6.3-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnunit-cil-dev:
 libnunit-cil-dev depends on libnunit-console-runner2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-console-runner2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-core2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-core2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-core-interfaces2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-core-interfaces2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-framework2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-framework2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-mocks2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-mocks2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-util2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-util2.6.3-cil is not configured yet.
 
dpkg: error processing package libnunit-cil-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-cil-dev:
 libmono-cil-dev depends on libnunit-cil-dev (>= 2.4); however:
  Package libnunit-cil-dev is not configured yet.
 
dpkg: error processing package libmono-cil-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mono-devel:
 mono-devel depends on libmono-cil-dev (= 4.6.2.7-0xamarin3); however:
  Package libmono-cil-dev is not configured yet.
 
dpkg: error processing package mono-devel (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of emby-server:
 emby-server depends on mono-devel (>= 4.6); however:
  Package mono-devel is not configured yet.
 
dpkg: error processing package emby-server (--configure):
 dependency problems - leaving unconfigured
Setting up mono-csharp-shell (4.6.2.7-0xamarin3) ...
Setting up libmono-system-design4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-web-services4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-servicemodel4.0a-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-web-extensions4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-servicemodel-discovery4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-servicemodel-routing4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-web-dynamicdata4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-web-extensions-design4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-web-http-selfhost4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-web-mvc3.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-xml-serialization4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-servicemodel-activation4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-servicemodel-web4.0-cil (4.6.2.7-0xamarin3) ...
Setting up libmono-system-data-services4.0-cil (4.6.2.7-0xamarin3) ...
Processing triggers for systemd (215-17+deb8u6) ...
Processing triggers for libc-bin (2.19-18+deb8u7) ...
Processing triggers for ca-certificates (20141019+deb8u2) ...
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....Updating Mono key store
Segmentation fault
Done
done.
Errors were encountered while processing:
 libnunit-core-interfaces2.6.3-cil
 libnunit-core2.6.3-cil
 libnunit-util2.6.3-cil
 libnunit-console-runner2.6.3-cil
 libnunit-framework2.6.3-cil
 libnunit-mocks2.6.3-cil
 libnunit-cil-dev
 libmono-cil-dev
 mono-devel
 emby-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
any ideas?
 
thanks
Link to post
Share on other sites

hi,

 

right so i managed to install it - and it worked for the first time

 

once i reboot the server will not start

 

i have made a fresh install and the same thing happends.

 

when i run sudo service emby-server start and then go to the ip:8096 it doesnt load

when i run sudo service emby-server status i get:

 

emby-server.service - Emby Media Server
   Loaded: loaded (/lib/systemd/system/emby-server.service; enabled)
   Active: failed (Result: exit-code) since Sat 2017-03-11 12:41:53 UTC; 1s ago
  Process: 3543 ExecStopPost=/usr/bin/emby-server clear (code=exited, status=203/EXEC)
  Process: 3540 ExecStart=/usr/bin/emby-server start (code=exited, status=203/EXEC)
 Main PID: 3540 (code=exited, status=203/EXEC)
 
Mar 11 12:41:53 raspberrypi systemd[1]: Started Emby Media Server.
Mar 11 12:41:53 raspberrypi systemd[1]: emby-server.service: main process exited, code=exited, status=203/EXEC
Mar 11 12:41:53 raspberrypi systemd[1]: emby-server.service: control process exited, code=exited status=203
Mar 11 12:41:53 raspberrypi systemd[1]: Unit emby-server.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
 
 
any ideas?
Link to post
Share on other sites
hurricanehrndz

 

hi,

 

right so i managed to install it - and it worked for the first time

 

once i reboot the server will not start

 

i have made a fresh install and the same thing happends.

 

when i run sudo service emby-server start and then go to the ip:8096 it doesnt load

when i run sudo service emby-server status i get:

 

emby-server.service - Emby Media Server
   Loaded: loaded (/lib/systemd/system/emby-server.service; enabled)
   Active: failed (Result: exit-code) since Sat 2017-03-11 12:41:53 UTC; 1s ago
  Process: 3543 ExecStopPost=/usr/bin/emby-server clear (code=exited, status=203/EXEC)
  Process: 3540 ExecStart=/usr/bin/emby-server start (code=exited, status=203/EXEC)
 Main PID: 3540 (code=exited, status=203/EXEC)
 
Mar 11 12:41:53 raspberrypi systemd[1]: Started Emby Media Server.
Mar 11 12:41:53 raspberrypi systemd[1]: emby-server.service: main process exited, code=exited, status=203/EXEC
Mar 11 12:41:53 raspberrypi systemd[1]: emby-server.service: control process exited, code=exited status=203
Mar 11 12:41:53 raspberrypi systemd[1]: Unit emby-server.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
 
 
any ideas?

 

Please post the full journalctl from last reboot `journalctl -b`

Link to post
Share on other sites

sorry not sure what you mean by distribution

im using a raspberry pi 2 connected by ethernet running raspbian jessie with pixel

 

 

I ran this bit of code to install emby server

Installing directly on raspbian or other debian directive without docker (armhf/armv7/aarch64):
wget -qO - http://download.opensuse.org/repositories/home:emby/xUbuntu_14.04/Release.key | sudo apt-key add -
sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04/ /' >> /etc/apt/sources.list.d/emby-server.list"
sudo apt-get update
sudo apt
-get install emby-server

 

it works when i run the code for the first time and loads via the ip:8096, but if i turn it off and back on then even when i run the server start code in the terminal - the ip:8096 brings back nothing (can't load page)

 

Let me know if you need any other info or this isn't what you needed

 

appreciate the help!

 

kent

Link to post
Share on other sites
epayson85

sorry i used dietpi

 

http://www.htpcbeginner.com/setup-emby-server-with-raspberry-pi-3/

 

theres a link to what i followed - it worked like a charm

 

Thanks for your help guys :D

 

Hey so how is it working so far?  How big is your library?  I want to make a quick easy to use system for a friend as a gift.  I do full on HTPCs for people all the time but this will literally just be to hold movies.  I was debating doing a shield tv with plex server on it, but from what I have been reading is plex can't handle a large collection and starts to slow down on that device.  Since its a gift I want something that is simple, they just plug it in, and they go.  My thought now is raspberry pi with emby server on it that they plug in to their router and never touch it.  Then an android device or firetv they use on their TV to access it.  No transcoding required but does the server seem to hold up ok?  How about say 2,000+ movies? 

Link to post
Share on other sites

Hey,

 

just to let you know as you were asking for an update.

 

I've ran into a problem , it may be how I've set up the smb shares. basically in emby server when i am setting up my folders of media it sees a different section of the SD card than you see over the network and on kodi.

 

 

i.e.  in dietpi terminal & emby server external hard drives are mounted to /mnt/3TB_TV, /mnt/2TB_Movies

kodi when syncing the emby library when using direct parts is looking for /mnt/3TB_TV etc but not finding these. 

 

 

it seems that under the browser in kodi when looking for smb hard drives its location is different /dietpi/data/3TB_TV

 

the two don't quite link up

 

 

Thanks for that link i will have a look at that!

 

 

let me know if anyone know how to get them to see each other

 

kent

Edited by darkkent
Link to post
Share on other sites

also guys not sure if this is normal I've got about 4tb of movies and 5 tb of tv shows and scraping all the meta data has taken a day (24hours)and its only at 42% or a raspberry pi 2

 

seems abnormally slow as i can scrape that in koi normally in a few hours

Link to post
Share on other sites

Ok, it is scanning everything one at a time. By default Emby server enables several metadata providers, including Omdb, MovieDb, Tvdb, and Fanart. You might consider going into the metadata settings section and turning some of those off. That is basically what the server is doing here.

Link to post
Share on other sites

ah okay! i guessing i can only do this when its not scanning as i can't see the setting there to turn any of them off at the moment

 

also i keep having a problem when integrating my library with kodi

 

it keeps coming up with a error when building the library that it can't find the source for each movie.

 

i'm guessing this is to do with the network credentials?

 

my smb address is smb://LIBREELECSERV/(harddrivename)

to my knowledge i haven't set up a username and password. is it asking for the username and password that i log into the embryo dashboard with?

 

Thanks

Link to post
Share on other sites
  • 2 months later...
Luke

How can I selectively disable metadata providers?

 

Have you explored the settings in the emby server dashboard under library -> metadata?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...