Jump to content

Emby Theater on Raspberry Pi


Recommended Posts

Ok, after re-installing it is co-operating much more. I still had to use sudo npm -g install electron@1.4.16 --unsafe-perm=true --allow-root to install electron without errors but now emby actually starts up. 

The only weird thing i noticed testing this out so far was that with live tv it takes a while after clicking on the channel for the tv guide grid to go away. I think it was between 5 and 10 seconds that i was watching tv with the tv guide super-imposed over the program. 

I also think my tv does not support hdmi cec because the tv remote did nothing to control the rpi, but on the same tv i cant use my tv remote to control the mi box or the amazon fire so pretty sure its just not supported by the tv. I will have to see about testing on the living room tv, which i can use the living room tv to control the fire.

Also of note, for me playing tv was direct play and all my tv channels are .ts so is emby auto detecting that my rpi has mpeg2 hardware acceleration unlocked? I was very happy to see direct play under stats for nerd on my rpi.

At some point i will have to see what i can do about a decent bluetooth remote. I could see the rpi making a really nice ET device at this point. The price point is hard to beat. Management is pretty easy also, just turn ssh on and do all the tweeking from a computer.

Link to post
Share on other sites
cybergrimes

No, I tried changing the display from desktop / TV & horizontal/vertical.

I didn't see any change between horizontal/vertical, maybe I'll try restarting the app to see if that helps the layout update

@@Luke

Restarting after setting new layout display let it take effect, wouldnt change otherwise

 

So in ET the guide button is only in the horizontal layout? I didnt see one when using the layout that matches web & Android TV style

Edited by cybergrimes
Link to post
Share on other sites

@@Luke

Restarting after setting new layout display let it take effect, wouldnt change otherwise

 

So in ET the only way to get a guide button is in the horizontal layout? I didnt see one when using the layout that matches web & Android TV style

 

There is help text underneath the field saying you need to restart or log out.

 

Make sure live tv is one of your visible home screen sections.

Link to post
Share on other sites
cybergrimes

There is help text underneath the field saying you need to restart or log out.

 

Make sure live tv is one of your visible home screen sections.

 

Thanks re: help text, it's clearly right there but I can't read apparently ;/

 

As for live TV, I do have a home screen button for live TV just like all my other devices but when I click into it on a TV style layout my top menu options are: programs, channels, recordings, schedule and series.

The same menu on the web app includes guide. I don't see the guide button on ET for Windows either.

 

ET for Windows:

5acf5eda2e17c_et.png

 

Web:

5acf5f1a15d4e_web.png

Edited by cybergrimes
Link to post
Share on other sites

I know some people avoid the pi as a emby client because you have to manually start theater once the pi boots.

 

A solution for the time being:

 

In a terminal on your pi once you have theater installed and running:

cd /home/pi/.config/lxsession/LXDE-pi
sudo nano autostart

At the bottom of this file add:

@xset s off
@xset -dpms
@xset s noblank
@/usr/local/bin/electron /home/pi/emby-theater-pi
Once you have done this, emby theater will start when the pi boots and you can then control it via another emby client (like android).

No need for a mouse / keyboard, or any other hardware for that matter. :)

 

 

Because of the lack of audio via analog out, im using the web app atm via chromium.

To auto start that add this to the file instead:

@chromium-browser --start-fullscreen http://<your server url here>

Silly question, but how do i control this from another emby app?

Link to post
Share on other sites
  • 1 month later...

I know some people avoid the pi as a emby client because you have to manually start theater once the pi boots.

 

A solution for the time being:

 

In a terminal on your pi once you have theater installed and running:

cd /home/pi/.config/lxsession/LXDE-pi
sudo nano autostart

At the bottom of this file add:

@xset s off
@xset -dpms
@xset s noblank
@/usr/local/bin/electron /home/pi/emby-theater-pi
Once you have done this, emby theater will start when the pi boots and you can then control it via another emby client (like android).

No need for a mouse / keyboard, or any other hardware for that matter. :)

 

 

Because of the lack of audio via analog out, im using the web app atm via chromium.

To auto start that add this to the file instead:

@chromium-browser --start-fullscreen http://<your server url here>

 

 

Flawless idea using chromium at boot and avoiding any npm fiddling. Working great with the above setup. Only occasional stutters exist which I'll blame on the hardware itself. 

 

Couldn't get Emby audio-out on firefox (I use a hifi-berry dac+, probably the issue here?). 

 

As others have said, a real remote control interface built on the API a la Kodi/Plex is all that's needed now. 

Link to post
Share on other sites
  • 3 weeks later...

This has become a fairly long thread with several different sets of install instructions, not all of which work completely.

 

I figured id post what I have done to setup my rpi today, maybe someone will find it useful.

 

First things first, Install Raspbian

 

Once you have booted into Raspbian on your RPI open a Terminal and enter the following:

sudo apt-get update 
sudo apt-get dist-upgrade
sudo apt-get update

sudo apt-get install npm
sudo npm -g install electron@1.4.16
cd ~
git clone https://github.com/MediaBrowser/emby-theater-pi.git
To start Emby Theater, you can open terminal and run:

cd emby-theater-pi
electron .
Or you can navigate to /emby-theater-pi/ and run start.sh.

 

I also decided to make a desktop icon to launch emby. You can do this by creating a text file on the desktop named 'emby.desktop' with the text:

[Desktop Entry] 
Name=Emby
Type=Application
Comment=Start Emby Theater
Categories=Application
Exec=/home/pi/emby-theater-pi/start.sh
Terminal=false
StartupNotify=false
Icon=/home/pi/emby-theater-pi/icon.ico
As a work-around to the issue with dark video:

 

If you edit /emby-theater-pi/playbackhandler/playbackhandler.js

 

And change "var args = ["--alpha", "80"];" the value is a number between 0 and 254.

0 being completely black, and 254 the controls aren't visible over the video.

I find 200 to be pretty good.

 

I actually find this to be a handy feature. The tv I'm using is far too bright in a dim room.

 

 

 

 

Edit:

If you need audio to play from the analog output instead of only the hdmi, open the file 'playbackhandler.js' and directly after:

var args = ["--alpha", "180"];

 

 

Add the lines:

args.push("--adev");

args.push("both");

 

 

Followed these instructions and have it working lovely, my only issue is that the onscreen overlay for transport controls and choosing the quality is very opaque and nearly unreadable. is there a tweak for this? 

Link to post
Share on other sites
Luke

Followed these instructions and have it working lovely, my only issue is that the onscreen overlay for transport controls and choosing the quality is very opaque and nearly unreadable. is there a tweak for this? 

 

They're supposed to be opaque. can you show a screenshot? thanks.

Link to post
Share on other sites
darkassassin07

......

 

 

As a work-around to the issue with dark video:

 

If you edit /emby-theater-pi/playbackhandler/playbackhandler.js

 

And change "var args = ["--alpha", "80"];" the value is a number between 0 and 254.

0 being completely black, and 254 the controls aren't visible over the video.

I find 200 to be pretty good.

.....

 

 

Did you try messing with this at all?

Link to post
Share on other sites
  • 3 weeks later...

Hi all,

 

Everything seems to be working fine with this install, I can watch ripped DVDs, MKV files, and Live TV just fine. I have an old WMC RC6 remote that I was able to configure using ir-keytable for all of the basic navigation functions, but I have not been able to get any of the volume controls to work. I think it's because of the different keys used by omxplayer and Emby, but I'm not sure. Has anyone been able to get this part of the install working?

 

Appreciate any help I can get. Thanks.

Link to post
Share on other sites

Hi all,

 

Everything seems to be working fine with this install, I can watch ripped DVDs, MKV files, and Live TV just fine. I have an old WMC RC6 remote that I was able to configure using ir-keytable for all of the basic navigation functions, but I have not been able to get any of the volume controls to work. I think it's because of the different keys used by omxplayer and Emby, but I'm not sure. Has anyone been able to get this part of the install working?

 

Appreciate any help I can get. Thanks.

 

How were you able to get Live TV to work? What is your current setup consist of?

Link to post
Share on other sites

Yes, Live TV works. I'm using it in the office which does not have the best wifi, so occasionally I do have to pause it to let the buffer catch up. I'm using an RPI3 with the internal wifi, no dongle, and an HDMI connection.  I did use a few of the tweaks for the playbackhandler.js file mentioned in this thread;

 

var args = ["--alpha", "180"] for the dark screen

args.push("--adev") and args.push("both") for getting both the HDMI and analog audio, for headphones, working

args.push("--live","--lavfdopts","probesize:700000") for quicker channel startup

  • Like 1
Link to post
Share on other sites

Yes, Live TV works. I'm using it in the office which does not have the best wifi, so occasionally I do have to pause it to let the buffer catch up. I'm using an RPI3 with the internal wifi, no dongle, and an HDMI connection.  I did use a few of the tweaks for the playbackhandler.js file mentioned in this thread;

 

var args = ["--alpha", "180"] for the dark screen

args.push("--adev") and args.push("both") for getting both the HDMI and analog audio, for headphones, working

args.push("--live","--lavfdopts","probesize:700000") for quicker channel startup

 

Nope. Still a no-go for me. What kind of tuner do you have?

Link to post
Share on other sites

Two HDHomeruns, an older Connect and the newer Quatro, both for over the air tuning. Due to the not so good wifi, I had to change the quality settings to 720p-1.5Mbps, otherwise it stutters really badly. Do you get any picture or audio at all?

Link to post
Share on other sites

Two HDHomeruns, an older Connect and the newer Quatro, both for over the air tuning. Due to the not so good wifi, I had to change the quality settings to 720p-1.5Mbps, otherwise it stutters really badly. Do you get any picture or audio at all?

 

Nope. HomeRunHD Prime here. It works with desktop browsers, but when I try the Pi it just sits at a black screen. No audio. It's like it just stops communicating with the HomeRun after it makes a request. No idea what the issue is.

Link to post
Share on other sites

You might have already did these things, but I have to ask. Did you add your mpeg license to the /boot/config.txt file? Have you increased the gpu memory to 128 or 256? 

Link to post
Share on other sites

You might have already did these things, but I have to ask. Did you add your mpeg license to the /boot/config.txt file? Have you increased the gpu memory to 128 or 256? 

 

I have not increased GPU memory. I'll give that a go. Thanks.

Link to post
Share on other sites
Luke

I pushed some updates to the Pi repo yesterday just to bring this up to speed a little bit with other platforms. Thanks guys.

Link to post
Share on other sites

I know some people avoid the pi as a emby client because you have to manually start theater once the pi boots.

 

A solution for the time being:

 

In a terminal on your pi once you have theater installed and running:

cd /home/pi/.config/lxsession/LXDE-pi
sudo nano autostart

At the bottom of this file add:

@xset s off
@xset -dpms
@xset s noblank
@/usr/local/bin/electron /home/pi/emby-theater-pi

 

Can anyone tell me how to change this so that Emby Theater starts at startup with CEC support?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...