Jump to content

Recommended Posts

Hello,

I'm trying to install emby on Raspberry Pi 3. Both Ubuntu-mate and Rasbian give me the exact unmet dependencies error:

root@raspberrypi:# apt-get update && apt-get install emby-server
 

The following packages have unmet dependencies:
 emby-server : Depends: mono-runtime (>= 3.0~) but it is not going to be installed
               Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed
               Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed
               Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
               Depends: libmono-system-transactions4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-web4.0-cil (>= 2.10.3) but it is not going to be installed
               Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed
               Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed
               Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: mono-devel (>= 1.0) but it is not going to be installed

               Recommends: libembymagickwand-6.q8-2 but it is not installable

E: Unable to correct problems, you have held broken packages.




root@raspberrypi:# apt-cache policy libembymagickwand*
libembymagickwand-6.q8-2:
  Installed: (none)
  Candidate: (none)
  Version table:



Also tried the following solutions:

https://emby.media/community/index.php?/topic/29622-unmet-dependencies-imagemagick-6q8/
https://emby.media/community/index.php?/topic/28188-massive-update-for-debian-and-ubuntu/

root@raspberrypi:# apt-get remove --purge  libmagickwand-6.q8-2 libmagickcore-6.q8-2  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libmagickwand-6.q8-2
E: Couldn't find any package by regex 'libmagickwand-6.q8-2'
E: Unable to locate package libmagickcore-6.q8-2
E: Couldn't find any package by regex 'libmagickcore-6.q8-2'



Is it currently possible to install emby-server on Debian/Rpi?


Cheers,

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...