Jump to content

Krypton no more Ratings


b0mb
 Share

Recommended Posts

@@im85288

 

I've tried your update but nothing changed ...

 

Edit:

 

In some skins the rating is shown in the info view of a movie but not in all skins.

 

When I scroll through my movies the rating is missing either.

Edited by b0mb
Link to comment
Share on other sites

im85288

@@im85288

 

I've tried your update but nothing changed ...

 

Edit:

 

In some skins the rating is shown in the info view of a movie but not in all skins.

 

When I scroll through my movies the rating is missing either.

 

Thanks, I just put up version 2.3.27 in the beta repo. Can you give that a try and remember to reset all your library (as new tables are being populated in your database), also this is for now only for Movies

Link to comment
Share on other sites

sualfred

It seems to work in DialogVideoInfo.xml for all movies. In MyVideoNav.xml it's only shown for a few. 

Link to comment
Share on other sites

im85288

Is that with the latest 2.3.27 version? As far as I can see I now populate the correct tables.

 

Two new ones are populated:

 

ratings and uniqueid

 

If anyone can compare what they get via emby with a standard library that would be super useful...other than that it looks correct to me

Edited by im85288
Link to comment
Share on other sites

sualfred

Yep, 2.3.27.

I'm already in the bed (my child will beggin for her bottle in a few hours, need sleep), but I can provide you a local and a emby based library tomorrow if it's useful.

  • Like 1
Link to comment
Share on other sites

2.3.27 looks like the version before to me.... No visible changes

 

BTW I'm also already in my bed - with my kid together ;-)

 

Gesendet von meinem LG-D855 mit Tapatalk

Edited by b0mb
Link to comment
Share on other sites

im85288

2.3.27 looks like the version before to me.... No visible changes

Gesendet von meinem LG-D855 mit Tapatalk

May I ask if your looking at the actual database contents or is this a visual check? If so which skin? I ask as I'm not sure Estuary shows ratings and my new mod uses the skin helper so shows rotten tomatoes and IMDb ratings (but not from the Kodi db) Edited by im85288
Link to comment
Share on other sites

I've tried estuary mod, aeon mq 6 mod, aeon nox Silvo and latest arctic zephyr mod ;-)

 

Gesendet von meinem LG-D855 mit Tapatalk

Edited by b0mb
Link to comment
Share on other sites

im85288

Ok well estuary mod is not mine so no support!!! (ReEstuarized does of course come with support!) In fact all those are mods...as krypton is so new it's difficult to know if it's the skin or not. Anyway others please report your findings and I'm sure we will get there.

Link to comment
Share on other sites

sualfred

Ok, I spent some of my sleeping time to get you some research resources ;)

 

2 freshly scanned libraries. One with Emby (2.3.27) and one with the Krypton RC1. Both have the same content.

https://1drv.ms/f/s!Aj8g8aA7CEOwgeg2hKfIwiWRahB-Cg

 

What I have noticed with 2.3.27:

The few ratings, which are going to be populated in MyVideoNav.xml, are wrong. Example -> a movie has 6,6/10 in the library and 7.0/10 in die video info dialog.

Edited by sualfred
Link to comment
Share on other sites

im85288

Awesome thanks, I think we are getting somewhere though. Marcel confirmed my changes are on the right track: https://github.com/MediaBrowser/plugin.video.emby/commit/87501eedeabf21af04097a330841e2435770de75#commitcomment-20324946 so maybe just a few more tweaks to go.

 

Will continue tomorrow as I've had enough for the day and you need sleep :)

Link to comment
Share on other sites

CBers

Just updated to v2.3.27, but what do I need to do to see if anything has changed, other than resetting the database please?

 

Running Marcelveldt's Titan skin.

 

Also, if someone has managed to download RC1 of Krypton, please share via Dropbox (or similar), as the Kodi site is heavily oversubscribed at the moment :)

Link to comment
Share on other sites

CBers

It's OK, I've figured it out. I didn't HAVE the IMDB option enabled.

 

I do now and every movie now has a rating.

 

Takes a second or two to appear, but it does appear.

  • Like 1
Link to comment
Share on other sites

CBers

On my 2nd Shield, I already had IMDB ratings.

 

I didn't start using Krypton until beta 3 was out, so I must have had the correct database setup.

Link to comment
Share on other sites

CBers

Also, if someone has managed to download RC1 of Krypton, please share via Dropbox (or similar), as the Kodi site is heavily oversubscribed at the moment :)

Just updated to RC2 of Krypton.

 

Yes, RC2, not RC1 :)

Link to comment
Share on other sites

im85288

That was quick! Getting closer to becoming stable.

 

Any ideas on the name for Kodi 18? I go for Luna

Link to comment
Share on other sites

sualfred

Luna or Loki
(My dog is named Luna, and my grand-grand-grand-grand-grand-........................grand-grand-..........grand-grand-grand-............grand-grand-....grand-parents were Vikings) ;)

 

But to be non OT:
Were my databases useful?

Link to comment
Share on other sites

im85288

 

But to be non OT:

Were my databases useful?

 

Yes...but yesterday I took the day off and today i'm sort of confused as to what Kodi is putting in there for episodes/tvshows

 

This for example is the one from your kodi database

 

z9t5ZON.png

 

As you can see movies have a imdb identifier...but I'm not sure what the other ones are...perhaps tvdb id's?

 

The movies though appear to be correct except for I added the type as "imdb" rather than "unknown"

 

JdBN4eX.png

Link to comment
Share on other sites

im85288

Ok answering my own query here...it is the TVDB Id....I'll work on that for tv shows and get a new release put up

Link to comment
Share on other sites

im85288

There's a new release now in Beta with the above changes for tvshows/episodes. 

 

Please check and remember to do a clean install (as this changes the local database)

Link to comment
Share on other sites

Angelblue05

Does a repair for the specific media type not work as well? Just curious.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

im85288

My only concern here is the "type" setting....using a non emby library sets it as "unknown" where I am setting it to either "imdb" or "tvdb". I think my way is more descriptive but as yet I am not aware of the consequences that may have. 

 

If anyone knows more please post it here.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...