Jump to content


Photo

Emby Server - Odd Performance Issue

Emby Server Performance Disk Windows

Best Answer PenkethBoy , 26 September 2016 - 11:10 AM

I assume that the host server has more than 4gig of ram and its the vm's that have 4gig as its not clear from your description

 

i have my emby server on a Intel NUC that has its data on a NAS - via 1 gig network and have no performance issues - so remote data - but i have my cache local on the NUC via M.2 drive

 

Where have you got your cache as this is possibly why its slow as its trying to load the images and they may not be "available" quick enough if the disk performance of the vm is "slow"

 

yes the ssd will speed up the boot and snappiness of the vm when disk access is needed

 

Out of curiosity why are you running emby in a vm?

Go to the full post


  • Please log in to reply
8 replies to this topic

#1 greenwoc OFFLINE  

greenwoc

    Member

  • Members
  • 12 posts
  • Local time: 10:38 PM

Posted 26 September 2016 - 08:15 AM

I'm new to Emby and trying to get a optimal setup sorted.

 

I have the following:

 

Emby Server running on Windows Server 2012 running on a new Quad Core low end (new) Xeon Processor, 4GB Ram. Storage is traditional spinning rust.

Media is all stored on another Server 2012 OS, running on the same hardware (they are two VMs in the same box)

 

Clients include the web app, the Android app, Windows Theatre and the WMC Client (which I hope to replace with the Win 7 Theatre or even the Win 10 UWP App)

 

I initially tried Emby on CentOS and although everything worked as expected I experienced occasional slowdowns where the server would just stop responding for a minute or two.

 

On Windows it's a lot better however sometimes when loading the libraries from a client it will just hang and not display any media. Flicking between libraries usually resolves the issue if it doesn't load itself after 20 seconds or so. I have experienced this on all clients.

 

My guess is that the storage is just not performing well enough and taking too long to load files, causing a slow down.

 

What I'm going to try next is to do one of the following:

 

Move the Emby server onto an SSD, this should speed up the server itself.

 

Move the media into the Emby server and make it a combined Emby and Media server. This in itself shouldn't really make much difference except from moving the media a little closer to the server.

 

My gut is to move the Emby server itself onto an SSD first and see what it does to the performance. Does anyone with more knowledge and experience of Emby have any suggestions for what I should check or anything else that I can try to improve performance?

 

Cheers,

 

Chris



#2 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3445 posts
  • Local time: 10:38 PM
  • LocationWarrington,UK

Posted 26 September 2016 - 11:10 AM   Best Answer

I assume that the host server has more than 4gig of ram and its the vm's that have 4gig as its not clear from your description

 

i have my emby server on a Intel NUC that has its data on a NAS - via 1 gig network and have no performance issues - so remote data - but i have my cache local on the NUC via M.2 drive

 

Where have you got your cache as this is possibly why its slow as its trying to load the images and they may not be "available" quick enough if the disk performance of the vm is "slow"

 

yes the ssd will speed up the boot and snappiness of the vm when disk access is needed

 

Out of curiosity why are you running emby in a vm?


  • kanipek and greenwoc like this

#3 greenwoc OFFLINE  

greenwoc

    Member

  • Members
  • 12 posts
  • Local time: 10:38 PM

Posted 26 September 2016 - 01:05 PM

Hi PenkethBoy,

 

Thanks for the reply. The server has 32GB or with plenty spare so that should be fine. I can increase memory on either the fileserver or Emby if needed but neither seem to be a bottleneck.

 

I think you are on the money with the cache suggestion. That feels like exactly what it is to me and being pretty new to Emby and not yet understanding the architecture I hadn't really thought about it (hence the post).

 

As for running Emby in a VM, there are a few reasons but the main reason TBH is flexibility. Once any OS is built in a VM it's so portable I can quickly move things around and turn them on/off. I'm running a Dell T20 server with a Xeon chip and 32GB of RAM with a bunch of hard disks in there. This means I can run a whole host of different applications self contained within 1 server that is near silent and uses very little power. When I recently upgraded from HP Microservers the migration was as simple as moving the disks from the old server to the new server and registering the VMs in the new hypervisor. 

 

This setup allowed me to build Emby in both CentOS and Windows and compare them, trashing CentOS when I decided I preferred it under Windows, and if I decide to have a go I can build a Plex server and try it out without even turning off my Emby server! Also snapshots, mean that I can instantly roll back if I screw up an installation, upgrade, config etc!



#4 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3445 posts
  • Local time: 10:38 PM
  • LocationWarrington,UK

Posted 26 September 2016 - 01:55 PM

Ok fine was just curious - for testing yes vm's make sense - i always go to full install when i'm happy with the product :)

 

yes emby does not use that much memory - although when doing a db refresh/scan/clean with say image chapter extraction running i have seen my NUC go upto about 2gig for emby plus its spawned processes - this may depend on how big your library is as well but  i am not sure yet from limited testing/observation.

 

Yes i would put your cache on the fastest disk you have to avoid bottlenecks

 

also if you are going to do transcoding you might struggle in a vm (not done this myself) or if you have a GPU in your server you could pass through that to the vm to help - testing will tell obviously and may push you to native install

 

Others may chip in if they have experience of this as a few people do run emby in vm's from reading the forum

 

Have fun

 

Ps - you can more the metadata, sync temp and transcode temp directories to another disk as this will easy the load on the "os" disk in your vm


Edited by PenkethBoy, 26 September 2016 - 01:58 PM.

  • greenwoc likes this

#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142781 posts
  • Local time: 05:38 PM

Posted 26 September 2016 - 02:20 PM

We'd have to look at a server log to offer much opinion:

https://emby.media/c...port-a-problem/

 

But yes certainly an SSD will be much faster.


  • greenwoc likes this

#6 greenwoc OFFLINE  

greenwoc

    Member

  • Members
  • 12 posts
  • Local time: 10:38 PM

Posted 27 September 2016 - 05:05 AM

Thanks Guys,

 

Moved the Emby server over to a spare SSD last night, I've gone from 5-20 second delays when loading a library down to a near instant response. And that is using an old SSD plugged into a PCI SATA I controller. Just need to replace that with a faster PCIe SATA III controller and fix my remaining live TV and guide issues and I'll have a pretty sweet setup.

 

What I love about Emby is that although it's still a little rough around the edges it has the potential to the by far the best solution out there and obviously has a great dev and support community around it. 

 

Thanks for the help PenkethBoy and thanks again Luke.



#7 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3445 posts
  • Local time: 10:38 PM
  • LocationWarrington,UK

Posted 27 September 2016 - 07:56 AM

Good

 

If you want a cheap and cheerful Sata III controller have a look at this i have 5 of them :)

 

https://www.amazon.c...0?ie=UTF8&psc=1

 

Less then £14 for a couple of sata ports or esata ports 



#8 colejack OFFLINE  

colejack

    Advanced Member

  • Members
  • 81 posts
  • Local time: 06:38 PM

Posted 27 September 2016 - 11:15 AM

What storage are you using for your vm host? Also what hypervisor are you running? (just my own curiosity)



#9 greenwoc OFFLINE  

greenwoc

    Member

  • Members
  • 12 posts
  • Local time: 10:38 PM

Posted 17 October 2016 - 07:03 PM

ESXi 6 and an LSI 9210 8i plus 2 mini SAS to SATA cables (£60 brand new from ebay for card and cables). Connected to that I've got 2 RAID1 pairs of 2x 1.5TB and 2x 3TB all fairly old plus an old 60GB SSD that is running the Emby server. Emby flies on that but I have a 256GB much newer SSD to replace the 60GB one at some point.





Also tagged with one or more of these keywords: Emby Server, Performance, Disk, Windows

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users