Jump to content

Help Needed - Emby Server cant find media folders on NAS


JestersDance
 Share

Go to solution Solved by JestersDance,

Recommended Posts

JestersDance

Hi All, 

Just needing a bit of help and not sure where to look.

I recently did a reformat and reloaded emby server (version 3.0.5882.0) but when I go to add media locations server cant find my NAS. The NAS is working fine, ive got mapped drives to my PC etc.

When I try to input the path location of these mapped drives or even the drive directly emby just resets the screen to a blank form and continues to ask me to input an address. I am at a loss as to what to do. To add to this, I really know flip all about a lot of this stuff so am not sure where to dig a little deeper to find the problem.

 

oh, and prior to my reformat is was all working fine!

 

Any help would be very greatly appreciated.

 

happy to post log files etc.. if someone can tell me where to get them! (thats how unskilled i am!)

Link to comment
Share on other sites

Don't use mapped drives.  Just type in the UNC path directly and see if that works.

 

Mapped drives are a very old technique that dates back to before computers really understood networks and the way Windows handles them is not reliable at all (it will disconnect them and not always re-connect them).

Link to comment
Share on other sites

JestersDance

Don't use mapped drives.  Just type in the UNC path directly and see if that works.

 

Mapped drives are a very old technique that dates back to before computers really understood networks and the way Windows handles them is not reliable at all (it will disconnect them and not always re-connect them).

Can you you describe what the UNC path would be? I think I am already doing that?

Link to comment
Share on other sites

JestersDance

I have tried using both my NAS name, eg:

\\NAS0001\Movies

or its IP address:

\\123.456.789.10\Movies

 

and each time it wont accept the input (i.e. the input dissapears in the 'current path' form and it keeps re-asking me to 'please fill out this field'.

After a bit of playing around I have discovered that by pressing enter it accepts the path, but then I get the error message below. If I click 'OK' or the little spirally thing, it removes the path I have put in and asks me to 'please fill out this field.'

 

A thought I had is that it might need the password to get into the NAS - but there has never been a point during the setup that log in screen has come up? Is there a way to give Emby access to the NAS?56f58eecde3f5_Capture.jpg

Link to comment
Share on other sites

FrostByte

Also, if running Emby as a service then the account you start the service with on the server has to be a valid account and password on the NAS also. 

Link to comment
Share on other sites

JestersDance

I guess Im running it as a service? Whats the difference? I did see that page when I installed Emby but it didnt really give me a choice of what to do so I am running it as whatever the default installation is?

 

There is only one user account on the PC and it has access to the NAS. I am thinking Emby isnt being allowed access to it though somehow?

 

Sorry, I realise my limited knowledge must be super frustrating. Emby has always worked for me in a bit of a plug and play and forget way..so have never really had to encounter things like this before!

Link to comment
Share on other sites

FrostByte

You would know if you're running as a service.  It's not something the install does automatically and has to be setup manually after.   That's probably not the issue then

 

Edit: in the dashboard under Advanced Settings if the box to "Run server at startup" is unchecked and there is no Emby icon in the corner then you're running as a service.  If you see the icon then you are not running as a service

Edited by FrostByte
  • Like 1
Link to comment
Share on other sites

geaves

10

That might be the problem, there is a registry I had to add to my windows 10 to allow it to 'see' all PC's and shares on the network....there is a reason some M/S change regarding security....give a sec I'm on another machine.

 

Edit;

 

This is what I added to my windows 10 after a clean install,

 

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\

then in the right hand pane do new REG_WORD and apply this name, AllowInsecureGuestAuth then modify the value to 1

Edited by geaves
  • Like 1
Link to comment
Share on other sites

JestersDance

You would know if you're running as a service.  It's not something the install does automatically and has to be setup manually after.   That's probably not the issue then

 

Edit: in the dashboard under Advanced Settings if the box to "Run server at startup" is unchecked and there is no Emby icon in the corner then you're running as a service.  If you see the icon then you are not running as a service

Thanks for the tip. I have the icon, so I guess I am not running as a service! Is there any advantage to do so?

 

 

That might be the problem, there is a registry I had to add to my windows 10 to allow it to 'see' all PC's and shares on the network....there is a reason some M/S change regarding security....give a sec I'm on another machine.

 

This would be incredible if it was the solution! Having said that when I did my initial upgrade to Win 10 last year Emby worked ok - so is it a recent update to em MS security settings? Definitely worth a try regardless!

Link to comment
Share on other sites

JestersDance

That might be the problem, there is a registry I had to add to my windows 10 to allow it to 'see' all PC's and shares on the network....there is a reason some M/S change regarding security....give a sec I'm on another machine.

 

Edit;

 

This is what I added to my windows 10 after a clean install,

 

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\

then in the right hand pane do new REG_WORD and apply this name, AllowInsecureGuestAuth then modify the value to 1

Thankyou!! However I might need your help to find where to navigate to for that path?

 

56f59d3769af5_Capture.jpg

Link to comment
Share on other sites

geaves

Sorry you want HKEY_LOCAL_MACHINE,

 

Just to test I have installed Emby on my W10, with that reg key in place when I do add media, then add folder, click on network it finds all pc's and shares on the network.

Edited by geaves
Link to comment
Share on other sites

JestersDance

So I added the registry note as you mentioned. Did a restart, and am still having the same issue.

If i try to find my server through 'Network' nothing is there.

If I enter the UNC path/IP path, i get the error message:

'There was an error adding the media path. Please ensure the path is valid and the emby server process has access to that location.'

56f5a2082de59_Capture.jpg

Link to comment
Share on other sites

FrostByte

I have the icon, so I guess I am not running as a service! Is there any advantage to do so?

 

 

If you're running your daily desktop on the same machine then you're probably best to just leave it as is.  The biggest advantage of running as a service is that you don't have to be logged on for it to run, so it's nice for a headless server type of environment like a NAS or dedicated HTPC.

 

Hopefully the registry change does the trick

Link to comment
Share on other sites

geaves

So I added the registry note as you mentioned. Did a restart, and am still having the same issue.

If i try to find my server through 'Network' nothing is there.

If I enter the UNC path/IP path, i get the error message:

'There was an error adding the media path. Please ensure the path is valid and the emby server process has access to that location.'

56f5a2082de59_Capture.jpg

 

OK....that is odd....in file explorer left hand pane network anything under there?

 

Another option, Control Panel, Programs and Features, Turn Windows features on or off....check SMB1.0/CIFS File Sharing Support

 

Sorry another option, Control Panel, Network and Sharing Centre, Advanced sharing settings, check Turn on network discovery, and check Turn on automatic setup of network-connected devices.

Edited by geaves
Link to comment
Share on other sites

JestersDance

OK....that is odd....in file explorer left hand pane network anything under there?

 

Another option, Control Panel, Programs and Features, Turn Windows features on or off....check SMB1.0/CIFS File Sharing Support

 

Sorry another option, Control Panel, Network and Sharing Centre, Advanced sharing settings, check Turn on network discovery, and check Turn on automatic setup of network-connected devices.

 

So, The NAS isnt showing under network on either of my Windows 10 machines (my server HTPC or my general laptop)!

I went to programs and features but that option was already checked.

 

arrggggh! :)

Link to comment
Share on other sites

geaves

So, The NAS isnt showing under network on either of my Windows 10 machines (my server HTPC or my general laptop)!

I went to programs and features but that option was already checked.

 

arrggggh! :)

 

Pants!! I would have thought that was it.....BTW what's the NAS? I'm on nas4free, I must admit until I added that reg key I was having all sorts of issues....on file explorer if type in \\nas4free.local it appears under network, but Emby doesn't that entry...

 

Cheeky question...they are all in the same workgroup  ;)

 

I found this which my W10 is set too

Edited by geaves
Link to comment
Share on other sites

JestersDance

doing a bit of googling it seems this (NAS not showing under 'network') is a very common issue.

Link to comment
Share on other sites

geaves

doing a bit of googling it seems this (NAS not showing under 'network') is a very common issue.

 

It is, when I just did the W10 upgrade, it was fine, then I had a HDD failure so decided to install a clean W10, and that's when all the googling started, but finally got it sorted, but it might have been a combination of various solutions.

 

All my networking is Linux which I am still learning, multi function printers take some setting up...no plug and pray with Linux... :P

Link to comment
Share on other sites

JestersDance

Similar happened to me. All was working fine, then I did a reformat last week now it wont find the NAS!

Link to comment
Share on other sites

Happy2Play

Because the upgrade carried over most of the settings from the previous OS, and the clean install starts from scratch.  Everyone will feel the pain when they have to or do a clean install.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...