Jump to content


Photo

External Network Path Substitution for Kodi Emby

external network kodi embed path substitution

  • Please log in to reply
4 replies to this topic

#1 etern1ty OFFLINE  

etern1ty

    Newbie

  • Members
  • 1 posts
  • Local time: 11:19 PM

Posted 08 January 2016 - 01:51 AM

Hi,

 

I have my server for Emby running locally on a Fedora 23 machine, ports forwarded and local networking is fine.

I can reach the server website from my external IP address from outside my network and everything loads.

I have set up the transcoding/streaming bit rate to be low enough to test streaming despite internet quality.. However I cannot access the media outside of my network. 

 

Going through the Kodi Logs (on an external network) its apparent that the Kodi installation isn't looking for the media on my server at a different location however its currently looking at "/mnt/data/Videos/.." on the Kodi machine, whilst the actual data is at a location such as 192.192.192.192:/mnt/data/Videos/..

 

Would i utilise path substitution here? or would that interfere with the transcoding and streaming performance? If i do use PS, how would i go about setting that up? ( i considered FTP or NFS.. but then security question is raised as I'm unsure how you'd have a login for either with the Emby for Kodi add-on).

 

Regards,

Jeremy



#2 pcgirl OFFLINE  

pcgirl

    Advanced Member

  • Members
  • 44 posts
  • Local time: 10:19 AM

Posted 20 January 2016 - 10:01 AM

So, how are you accessing your Emby server externally?  By using a browser?  Go to http://app.emby.medi...nnectlogin.htmland login using your Emby account information.  You should then see your Emby Server.  Click that and you should have all your media to view. 



#3 Vidman OFFLINE  

Vidman

    Advanced Member

  • Alpha Testers
  • 2662 posts
  • Local time: 11:19 PM

Posted 20 January 2016 - 10:11 AM

In Emby for kodi settings you need to use http instead of smb for remote access

#4 Mdrodge OFFLINE  

Mdrodge

    Member

  • Members
  • 25 posts
  • Local time: 04:19 PM

Posted 29 October 2016 - 09:40 PM

I have the same issue. I've tried just about every thing. in the manual ip box I can set the external address but it just reverts to the internal (fair enough)
In the network credentials box I've added the external ip and every thing seems to go well (did I need the http: at the start or :8096 at the end?)(because i just put the address)(if so maybe a area with some help info wouldn't go a miss)

#5 Mdrodge OFFLINE  

Mdrodge

    Member

  • Members
  • 25 posts
  • Local time: 04:19 PM

Posted 30 October 2016 - 01:34 PM

ok I've tried every variation of setting and I've been working on this for 36 hours now. the only thing I haven't tried is smb.





Also tagged with one or more of these keywords: external, network, kodi, embed, path, substitution

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users