Jump to content
tmataraza

Emby not workin on DLNA device

Recommended Posts

Luke

Thanks for the info.

Share this post


Link to post
Share on other sites
dack64

After the last update (4.0.2), the LG TV(Netcast) does not detect the DLNA server. It only helps to turn off and turn on the DLNA server, after turning off the TV, everything repeats.

Share this post


Link to post
Share on other sites
Luke

After the last update (4.0.2), the LG TV(Netcast) does not detect the DLNA server. It only helps to turn off and turn on the DLNA server, after turning off the TV, everything repeats.

 

Hi there @@dack64, can you please attach the emby server log? thanks.

Share this post


Link to post
Share on other sites
Luke

I assume my issue running Roon and Emby on the same box/QNAP is not going to be addressed until .net core 3.0?

 

https://community.roonlabs.com/t/roon-server-udp-1900/58299/10

 

That's correct, please see here for technical explanation:

 

https://emby.media/community/index.php?/topic/61265-error-dlna-error-in-beginlisteningforbroadcasts/page-2&do=findComment&comment=670391

 

You CAN still use Dlna with Emby Server in the meantime, but it will require you to shutdown all other dlna software on the server machine.

Share this post


Link to post
Share on other sites
dack64

Hi there @@dack64, can you please attach the emby server log? thanks.

20.01.2019 - 19:22 il restart dlna, after that LG TV discover it.

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback.

Share this post


Link to post
Share on other sites
JAAlperin

Still desperately seeking a version of Emby server that will work with all my devices.  Please see prior posts in this topic for past efforts and results.

 

Thought I had a good thing going with 3.5.2 on DietPi.  It worked properly with my Oppo, my WD TV Live, and my various Rokus.  But, the Emby server kept quitting, and I have not been able to pin down the cause.

 

So, back to FreeNAS.  Installed 4.1.0.1.  All devices are working, but regardless of which TV episode I select, the Oppo will play the first episode of that season.  Happens for all TV shows, only on Oppo BDP-93.  Browser, Rokus, WD TV all play properly.  No problems yet found with movies.

 

So, watched TV series tonight using 3.3.1.

 

Both FreeNAS and Emby used to be rock solid, but recent releases of both are giving me fits.

Share this post


Link to post
Share on other sites
JAAlperin

Reported above that Oppo BDP-93 requests episode 4 from 4.1.0.1, but gets/plays episode 1.  Makes no difference what TV show or season, Oppo always gets the first episode of the season.  Other devices do not show this problem.  Log attached. Please see 2019-01-22 08:34:44.048 and following.

Emby4101DLNAlog.txt

Edited by JAAlperin

Share this post


Link to post
Share on other sites
Luke

I'll have to get an oppo in order to test this personally.

Share this post


Link to post
Share on other sites
JAAlperin

Thanks, Luke.

 

Can I give you access to test on my network (see the actual failing devices)?

Share this post


Link to post
Share on other sites
Luke

No it's best for me to just get an oppo. Thanks.

Share this post


Link to post
Share on other sites
JAAlperin

Hi Luke.

 

4.1.0.1 did not stream to Oppo BDP-93, but 4.1.0.2 does.  And, all my other devices seem to be working (WD TV Live, various Roku, Chrome browser).  First time in a while that It is all working again.  Thank you!

 

I'm running Emby in iocage plugin jail on FreeNAS 11.2-U1.  Used the setup for beta provided here: https://github.com/bott0r/iocage-plugin-emby (reads 4.1.0.1, but installs latest = 0.2).

 

But, I'll watch this for a bit before I delete 3.3 in the warden jail.

 

Roku causes transcoding due to unsupported subtitle streams.  Any easy way to stop that (short of removing the subtitles from the media)?

 

###########################################

 

Sorry - Oppo plays first episode of TV season regardless of which is selected.

Edited by JAAlperin

Share this post


Link to post
Share on other sites
Luke

Well no changes were that would affect dlna but thanks for the info.

 

Please open a topic in the Roku section. Thanks.

Share this post


Link to post
Share on other sites
JAAlperin

Hi Luke.

 

Recapping my current situation:

3.3 works with my Oppo BDP-93, but not Roku (Emby app reports server version too old).

4.1.0.2 works with Roku but not Oppo (endlesly loops while connecting?).  Works with WD-TV Live, but disconnects about once an hour.

 

I presume you have not been able to test with an Oppo.  If you won't test on my network, can I send an Oppo to you?

 

Is it possible to install old versions of the Emby app on a Roku?

Share this post


Link to post
Share on other sites
Luke

4.1.0.2? If you're running the beta server then i would make sure to stay on the latest. You're a little behind now. Thanks.

Share this post


Link to post
Share on other sites
JAAlperin

Thanks, Luke.

 

As before, 4.1.0.8 plays first episode of season on Oppo BDP-93 instead of requested episode (request s06e03, get s06e01).  This is consistent for all TV shows tested.

Share this post


Link to post
Share on other sites
Luke

And 4.1.0.2 is really different? That's just bizarre because there aren't any dlna changes between those two versions.

Share this post


Link to post
Share on other sites
JAAlperin

Hi Luke.

 

Sorry for any confusion, but no.  4.1.0.2 is not different.  The problem reported for 0.8 had been previously reported for 0.2.  You pointed me toward a new release, and I tried to say I still had a problem ("As before").

 

I am reiterating in hopes of keeping my issues alive.  For me, Emby has been problematic for months (remote Roku stopped working because app reported server version too old, eventually upgraded server when FreeNAS iocage plugin became available, and BDP-93 has had various DLNA problems since.)  Running MiniDLNA is a letdown after years of Mediabrowser and Emby.

 

Two unanswered questions, please:

Can I somehow backlevel the Roku app to a version that will accept the 3.3 Emby server?

If you have no access to an Oppo BDP-93, and will not test via remote access to my network, do you want me to send you an Oppo or testing (I have no idea where you are located or what it would cost)?

 

Do you want logs again for the "plays first episode" issue?

 

Thank you for your help, and for Emby.

Share this post


Link to post
Share on other sites
Luke

I'm looking into these issues, thanks.

Share this post


Link to post
Share on other sites
JAAlperin

Anything, Luke?

Share this post


Link to post
Share on other sites
Luke

Sorry, not yet. this is an eight year old device and it will be a little more work to accommodate than newer devices. Thanks.

Share this post


Link to post
Share on other sites
JAAlperin

Thanks, Luke.

 

But, the eight year old device runs a standard, albeit old, version of DLNA, and was working perfectly in previous versions of Emby.

Share this post


Link to post
Share on other sites
JAAlperin

Hi Luke.

 

I gather this will not be fixed (because my device is deemed too old).  Please confirm.

 

If you are still pursuing this and need an Oppo BDP-93, I renew my offer to send one.

Share this post


Link to post
Share on other sites
JAAlperin

Tried 4.1.0.16.  Still the problem that requests from the BDP-93 for episodes other than the first of a TV season will play the first episode.  Interestingly, this is not true for season 1, which plays all episodes properly.  This phenomenon is consistent for all TV series that I tried.  I did a "replace metadata" scan, but the problem persists.  So, no joy here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...