Jump to content


Photo

Emby not workin on DLNA device

freenas dnla video formats

  • Please log in to reply
72 replies to this topic

#1 tmataraza OFFLINE  

tmataraza

    Newbie

  • Members
  • 1 posts
  • Local time: 10:21 PM

Posted 12 December 2015 - 10:02 PM

  • I have a samsung smart tv and a denon avr-e300 home theater receiver that both are DLNA ready. I have emby server installed on a FREENAS server with a static IP. The Server, TV and receiver are all networked and have Static IPs. Emby works beautifully on all my devices using the webserver IP except on the DLNA devices. It says the video files are music files, then error out when I try to play them. I have tried .mkv and .mp4. What other file
  •  
    type should I use?


#2 cyrille_v OFFLINE  

cyrille_v

    Newbie

  • Members
  • 1 posts
  • Local time: 06:21 AM

Posted 13 May 2016 - 05:53 PM

I have same problem. Latest version of emby server installed on FreeBSD 10.2, Can browse media folders from iPhone and pc browser. Can switch and play on both, but my

DLNA compatible Pioneer player does not see emby server, Also embry server does not see Pioneer DLNA player. All od devices are with static IPs.

Any suggestion and ideas?  



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 13 May 2016 - 06:16 PM

I have same problem. Latest version of emby server installed on FreeBSD 10.2, Can browse media folders from iPhone and pc browser. Can switch and play on both, but my

DLNA compatible Pioneer player does not see emby server, Also embry server does not see Pioneer DLNA player. All od devices are with static IPs.

Any suggestion and ideas?  

 

For the upcoming server release there is a fix for the Play To feature that will allow Emby to see the device.



#4 wkl_lau OFFLINE  

wkl_lau

    Newbie

  • Members
  • 7 posts
  • Local time: 11:21 PM

Posted 22 October 2016 - 04:49 PM

Same here, I have been looking for a good media server for home. Right now I am using Universal media server because it can stream to all DLNA device but the web interface looks unrefined. I really want switch to Emby and so far it satisify all my requirement, But it cannot stream to my Pioneer XV-BD717W player. I have the same experience with Plex (Emby is developed from plex I think?)

 

I am using EMBY version 3.0.8300.0 (latest as of Oct 22) and due to this limitation I am keeping it in a test machine and won't switch until the DLNA issue is resolved.



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 22 October 2016 - 04:51 PM

Emby is developed from Emby :)

 

Thanks for the report. We are looking into it.



#6 wkl_lau OFFLINE  

wkl_lau

    Newbie

  • Members
  • 7 posts
  • Local time: 11:21 PM

Posted 12 September 2018 - 08:14 AM

Hello it has been 2 years since my last reply. Emby still not working with my Pioneer XV-BD717W. Right now I am using Emby 3.5.2. When trying to browse Emby's media library from the device, It give me network errors,

 

I attach Emby's Log.

 

if you need anything else please let me know. 

 

Thx

Attached Files


Edited by wkl_lau, 12 September 2018 - 08:15 AM.


#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 12 September 2018 - 02:51 PM

Hi, what this means is that we're probably sending back a response that the Pioneer doesn't like. Unfortunately I don't have a Pioneer receiver for testing so it's difficult to say what that might be. Hopefully there is a knowledgeable community member who can help track this down. Thanks !



#8 wkl_lau OFFLINE  

wkl_lau

    Newbie

  • Members
  • 7 posts
  • Local time: 11:21 PM

Posted 12 September 2018 - 09:51 PM

is there anything I can do to help? Any other test or log I can provide? Wireshark?  Emby is close to perfection except DLNA. 



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 12 September 2018 - 11:54 PM

In this situation what i'll generally do is compare the responses we're sending back to that from another application that is working.



#10 wkl_lau OFFLINE  

wkl_lau

    Newbie

  • Members
  • 7 posts
  • Local time: 11:21 PM

Posted 13 September 2018 - 03:13 PM

Hi I plug my server and client (win10 using WMP as DLNA client) in a private VMnet and connection is successful. Here is the log.

 

BTW, do I HAVE TO assign a profile? Will generic profile work?

Attached Files


Edited by wkl_lau, 13 September 2018 - 10:15 PM.


#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 13 September 2018 - 10:34 PM

Unfortunately that's different. That won't tell us what the Pioneer doesn't like about our communications.



#12 wkl_lau OFFLINE  

wkl_lau

    Newbie

  • Members
  • 7 posts
  • Local time: 11:21 PM

Posted 13 September 2018 - 10:50 PM

OK, so what else you need to debug? I mean the pioneer almost accept all DLNA source, Universal media server, native Windows media player DLNA, etc The only 2 server it has problem with is Plex and Emby.

 

Please tell me what else can I do



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 24 September 2018 - 11:44 PM

I will need to try and find a developer with a Pioneer receiver who can help us. Thanks.



#14 wkl_lau OFFLINE  

wkl_lau

    Newbie

  • Members
  • 7 posts
  • Local time: 11:21 PM

Posted 27 September 2018 - 11:35 PM

Thanks, today I notice something else. today I promote my test server to be a domain controller (install Server essential experience - which makes it a DC) and Emby no longer seen by my pioneer. Not sure if this is related.

 

Thx



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 28 September 2018 - 12:32 AM

What are the differences in the network?



#16 wkl_lau OFFLINE  

wkl_lau

    Newbie

  • Members
  • 7 posts
  • Local time: 11:21 PM

Posted 28 September 2018 - 11:39 PM

No change in the network, IP is the same, 

 

I used UPnP tools from http://www.meshcommander.com/upnptools and run device spy. it doesn't see it

however, if I run UpnpScanner (http://alax.info/blog/257) it will see it.



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 29 September 2018 - 11:10 PM

Can you try rebooting the Pioneer with Emby Server running?



#18 gruni OFFLINE  

gruni

    Newbie

  • Members
  • 4 posts
  • Local time: 04:21 AM

Posted 21 December 2018 - 12:02 PM

My problem is similar:
After restarting Emby Server my pioneer N-50a see Emby DLNA. Switching pioneer off for a while, it will not find Emby DLNA again. Server alive every 10 sec. Makes no change, I have to restart Emby. My iPhone-APP 8playerPRO shows the same issue. QNAP DLNA, music station and so on is switched off. Emby Server is 3.6.0.80.

A simple option to adjust DLNA folder structure similar to Twonky will be very fine as well. 10 entries in 4 Lines of my network player are not useful, for example I need only songs and playlists after entering Dlna menue.

#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121612 posts
  • Local time: 11:21 PM

Posted 21 December 2018 - 11:49 PM

What version of Emby Server?



#20 gruni OFFLINE  

gruni

    Newbie

  • Members
  • 4 posts
  • Local time: 04:21 AM

Posted 22 December 2018 - 07:39 AM

emby-server-qnap_3.6.0.80_x86_64







Also tagged with one or more of these keywords: freenas, dnla, video formats

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users