Jump to content
NahsiN

3D movies not playing in 2D/3D mode over http

Recommended Posts

NahsiN

Hi, I am running Kodi 15.1 with Emby 1.1.13. I am trying to play a 3D movie in 2D/monoscopic mode but it's not working. In Kodi, the 3D icon is shown next to the movie and looking in the metadata manager, I can see Emby has correctly marked this movie as 3D. When I am on the same network and "Play from http instead of SMB" option is unchecked in plugin settings, Kodi gives me a choice between 2D/3D and everything is fine. But when I am connecting to my server over the Internet and I have checked the "Play from http instead of SMB" option or I have this option checked and I am on the same network, the movie is not being detected as 3D in Kodi and it just plays as is. My two cents is that the 3D status of the movie is being detected by Kodi from the filename (which works over smb but not http) instead of an entry in MyVideo93.db (I assume this is where the 3D icon is coming from). I should also note I am using https. Please chime in...

Share this post


Link to post
Share on other sites
Angelblue05

The 3D tag does come from the filename. It is included in the path. However, I'm not certain what we can do about direct streaming, I'll have to see what our options are.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
NahsiN

Then what is the use of that 3D icon? It is still being displayed which means in the mysql database, there must be some sort of a field indicating if the movie is 3D or not.... Anyways that then becomes a Kodi issue and I have created a thread there also. Let's wait and see

Edited by NahsiN

Share this post


Link to post
Share on other sites
tjalfe

Hi,

 

I'm experiencing this also with my 3d movies.

If i add them to kodi directly, i get asked about the 3d setting i want to use, but when using Emby for kodi, i'm never asked.

 

Any work being done on this? I use HTTP streaming since i often travel, i like having a rpi in my bag ready for some streaming.

 

I assume that when starting a movie using the HTTP version, it tells kodi to stream from http://IP:PORT/SomEThinGWeryLongAndComPliCaTed

Maybe just adding a 3d or 3d-hsbs depending on the source to the end of that streaming URL would make Kodi detect it as 3d source?

 

//TjaLfE

Share this post


Link to post
Share on other sites
Marix91

Hi,

 

I'm experiencing this too. Is there a way to handle this or to update the emby for kodi addon?

 

Or is there a way in the normal android emby app to switch between 2D and 3D? - I use the "outside of my home" function a lot - especially for my sister and it would be nice if i didn't had to provide my 3d movies as a 2d mkv.. and block my hdd space by that.

 

It would be so kind of you, if you could send me a tutorial or solve this for http in the emby addon for kodi :)

 

Excuse me if i ask questions which were solved before, but i didn't find any answer yet, that solved my problem...

 

Marix91

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...