Jump to content

"Dummy" video sources in Kodi = normal?


cw-kid
 Share

Recommended Posts

cw-kid

No it just means your database was locked when we tried to commit. You should not be moving in the UI or entering any menus, while the scan is going because Kodi will try to load from the database while we are still writing to it, and you get this error.

So what about in normal operation? Your gonna want to be launching Kodi and then browsing around the UI right away to select something to play whilst the start up sync is happening in the background. Its actually the first time I've seen this DB is locked in the logs though.

Link to comment
Share on other sites

cw-kid

Although saying that my actual HTPCs go in to S3 sleep mode so when turned on or woken Kodi doesn't actually launch as its always open unless I have to reboot them, so would the Emby startup sync even run? Probably not.

Link to comment
Share on other sites

Angelblue05

I meant you can get this error. It does happen, very rarely but it's really out of our control. You can do whatever you'd like during the start up sync :) It's just during the initial sync, it's more risky because as I mentioned in another post, if the initial sync does not complete, it will keep trying everytime you restart Kodi until it suceeds. So if you get the error, you basically have to restart Kodi so it relaunched the sync.

 

It does start a sync when the device wake up from sleep.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

cw-kid

Hi @@Angelblue05 @@marcelveldt

 

I just uninstalled the Emby beta repo and installed the Emby stable repo instead, I also uninstalled the Emby add-on and then installed version 1.1.13 and now the music sync is working again after a DB reset and the music library is back now. 

 

Main reason to try this is I wanted to also install the Arctic Zephyr Exploded skin which is in the Emby stable repo. 

 

I wonder what would happen if I then uninstalled the stable repo and went back to the beta one or installed the latest version of the add-on from Github, would the music sync stop working again?

 

Many Thanks

Link to comment
Share on other sites

cw-kid

 

On version 1.1.13 after closing and opening Kodi several times the music library was still there and working OK. 

 

I then installed the latest version of the add-on from Github v1.1.24 it then ran a sync after the add-on had updated and now the sync is timing out at the end of the TV Shows section. (I removed the "Music Videos" from the Emby Server library) and since then the sync has been timing out on the TV instead. 

 

After it times out and pops up with "Compressing" the music library has gone again and cannot be seen. 

 

I am as yet not using the new Fast Sync plug-in and that option is turned off in the add-on settings. 
Link to comment
Share on other sites

Angelblue05

Please post the log timing out, just set addon debug to info should be enough without creating a huge log. We'll check it out - i'll be back later.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

cw-kid

Here's a snipet from the log -  1.1.24 getting stuck on the TV section of the sync and not progressing on to the music part of the sync. 

14:43:26 T:3592   ERROR: XFILE::CDirectory::GetDirectory - Error getting

14:43:49 T:3256  NOTICE: EMBY DownloadUtils -> logMsg : Server unreachable at: http://192.168.x.x:8096/mediabrowser/Users/9f71a703f1e34ea1b496def85fac38d3/Items?Fields=Etag,Path,Genres,SortName,Studios,Writer,ProductionYear,Taglines,CommunityRating,OfficialRating,CumulativeRunTimeTicks,Metascore,AirTime,DateCreated,MediaStreams,People,Overview&Recursive=true&IncludeItemTypes=MusicAlbum&format=json

14:43:49 T:3256  NOTICE: EMBY DownloadUtils -> logMsg : HTTPConnectionPool(host='192.168.x.x', port=8096): Max retries exceeded with url: /mediabrowser/Users/9f71a703f1e34ea1b496def85fac38d3/Items?Fields=Etag,Path,Genres,SortName,Studios,Writer,ProductionYear,Taglines,CommunityRating,OfficialRating,CumulativeRunTimeTicks,Metascore,AirTime,DateCreated,MediaStreams,People,Overview&Recursive=true&IncludeItemTypes=MusicAlbum&format=json (Caused by ReadTimeoutError("HTTPConnectionPool(host='192.168.x.x', port=8096): Read timed out. (read timeout=30)",))

Will try and post a full log file soon. 

 

 

Thanks

 

Link to comment
Share on other sites

Angelblue05

@@cw-kid

 

How many artists do you have, roughly? I'm curious, might be that pulling the entire list just takes longer than 30 seconds (it's maybe hitting the timeout limit before we get a response back from the server.) Checking to see what we can do.

Edited by Angelblue05
Link to comment
Share on other sites

cw-kid

... Album Artists but there will be way more if you include individual artists tagged on compilation albums.

Thanks

Edited by cw-kid
Link to comment
Share on other sites

Angelblue05

Did you try 1.1.25 to see if your music sync completes? Thanks, let me know!  :)

Edited by Angelblue05
Link to comment
Share on other sites

cw-kid

Updated the add-on, the scan that runs immediately after updating the add-on, has now been stuck on Music Albums 99% for a very long time. 

Link to comment
Share on other sites

Angelblue05

which is normal, it's pulling all of your songs right now. Unless it specifically says in your log that it's timing out, it's still running.

Link to comment
Share on other sites

Angelblue05

Indeed :) I also added a stat to calculate the time of the initial sync/start up sync so the log will tell you exactly how long it took to complete.

Link to comment
Share on other sites

cw-kid

The sync has now completed. The music library is now present and seems to be accessible. 

 

This is the log file here for it, it may also contain entries referring to v 1.1.13 as I didn't close Kodi before installing v 1.1.25 etc. 

 

Fingers crossed then! I will close and open Kodi a few time now see what happens and if the music library remains present? 

 

Cheers

 

 

 

 

 

 

  • Like 1
Link to comment
Share on other sites

Angelblue05
NOTICE: EMBY LibrarySync -> Doing_Db_Sync: syncDatabase (Finished in: 0:41:18) True

It should be good :) It completed! It took 41min 18secs to sync your entire music library. Crazy! But still faster than if Kodi did it lol...

 

Hopefully there's not too many database modifications coming.... but the good news is if you use the same Kodi version across many devices you can always copy the database files over to each, this way you don't need to endure the initial sync more than once per emby user.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

cw-kid

After closing Kodi and re-opening it, the subsequent start up scans seems to take just as long as the initial sync, not sure if that is expected? 

 

Again it seems to hang on 99% "Music Albums" section of the scan for a long time and then eventually progresses on to the "Music Songs" part of the scan. 

 

So maybe now I can move on and start testing the new Fast Sync plug-in as well. 

 

Many thanks for your time and patience with me :lol:

Link to comment
Share on other sites

xnappo

Depends on the device - it could be normal but post a log to be sure.

 

Certainly the fast startup sync will fix it - but it might also mask another problem - so do post a log before switching to it.  Once you switch you will not want to go back :D

  • Like 1
Link to comment
Share on other sites

cw-kid

OK let me post another log after closing and opening Kodi and whilst its doing its startup sync. 

 

I am testing on my Windows 7 laptop which is an Intel Gen1 i5 with 4GB of RAM and a wired Gigabit network connection. 

Link to comment
Share on other sites

cw-kid

I guess I can live with slow long sync's as long as they are working, which they appear to be at the moment. 

 

When it did eventually move on to "Music Songs" it seemed to rattle through them pretty quickly. 

 

Here is the log for the last start up sync. 

 

http://xbmclogs.com/p4yqotqze

Link to comment
Share on other sites

xnappo

That looks like it took a really long time.  Like 20 minutes?  If you have a huge music database - maybe that is okay, but we might need a log with more detail turned on to be sure.

 

Again - the fast sync plugin will resolve this for sure - I just want to be sure it isn't thinking it needs to update items that don't really need to update.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...