Jump to content

Arch Linux


Luke

Recommended Posts

wilberfan

Brand-new Emby install on a brand-new Arch Linux box.  I have a Chromecast on my Vizio monitor.  I'm only seeing a Chromecast option on the Emby app under Android--both the Server and a laptop only have an option that says, "My Device/Emby".  

Is there a setting I've missed?

 

Is there an option to hardwire the server to the Vizio (ie, HDMI cable) so as to not have to play stuff via the Chromecast?

Link to post
Share on other sites
wilberfan

What's wrong with Chromecast?

Well, maybe nothing...I'm not sure yet.  Can it handle 1080p stuff over a 5Ghz wireless?

 

Also, my missing Chromecast option was a browser issue.  (Duh.)  

Link to post
Share on other sites

Well, maybe nothing...I'm not sure yet.  Can it handle 1080p stuff over a 5Ghz wireless?

Yes that should be fine.

Link to post
Share on other sites
  • 2 weeks later...
NErdgOd56

will we be getting the 4.2 update in the official repo soon? 4.1.1.0 gave me a few problems im not willing to go back to and the 4.3 beta from aur is exiting every day or two on its own (with no error code-- almost like im running `systemctl stop emby-server` which im not) i dont have time to find out why currently

 

Edit: i just realized the beta updated to 4.3.0.1 only yesterday, so i guess it was 4.2.0.40 crashing every few days. running the 4.3 beta right now will report back if it exits again

Edited by NErdgOd56
Link to post
Share on other sites

will we be getting the 4.2 update in the official repo soon? 4.1.1.0 gave me a few problems im not willing to go back to and the 4.3 beta from aur is exiting every day or two on its own (with no error code-- almost like im running `systemctl stop emby-server` which im not) i dont have time to find out why currently

 

It should be available soon. Thanks.

Link to post
Share on other sites
NErdgOd56

4.2.0.40 has been in the official repositories for about a week, no issues to report here.

ok, i think i actually had a mirror problem or something. i refreshed the mirror list and switched back to worldwide in pamac and got 302 updates all the sudden. sorry for the thread clutter lol

Link to post
Share on other sites
  • 2 weeks later...
sekondchakra

Is it possible to move all of the Emby "system" data (ie, everything in /var/lib/emby) to somewhere else...?  I think I would prefer not to fill up my / partition if I can avoid it.  

 

I've changed the cache to /storage/embycache/ via the GUI already...

Edited by sekondchakra
Link to post
Share on other sites

Is it possible to move all of the Emby "system" data (ie, everything in /var/lib/emby) to somewhere else...?  I think I would prefer not to fill up my / partition if I can avoid it.  

 

I've changed the cache to /storage/embycache/ via the GUI already...

 

No, but if you change the cache, metadata and transcoding temp folders then the remaining folders shouldn't use too much space.

Link to post
Share on other sites
sekondchakra

No, but if you change the cache, metadata and transcoding temp folders then the remaining folders shouldn't use too much space.

 

Do I have to manually do something to move the cache--other than specify the new location in Advanced?   Nothing has populated yet.  Does it take awhile on it's own?

Link to post
Share on other sites

Do I have to manually do something to move the cache--other than specify the new location in Advanced?   Nothing has populated yet.  Does it take awhile on it's own?

 

Nothing gets moved. You can move the contents of the previous folder if you like, but you don't need to.

Link to post
Share on other sites
  • 1 month later...
sekondchakra

How could a log file end up being over 300 MBs in size??  I had some yesterday that were even larger.  (I had a total of 2.5 GBs of logfiles!)   

I just opened the largest one (below) (It took 3 or 4 minutes to load completely.  :  348,360 lines of entries

 

Here's a line chosen at random:  

2019-10-02 19:59:50.412 Info HttpServer: HTTP Response 200 to 192.168.1.107. Time: 2ms. http://192.168.1.129:8096/emby/videos/4541/hls1/main/1091.ts?DeviceId=6af3e277-41fa-5cf9-861f-7dd74c07f9a7&MediaSourceId=1d39a829a8d30fe71597b8d9f228c840&PlaySessionId=e202cefd393b46ebab58e7957e532dce&VideoCodec=h264,mpeg1video,mpeg2video,hevc&AudioCodec=aac,mp2,mp3,flac,opus,vorbis,lpcm&VideoBitrate=109616000&AudioBitrate=384000&MaxFramerate=61&MaxWidth=3840&MaxHeight=2160&AudioStreamIndex=1&SubtitleStreamIndex=2&SubtitleMethod=Encode&TranscodingMaxAudioChannels=2&SegmentContainer=ts&SegmentLength=3&MinSegments=1&BreakOnNonKeyFrames=True&h264-maxrefframes=16&h264-videobitdepth=8&h264-profile=high,main,baseline,constrainedbaseline&h264-level=51&aac-audiochannels=2&flac-audiochannels=2&lpcm-audiochannels=2&mp3-audiochannels=2&mp2-audiochannels=2&vorbis-audiochannels=2&opus-audiochannels=2&TranscodeReasons=AudioCodecNotSupported

"Enable debug logging" is NOT selected.  And "rotate log file" is set for DAILY at 10:30pm.

 

 

5d96c849f35f9_323MB.png

Edited by sekondchakra
Link to post
Share on other sites
sekondchakra

I'm willing to show you whatever/wherever I can...   What features would you be interested in, particularly?  

 

I noticed that when the logs are "rotated", the large (323.5 MB) .txt file wasn't deleted, there was just a NEW one created.  The new one is already 286.8 MB itself...

Link to post
Share on other sites
sekondchakra

Can we please look at an example? thanks.

How much of the log do you want to see?  I'm assuming most paste sites have a size limit?  The current log is 700 MB.

Edited by sekondchakra
Link to post
Share on other sites

How much of the log do you want to see?  I'm assuming most paste sites have a size limit?  The current log is 700 MB.

 

Ideally all of it since the issue you're reporting is log size. What about something like dropbox or google drive?

Link to post
Share on other sites
sekondchakra

So Roku is playing back the whole time. Is that correct?

 

In a practical sense, yes.  (I might pause occasionally.  Stop between programs and take a leak, get something to drink, etc.)

 

By the way, 'm using the Roku Emby Beta app (channel?) and the latest Emby Beta server (on Arch Linux).  

Edited by sekondchakra
Link to post
Share on other sites
sekondchakra

In addition to my gi-normous logfiles (above), I've started having an issue with the Roku Emby (beta) channel (app?) crashing/quitting after deleting a local video file and trying to return to the Emby dashboard via the 'back' button on the Roku remote.   I don't know if it's the Roku, the emby-server, or the Emby app/channel--but it started happening a couple of server beta releases ago.  

Link to post
Share on other sites
  • 1 month later...
sekondchakra

I've started having an issue with the Roku Emby (beta) channel (app?) crashing/quitting after deleting a local video file and trying to return to the Emby dashboard via the 'back' button on the Roku remote.   I don't know if it's the Roku, the emby-server, or the Emby app/channel--but it started happening a couple of server beta releases ago.  

 

This seems to have been resolved a few iterations ago, but just returned after updating to v4.3.0.26 tonight.  

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...