Jump to content

Unable to connect to emby using domain name


codyclayborn1
 Share

Go to solution Solved by Luke,

Recommended Posts

codyclayborn1

Emby is running on windows

 

For starters I have recently moved to a new location after having my emby server accessible via its domain for a month or so.

I can access emby remotely with my WAN IP along with my HTTP port number (HTTPS port isnt working). Im using cloud flare as for my SSL and DNS provider. when I attempt to connect using my domain I get a Error 522 (cloud flare cant connect to my server) I have updated my WAN IP to the one ive been assigned by my ISP. Tried changing the ports being forwarded (80,443,8920,8096) I have rebooted my computer and emby multiple times and updated my DNS A name a few times as well.

 

AName: emby|MyWanIP   (Domain is being proxied by cloud flare)

 

Any tips on how to narrow down what is causing my issue? Could it be that my ISP is blocking the ports im using or is it cloud flare?

Link to comment
Share on other sites

Hello codyclayborn1,

** This is an auto reply **

Please wait for someone from staff support or our members to reply to you.

It's recommended to provide more info, as it explain in this thread:


Thank you.

Emby Team

Link to comment
Share on other sites

  • 3 weeks later...
pir8radio
On 9/15/2022 at 8:30 PM, codyclayborn1 said:

Emby is running on windows

 

For starters I have recently moved to a new location after having my emby server accessible via its domain for a month or so.

I can access emby remotely with my WAN IP along with my HTTP port number (HTTPS port isnt working). Im using cloud flare as for my SSL and DNS provider. when I attempt to connect using my domain I get a Error 522 (cloud flare cant connect to my server) I have updated my WAN IP to the one ive been assigned by my ISP. Tried changing the ports being forwarded (80,443,8920,8096) I have rebooted my computer and emby multiple times and updated my DNS A name a few times as well.

 

AName: emby|MyWanIP   (Domain is being proxied by cloud flare)

 

Any tips on how to narrow down what is causing my issue? Could it be that my ISP is blocking the ports im using or is it cloud flare?

cloudflare doesn't support 8920, or 8096, yea look through that link posted above, let us know how you make out.

  • Like 2
Link to comment
Share on other sites

  • 1 month later...
codyclayborn1

Issue Resolved.

Sorry for the long wait on the update. Turns out that at some point I must have used the locally signed cert instead of the cloudflare one. After the switch the issue was fixed immediately. I will note that I had to add the cloudflare root cert whilst converting my cert. I swore I had been using it when initially setting up my SSL on emby but I guess not.

 

Solution: Im a idiot, use the cloudflare cert properly.

  • Like 1
  • Haha 1
  • Thanks 1
Link to comment
Share on other sites

pir8radio

glad you got it fixed up!   Its all part of the tech fun!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...