Jump to content

Downloads stuck on "Ready to Transfer"


reap
 Share

Recommended Posts

Hi everyone,

since months I have the same issue like the person in this thread.

No matter what I do, everything I want to download gets stuck on "Ready to Transfer.
- tried multiple iPads & iPhones in my home
- tried to download in "Original" (that's what I actually want)
- tried to download in various qualities

Platform: Synology 718+ with DSM 7.0.1
Docker-Version: emby/embyserver - latest
Emby-Version: 4.6.7.0
iOS-Version: 2.1.5

Any help how to solve this is appreciated. I really want this to work before the upcoming vacation.

Thanks

 

embyserver.txt

Edited by reap
Link to comment
Share on other sites

  • 2 weeks later...
Happy2Play

Will post here but selecting Download on my iPhone appears to create the download to wrong device.  Shows the desktop not the device that requested the Download.

image.png.ddd6d180fdbdfdfe4f7bc96331ab1058.png

Doing a Download to from device will allow device selection and create correct Download to job but still hangs at Ready to transfer.

image.thumb.png.37167663f99d55b2e85cc5571e2b260a.png

Link to comment
Share on other sites

Essjay10

I have the same problem.

Edit: If i go to the downloads (not manage downloads) section in settings, it kicks off the download.

Edited by Essjay10
Link to comment
Share on other sites

  • 3 weeks later...
bradford
Posted (edited)

I also have this issue on Emby Theater on Windows 11. I don't understand what makes this a perennial issue. 

Edit: I found my problem was disk space was running out. The emby download progress bar was always at 0%, so that never updated to tell me it was downloading, and the error message that eventually came just said that the download failed, with no indicator it was because there was no disk space. I think the download manager should pre-allocate the required space BEFORE attempting the transfer, and fail with a proper error message if there isn't enough space. 

Edited by bradford
Link to comment
Share on other sites

  • 1 month later...
Happy2Play

Clicking Download on iPhone creates a job to the server sync folder not the device.  Clicking Download To and selecting the phone will converts but hangs at Ready to transfer.

Download button on iPhone (no download to option created this job)

image.thumb.png.6a6b0b0fe736e22fe7e9d2dc34d26e9e.png

image.png.7574a16184ff6881c386389c52dc86ac.png

Download To allowed device selection

image.thumb.png.bb91ed884db7484d7927bde91349d6b2.png

But still hangs at Ready to tranfer after converting job completes.

testing on 4.8.0.1

iOS 2.1.6

iPhone OS 15_5

 

Retested on New Clean portable 4.7.2.0 and do not see the Download button going to the Sync folder location, but do not have that plugin installed on this server or any other device connection history.  But still hangs at Ready to Transfer.

Another test Connected to another server (4.8.0.1) that had Android device and iPhone previously connected and Download on iPhone created a download job for the Android device.  So Download button goes rogue not auto selecting itself as the Download to location.  But still hangs at Ready to Transfer. 

Since there are multiple topics on Ready to Transfer, I can only guess there is a server issue here but don't see anything in the server log.

 

Link to comment
Share on other sites

warrentc3

I'm having an eerily embyserver_syncfail.txtsimilar issue.  Sync just seems to fall on it's face.

 

Downloading a season of Bluey for the kid to watch in the car... gets one or two episodes... then just constantly starts transfer, then fails, then restarts.

The log is full of these.

2022-06-17 06:56:13.587 Error Server: Error processing request
	*** Error Report ***
	Version: 4.7.2.0
	Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb
	Operating system: Linux version 5.15.35-1-pve (build@proxmox) (gcc (Debian 10.2.1-6) 10.2.1 20210110, GNU ld (GNU Binutils for Debian) 2.35.2) #1 SMP PVE 5.15.35-3 (Wed
	Framework: .NET 6.0.2
	OS/Process: x64/x64
	Runtime: opt/emby-server/system/System.Private.CoreLib.dll
	Processor count: 24
	Data path: /var/lib/emby
	Application path: /opt/emby-server/system
	MediaBrowser.Common.Extensions.ResourceNotFoundException: MediaBrowser.Common.Extensions.ResourceNotFoundException: Exception of type 'MediaBrowser.Common.Extensions.ResourceNotFoundException' was thrown.
	   at Emby.Server.Sync.Api.SyncService.Get(GetSyncJobItemFile request)
	   at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
	Source: Emby.Server.Sync
	TargetSite: Void MoveNext()

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...