Jump to content

Cannot remotely connect to Emby (port forwarding issue)


IggyPS
 Share

Recommended Posts

IggyPS

Hello, 

I have Emby Premiere, and I have issues with remotely connecting to my server. I've tested this with my more tech-savvy brother, but no luck so far. We tried everything, which is why I'm finally giving in and opening a thread about it in the hopes of someone helping me out.

I've read other threads about this, and the one most closely resembling my case is this one. However, the solution of that case does not look to be relevant in my case because I have no such "VOIP box OOMA". 

The issue is likely with port forwarding and not with Emby itself because I get an Error if I check the ports on https://www.canyouseeme.org, but I don't know where to start. I will give as much info as I can. 

My setup is like this:

Emby server running on my PC > Ethernet cable to a simple 5 port switch > Ethernet cable to my Router > Ethernet cable to my ISP modem

I have opened ports 8096 and 8920 on my Windows Firewall in both the Inbound Rules and Outbound Rules.

These are my Outbound Rules:

941895718_OutboundRulesEmby.thumb.PNG.2feef98f291916b5ae0c55c4b070803a.PNG   

These are my Inbound Rules:

42065862_InboundRulesEmby.thumb.PNG.6378d74da71e9352f769c081a7635144.PNG

 

I have also port forwarded both the 8096 and 8920 ports on my Router and ISP modem. 

The "Allow remote connections to this Emby Server." setting is ticked on.

So what gives? Any ideas are really welcome 😰

Edited by IggyPS
Added more information.
Link to comment
Share on other sites

Hello IggyPS,

** This is an auto reply **

Please wait for someone from staff support or our members to reply to you.

It's recommended to provide more info, as it explain in this thread:

Thank you.

Emby Team

Link to comment
Share on other sites

4 hours ago, IggyPS said:

I have also port forwarded both the 8096 and 8920 ports on my Router and ISP modem. 

The "Allow remote connections to this Emby Server." setting is ticked on.

So what gives? Any ideas are really welcome 😰

If you have an ISP routing with NAT and your own router with NAT you need to do this:

Port forward 8096 on the ISP router to port 8096 on your router.
On your router you setup port forwarding of 8096 to Emby IP port 8096

So you need to forward twice.

Open a command prompt. Do a tracert to 8.8.8.8 
PM me the results.  That will show you local IP/routing as well as your ISP routing and if they are using any private LAN IP ranges which will stop this from working.

  • Agree 1
Link to comment
Share on other sites

justinrh

You can remove the modem stuff if you can set the modem to pass-through mode.

Link to comment
Share on other sites

Yes, if you can set the ISP router to bridge mode it won't do any local LAN routing or NAT.  Then it's strictly your router doing those functions.

If you can't figure this out, send me a PM and I can do a remote session with you to help you get this setup and working.

Link to comment
Share on other sites

IggyPS
18 hours ago, cayars said:

If you have an ISP routing with NAT and your own router with NAT you need to do this:

Port forward 8096 on the ISP router to port 8096 on your router.
On your router you setup port forwarding of 8096 to Emby IP port 8096

So you need to forward twice.

Hm, not sure I understand this. I thought I already did this, but maybe not correctly?

18 hours ago, cayars said:

Open a command prompt. Do a tracert to 8.8.8.8 
PM me the results.  That will show you local IP/routing as well as your ISP routing and if they are using any private LAN IP ranges which will stop this from working.

Done! I have sent you the results via PM. 

 

17 hours ago, cayars said:

Yes, if you can set the ISP router to bridge mode it won't do any local LAN routing or NAT.  Then it's strictly your router doing those functions.

If you can't figure this out, send me a PM and I can do a remote session with you to help you get this setup and working.

Yeah I think that's a bit beyond my paygrade. I'd be happy to jump on a call and to it with your help. 

Link to comment
Share on other sites

Tracert looked ok but confirms the double NAT.

Let's setup a remote session.  I'll PM you.

Link to comment
Share on other sites

  • 2 weeks later...
IggyPS
Posted (edited)

So I called my ISP and explained the situation. I just had to change one IP address on the ISP modem in the Port Forwarding settings, and it solved the issue. Now I can watch Emby remotely! 🙂

@cayars tagging you for visibility. Thank you for all your help. 

 

Edited by IggyPS
Link to comment
Share on other sites

38 minutes ago, IggyPS said:

So I called my ISP and explained the situation. I just had to change one IP address on the ISP modem in the Port Forwarding settings, and it solved the issue. Now I can watch Emby remotely! 🙂

@cayars tagging you for visibility. Thank you for all your help. 

Awesome, glad they got this done for you!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...