Jump to content

Emby Server for DSM7 Now in Synology Package Center


Luke
 Share

Recommended Posts

2 hours ago, Tandhruil said:

Hello,

I still don't have notifications from synology for updates.

Image2.jpg.c529deb725eea0b7890a020ebb1cbdb5.jpg

Releases in package center will generally be a few weeks behind because they have to go through the Synology review process. So you can either wait for that or install manually.

Link to comment
Share on other sites

Version 4.6.6 has not been fully tested and published by Synology to the store yet.  One of the advantages of downloading from GitHub is that you get it quickly

Also, you may have to install from the store in order to be notified in Package Center when there is an update the next time.  At least that's the way it has worked in the past when we had the repository.  If you install from GitHub you will get notified in the Dashboard and if you install from the Synology store then you will probably get notified in PC when there is an update.

Link to comment
Share on other sites

55 minutes ago, FrostByte said:

Version 4.6.6 has not been fully tested and published by Synology to the store yet.  One of the advantages of downloading from GitHub is that you get it quickly

Also, you may have to install from the store in order to be notified in Package Center when there is an update the next time.  At least that's the way it has worked in the past when we had the repository.  If you install from GitHub you will get notified in the Dashboard and if you install from the Synology store then you will probably get notified in PC when there is an update.

II've installed the 4.6.4 version from github with the DM7 migration.
I've never been notified of the 4.6.5 version (and in the synology menu it's still the 4.6.4 version which is active)
Should I uninstall the github version and install the synology package center one ?

Edited by Tandhruil
Link to comment
Share on other sites

49 minutes ago, Tandhruil said:

II've installed the 4.6.4 version from github with the DM7 migration.
I've never been notified of the 4.6.5 version (and in the synology menu it's still the 4.6.4 version which is active)
Should I uninstall the github version and install the synology package center one ?

I'm not sure why you weren't notified.  I got a notification yesterday in the dashboard for the new beta

I think it depends on if you prefer to get notifications from the dashboard and install using the spk files or if you prefer to wait and install from the Synology store and get notifications from within Package Center.  Nether one will auto update it seems. 

In order to start getting notified within PC though you may have to do an install from the store first.  At least that's the way it used to work with the old repository.  

Personally I would not uninstall if you prefer the store.  The next time there is an update to the stable release I would just wait and upgrade from the store once it arrives there.  If you do get an update notification great, if not, then you may have to wait again until the next update to start getting notifications.

This is the first stable update since the initial install on the Synology store so we'll have to wait and see how long it takes them to process updates.

Link to comment
Share on other sites

15 minutes ago, FrostByte said:

I'm not sure why you weren't notified.  I got a notification yesterday in the dashboard for the new beta

I think it depends on if you prefer to get notifications from the dashboard and install using the spk files or if you prefer to wait and install from the Synology store and get notifications from within Package Center.  Nether one will auto update it seems. 

In order to start getting notified within PC though you may have to do an install from the store first.  At least that's the way it used to work with the old repository.  

Personally I would not uninstall if you prefer the store.  The next time there is an update to the stable release I would just wait and upgrade from the store once it arrives there.  If you do get an update notification great, if not, then you may have to wait again until the next update to start getting notifications.

This is the first stable update since the initial install on the Synology store so we'll have to wait and see how long it takes them to process updates.

Ok, I'll wait the next stable version

Thx

Link to comment
Share on other sites

  • 2 months later...
On 11/19/2021 at 8:17 AM, Tandhruil said:

II've installed the 4.6.4 version from github with the DM7 migration.
I've never been notified of the 4.6.5 version (and in the synology menu it's still the 4.6.4 version which is active)
Should I uninstall the github version and install the synology package center one ?

 

On 11/19/2021 at 9:43 AM, Tandhruil said:

Ok, I'll wait the next stable version

Thx

We had to change our version numbering slightly for Synology which we've done so it will take one new install (webpage or package store) and then package store updates should be smooth from that point on.

So if it were me I'd pull down the latest release version from our website and manually install that. At this point you should be all set moving forward installing from our website or the store.  Our website will almost always have the version available before it shows up in the Synology store so it will be perfectly fine to download and install from our site one release and use the store for another so you aren't locked in to one way or the other!

Carlo

  • Like 2
Link to comment
Share on other sites

  • 4 months later...
MikeyMan

So is this the latest version now then? 

I’m still at 4.6.7. While 4.7.4 is already available. However, there’s no update available in the Package Center and the download link for synology on Emmy site gives a 404 error.

Link to comment
Share on other sites

12 minutes ago, MikeyMan said:

So is this the latest version now then? 

I’m still at 4.6.7. While 4.7.4 is already available. However, there’s no update available in the Package Center and the download link for synology on Emmy site gives a 404 error.

Hi, what download gives a 404? It seems to be working just fine for me.

Link to comment
Share on other sites

MikeyMan

Error was with my iPad. On the android phone it does seem to work. 

 

Should this or a later version than 4.6.7 be in the package center?

Link to comment
Share on other sites

1 minute ago, MikeyMan said:

Error was with my iPad. On the android phone it does seem to work. 

 

Should this or a later version than 4.6.7 be in the package center?

The update in package center will usually come a little later so you can either wait or install manually.

Link to comment
Share on other sites

MikeyMan

So there were no versions in between the two that I missed?

Link to comment
Share on other sites

Happy2Play
44 minutes ago, MikeyMan said:

So there were no versions in between the two that I missed?

No you do not need to worry about the 4 versions prior to current release 4.7.4.0.

Link to comment
Share on other sites

MikeyMan
15 hours ago, Happy2Play said:

No you do not need to worry about the 4 versions prior to current release 4.7.4.0.

Was thinking more in the lines of the updates from the package center working out from now on, or if something went wrong there.

Link to comment
Share on other sites

JohnWhitmore

Hi all,

Does everyone else's setting show Emby automatic update being greyed out?

Package Center - Settings - Auto Update

Most other packages can be ticked.

I am unsure if this is the same for everyone, or due to my having upgraded to DSM 7.1 fairly early and maybe needing to uninstall/reinstall (keen to check if this if affecting others before taking the risk of an uninstall).

image.png.d8bf83dae61c02c4916cc9af9573f31d.png

Link to comment
Share on other sites

FrostByte
1 hour ago, JohnWhitmore said:

Hi all,

Does everyone else's setting show Emby automatic update being greyed out?

Package Center - Settings - Auto Update

Most other packages can be ticked.

I am unsure if this is the same for everyone, or due to my having upgraded to DSM 7.1 fairly early and maybe needing to uninstall/reinstall (keen to check if this if affecting others before taking the risk of an uninstall).

image.png.d8bf83dae61c02c4916cc9af9573f31d.png

Yes, it's grayed out for everyone.  I believe all third-party apps are grayed out as far as auto update (at least all the ones I have are).  @Luke may need to ask Synology

  • Like 1
Link to comment
Share on other sites

heffeque

I'm sure that it's on purpose. You don't want Synology to rage-quit Emby and install a new version in the middle of someone's video playback.

Also... is 4.7.5 gonna be the one that reaches the package center at last? I want to be patient enough, but at the same time I'm biting my fingernails!

Edited by heffeque
Link to comment
Share on other sites

11 minutes ago, heffeque said:

I'm sure that it's on purpose. You don't want Synology to rage-quit Emby and install a new version in the middle of someone's video playback.

Also... is 4.7.5 gonna be the one that reaches the package center at last? I want to be patient enough, but at the same time I'm biting my fingernails!

It will either be 4.7.5 or a 4.7.6 early next week, so either way, not too long.

Link to comment
Share on other sites

heffeque
9 hours ago, Luke said:

It will either be 4.7.5 or a 4.7.6 early next week, so either way, not too long.

Argh! You guys are killing me! 🤪

😉

Link to comment
Share on other sites

  • 2 months later...

Been running DSM7 with Emby 4.6.7.704060700

I noticed there had not been a notification in a long time...so I checked and the current download for DSM7 64bit nas is emby-server-synology7_4.7.6.0_x86_64.spk.

Still haven't seen an update on this in package center.  Mine is greyed out like mentioned above...does this require a manual upgrade?

Link to comment
Share on other sites

44 minutes ago, scaryfast said:

Been running DSM7 with Emby 4.6.7.704060700

I noticed there had not been a notification in a long time...so I checked and the current download for DSM7 64bit nas is emby-server-synology7_4.7.6.0_x86_64.spk.

Still haven't seen an update on this in package center.  Mine is greyed out like mentioned above...does this require a manual upgrade?

An update was submitted to Synology but is taking longer for them to test.  You can either wait or install the spk.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...