Jump to content

Playback error. Need guidance


gillmacca01
 Share

Go to solution Solved by mark-in-dallas,

Recommended Posts

gillmacca01

Running latest version of server.

My live TV source is via an IPTV Service, and I am currently having a problem playing one channel. The channel worked a couple of weeks ago, but then went down and was fixed, but now I am getting the following message, regardless of device I play the channel on: 'Playback Error - No compatible streams are currently available'. I have tried the play this channel over the last few days and have restarted Emby, but still get the same message.

I have checked with other users who use the IPTV service, and they say that the channel is playing fine (they are using other ways to view it, not via Emby)

The channel is Sky Sports F1, and last attempt to watch the channel was 05/07/21 @ 13:03. All other channels appear to be working fine

 

 

embyserver.txt

Edited by gillmacca01
Add server log
Link to comment
Share on other sites

mark-in-dallas

Are you pulling the M3U into Emby from a URL or file that you downloaded?  If other people using the same service are able to view that channel It's possible that the IPTV provider changed the link and you are still trying to view the old one.  

Have you tried playing that stream in another media player like VLC?

Edited by mark-in-dallas
Link to comment
Share on other sites

gillmacca01

Haven't had a chance to test that yet. Will test in a bit and report back

Link to comment
Share on other sites

gillmacca01

Just tried it and it played fine in VLC.

As another test, I disabled my VPN, restarted Emby, and the channel still displayed the same error message

Link to comment
Share on other sites

mark-in-dallas

That's odd!  The next thing I might try would be to separate that one stream from the M3U fil and create a new M3U with only that stream in it, then create a new tuner in Emby with that single channel and see if it will then play.  My reasoning behind this is to see if that link is actually  the problem or if something else in the M3U might be causing it.

Cayars may be along with another idea, but I'm a bit stumped.

Link to comment
Share on other sites

4 hours ago, gillmacca01 said:

Just tried it and it played fine in VLC.

As another test, I disabled my VPN, restarted Emby, and the channel still displayed the same error message

If you can send me that one channel in a m3u file I'd be happy to try testing it on my side and see why it might not play.
Send me a PM with that channel if you want me to test/try it for you.

Link to comment
Share on other sites

This played for me in the web player. Watching an Indy 200 race.

It was slow to start but played just fine.

Link to comment
Share on other sites

gillmacca01

Million dollar question. Why does it not play on mine then?

Link to comment
Share on other sites

My guess would be the delay it takes to get started.  My server runs off SSD drives.  I have my transcoding and recording drive on a separate SSD drive as well so that could make a difference.

Where we are located could play a huge part in this as we don't know the origin of this particular stream which could be better for me as well in US.

Could you try playing this via the web player and then upload the ffmpeg file generated if it doesn't play?

Link to comment
Share on other sites

gillmacca01

 

The price is in dollars, so best guess is they are in the US, although that could just be their payment system 

 

Same error in chrome on mobile 

I have transcode and remix. 

I have attached both

 

Edited by Abobader
Removed logs
Link to comment
Share on other sites

Both of these log files are complaining about the stream not having a valid MOOV atom.

I don't get that test on my system.  I just tested this on a VM 4.6.4 Emby Server version and it too played back fine.

Link to comment
Share on other sites

What happens if you try to record a show off that channel?

Link to comment
Share on other sites

mark-in-dallas

I'm far from an expert or even experienced novice when it comes to logs, but as best as I could tell it looks like Emby spent 21 seconds trying to conenect to the channel, then closed the stream.

I had a problem with my last IPTV provider in that almost any channel that I tried to play would time out the first time that I tried to play it, but if I clicked it again right after it timed out it would play just fine.  I never did figure out the issue, but ended up changing to a different provider. 

Just out of curiosity, have you tired to play the channel again after it times out? 

Link to comment
Share on other sites

gillmacca01

Thanks for the advice @mark-in-dallas, tried it 3 times in a row, and still getting the error.

I have just restarted my NAS, and still getting the issue.

It's strange that I am getting the error, but cayars isn't

Link to comment
Share on other sites

Likely is a geo things.  I might be closer to the server and getting a lot less latency than you perhaps.

On the other hand I have a few channels from one of my m3u files I've removed because they just won't work for me.  Comes with the territory with these types of channels.
 

Link to comment
Share on other sites

gillmacca01

But why would it play fine in vlc and not in Emby

I've just installed emby (v4.7.3.0) on my laptop and added just that one channel. Laptop is on the same network, and the channel plays fine

Edited by gillmacca01
Link to comment
Share on other sites

  • Solution
mark-in-dallas

Damn gremlins!  I learned a long time ago that when it comes to computers and apps, some things just aren't meant to be figured out and you can be driven crazy trying too.

 

You may be able to get that channel to work on the NAS by doing the same thing you did with the Laptop; add a new M3U tuner with just that one channel.

Edited by mark-in-dallas
  • Thanks 1
Link to comment
Share on other sites

gillmacca01

And what do you know? Added as a single channel m3u into emby and it plays

Just hope the link doesn't change in the future

Edited by gillmacca01
  • Like 1
Link to comment
Share on other sites

gillmacca01

Silly question, but when emby refreshes the guide data, if any details for a channel in the m3u file has changed, does it update in emby?

Link to comment
Share on other sites

mark-in-dallas

As long as the link or file has changed, then Emby will update it when the Guide is refreshed.

Glad you got the channel working!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...