Jump to content

Migration DSM7 DS220+ : nickel !


MAX92
 Share

Recommended Posts

MAX92
Posted (edited)

Bonjour,

Pour info, la migration s'est bien déroulée. Aucune perte en suivant la procédure 

Juste une correction dans la ligne de code pour moi

cp -r /volume1/emby/* /volume1/@appdata/EmbyServer     à la place de cp -r /volume1/Emby/* /volume1/@appdata/EmbyServer

 

Sinon, un peu long de redonner les droits à Emby sur les répertoires mais ça va.

Vous pouvez y aller !

 

Ne pas oublier de donner les droits au répertoire de backup de la configuration aussi

Edited by MAX92
Compléments d'information
Link to comment
Share on other sites

MAX92

Il n'y a plus qu'à supprimer le vieux répertoire /volume1/emby/

  • Agree 1
Link to comment
Share on other sites

Tandhruil

Mes fichiers Multimédias sont dans le répertoire Emby, ça va avoir un impact sur les médiathèques ?

Link to comment
Share on other sites

Tandhruil
Posted (edited)

Yep

Volume1\Emby\Films

Volume1\Emby\Musique

...

J'utilisais le répertoire Emby avant la V4.6.x, celle-ci à migré l'application dans mon répertoire dédié

Edited by Tandhruil
V4.6.x instead of V6
Link to comment
Share on other sites

MAX92

Je dirai que ce n'est pas heureux mais ça marche quand même. 

A mon avis le mieux est de les déplacer ailleurs et de remettre les bons chemins dans tes collections.

  • Like 1
Link to comment
Share on other sites

I'm with @MAX92 on this.  If it were me I'd create a new share called "Media" or similar and then move all this content so it's:

Media\Films
Media\Music
Media\TV Shows
Media\Home Movies
etc.

Keep your media and program/meta data separate from each other.

  • Like 1
Link to comment
Share on other sites

Tandhruil
Posted (edited)
24 minutes ago, cayars said:

(...)

Keep your media and program/meta data separate from each other.

It was the case before the Emby 4.6.x version

It's Emby version who decided to merge with my installation ;)

Well, I Thnk I will let my medias in Emby directory and Emby in @appdata\EmbyServer directory

Edited by Tandhruil
Link to comment
Share on other sites

MAX92

Attention alors lors de l'exécution de la copie cp -r /volume1/emby/* /volume1/@appdata/EmbyServer     à la place de cp -r /volume1/Emby/* /volume1/@appdata/EmbyServer car toutes tes médias vont être copiés aussi.

  • Like 1
Link to comment
Share on other sites

  • 5 weeks later...
BaiytaOne

Bonjour,

Je n'ai pas été malin,

je n'ai pas regardé la procédure avant de migrer, je me suis contenté de regarder qu'il y a avait une version pour le DSM7 sur le site d'Emby et je n'ai même pas pris la peine d'updater le paquet sur mon syno.

Si je dois refaire toute la config, c'est pas très grave, ça ira vite, sauf que je ne parvient pas à l'installer, le paquet ne fonctionne pas : 

image.png.bb988c925bc84598d4727de5f3b384f3.png

J'ai un DS918+

J'ai bien le paquet pour DSM7 64bit.

j'ai supprimé l'ancien paquet (dont je ne suis plus sur de la version; 4.3.? il me semble)

j'ai vérifié et je n'ai plus aucun dossier qui traine dans le /Volume1 et j'ai supprimé le dossier /Volume1/@appdata/EmbyServer/ et autres @app...

MAis toujours le même message même après reboot du serveur.

Quelqu'un peut-il m'aider svp ?

Edited by BaiytaOne
Link to comment
Share on other sites

BaiytaOne

Yes and I also tried the Beta version for the same result

Edited by BaiytaOne
Link to comment
Share on other sites

alucryd

@cayars: Probably, if I'm not mistaken we've had another report like this one. This confirms Synology did not include the apollolake family in the generic x86_64 alias... The quick fix will be to add this specific family to our package, but then it will be refused by Synology for inclusion in the store... Will try to get them to fix that in a DSM update, if that takes too long I'll add the workaround to our package, at least the betas.

@LukeWould it be possible to ask Synology about this with the next package submission? Should I "fix" the beta right away so @BaiytaOnecan restore his server as soon as possible?

 

Link to comment
Share on other sites

alucryd

Having said that, I just realized have a 218+ which is also apollolake, and I don't have the issue so it might just be specific to the 918+. Not sure if adding apollolake will fix it then 😕

Edited by alucryd
Link to comment
Share on other sites

If I remember correctly the other NAS with the problem was a DS918+ as well.

To all reading: Do you have a DS918+ that you've upgraded to DSM 7?  Did the DSM 7 version of Emby install correctly for you?
Just wondering if this could be caused by some kind of config on a particular NAS?

Link to comment
Share on other sites

BaiytaOne

Thank you very much for your quick reactions.

Can i do something to help you ?

some Informations on my Nas, a specific file, ... ?

Link to comment
Share on other sites

neves000
On 7/5/2021 at 1:58 PM, MAX92 said:

Il n'y a plus qu'à supprimer le vieux répertoire /volume1/emby/

J'ajouterais que si ce dossier est un dossier partagé, alors il ne faut pas faire la même erreur que moi, c'est à dire aller le supprimer en SSH en se disant qu'il est vide alors ça risque rien, mais bien supprimer le dossier partagé en passant par l'interface DSM. Sinon ça casse les taches des backups qui essayent d'y accéder (même si ce dossier n'est pas sauvegardé), DSM pensant qu'il existe toujours (pareil quand on veux exporter la configuration du NAS).

2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: share/confbkp_share_export.c:179 SYNOGetFSType() failed[/volume1/Emby][No such file or directory], synoerr=[0xB500 bdb_cursor_get.c:71]
2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: share/confbkp_share_export.c:366 Fail to write share info!
2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: confbkp_export.cpp:240 Fail to export [share]
2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: confbkp_export.cpp:334 ConfbkpExportEx() Failed!
2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: synoconfbkp.cpp:557 SYNOConfBkpExport() failed
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: [31891]export_config.cpp:30 Error: Failed to export system config. error[255]
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: (31891) [err] logger.cpp:2845 last backup errcode [1300]
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: [31891]backup_controller.cpp:2519 failed to export config. (2)
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: (31891) backup_controller.cpp:2907 failed to backup data
2021-08-12T20:58:09+02:00 ds416 img_worker[451]: (451) client_base.cpp:125 [BkpCtrl] Got TERM signal: (15)
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: (31891) backup_controller.cpp:3634 INFO: abnormal terminate: blWorkerAlive[1], blWaitCloudUploaderEndResponse[0], blWaitBackupEnd:[0]
2021-08-12T20:58:09+02:00 ds416 img_worker[453]: (453) client_base.cpp:125 [BkpCtrl] Got TERM signal: (15)
2021-08-12T20:58:09+02:00 ds416 img_worker[450]: (450) client_base.cpp:125 [BkpCtrl] Got TERM signal: (15)
2021-08-12T20:58:09+02:00 ds416 img_worker[452]: (452) client_base.cpp:125 [BkpCtrl] Got TERM signal: (15)
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: (31891) backup_controller.cpp:3386 Error: worker[451] failed, result[ST_SUSPEND], resume_status: [RESUMABLE]

 

Link to comment
Share on other sites

MAX92
13 minutes ago, neves000 said:

J'ajouterais que si ce dossier est un dossier partagé, alors il ne faut pas faire la même erreur que moi, c'est à dire aller le supprimer en SSH en se disant qu'il est vide alors ça risque rien, mais bien supprimer le dossier partagé en passant par l'interface DSM. Sinon ça casse les taches des backups qui essayent d'y accéder (même si ce dossier n'est pas sauvegardé), DSM pensant qu'il existe toujours (pareil quand on veux exporter la configuration du NAS).


2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: share/confbkp_share_export.c:179 SYNOGetFSType() failed[/volume1/Emby][No such file or directory], synoerr=[0xB500 bdb_cursor_get.c:71]
2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: share/confbkp_share_export.c:366 Fail to write share info!
2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: confbkp_export.cpp:240 Fail to export [share]
2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: confbkp_export.cpp:334 ConfbkpExportEx() Failed!
2021-08-12T20:58:09+02:00 ds416 synoconfbkp[481]: synoconfbkp.cpp:557 SYNOConfBkpExport() failed
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: [31891]export_config.cpp:30 Error: Failed to export system config. error[255]
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: (31891) [err] logger.cpp:2845 last backup errcode [1300]
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: [31891]backup_controller.cpp:2519 failed to export config. (2)
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: (31891) backup_controller.cpp:2907 failed to backup data
2021-08-12T20:58:09+02:00 ds416 img_worker[451]: (451) client_base.cpp:125 [BkpCtrl] Got TERM signal: (15)
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: (31891) backup_controller.cpp:3634 INFO: abnormal terminate: blWorkerAlive[1], blWaitCloudUploaderEndResponse[0], blWaitBackupEnd:[0]
2021-08-12T20:58:09+02:00 ds416 img_worker[453]: (453) client_base.cpp:125 [BkpCtrl] Got TERM signal: (15)
2021-08-12T20:58:09+02:00 ds416 img_worker[450]: (450) client_base.cpp:125 [BkpCtrl] Got TERM signal: (15)
2021-08-12T20:58:09+02:00 ds416 img_worker[452]: (452) client_base.cpp:125 [BkpCtrl] Got TERM signal: (15)
2021-08-12T20:58:09+02:00 ds416 img_backup[31891]: (31891) backup_controller.cpp:3386 Error: worker[451] failed, result[ST_SUSPEND], resume_status: [RESUMABLE]

 

Je l'ai fait en SSH et je n'ai pas de problème du tout. Peut-être des droits à remettre pour la destination de la sauvegarde ?

Link to comment
Share on other sites

neves000
Just now, MAX92 said:

Je l'ai fait en SSH et je n'ai pas de problème du tout. Peut-être des droits à remettre pour la destination de la sauvegarde ?

Non parce qu'en fait, le problème venait de l'export de la configuration du NAS qui est réalisé par la sauvegarde, et c'est à ce moment qu'il se rend compte que le dossier partagé Emby n'était plus présent et donc que la sauvegarde Hyper Backup échoue (ce qui n'est pas normal, elle devait ignorer cette erreur, mais passons). C'était facile à vérifier parce qu'une exportation manuelle de la configuration du NAS (en .dss) échouait instantanément. Je suppose que tu n'as pas eu ce problème parce que tu n'avais pas de dossier partagé Emby qui pointait sur /volume1/Emby ?

Link to comment
Share on other sites

Mi.K

Lors de la copy sous Putty j'ai le message suivant : '/volume1/emby/*': No such file or directory
Je vois bien le répertoire Emby mais je n'arrive pas entrer dedans

Edited by Mi.K
Link to comment
Share on other sites

MAX92

Il faut faire attention à la majuscule sur Emby. 

On 7/6/2021 at 5:52 PM, MAX92 said:

Attention alors lors de l'exécution de la copie cp -r /volume1/emby/* /volume1/@appdata/EmbyServer     à la place de cp -r /volume1/Emby/* /volume1/@appdata/EmbyServer car toutes tes médias vont être copiés aussi.

 

Link to comment
Share on other sites

Mi.K

J'ai réussi  à débloquer l'accès au répertoire Emby en passant par l'autorisations de partage avancés mais maintenant c'est dans le répertoire appdata que les fichiers sont interdits de copie

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...