Jump to content

Alan Walker. Not recognized as musician


generiq
 Share

Recommended Posts

I  think everyone is missing the point here.

In the opening post, this: "MusicBrainz has him listed as a producer" and his subsequent removal of the musicbrainz ID fixing the issue imo clearly defines the problem. Emby must rely on the musicbrainz ID by default to define where and how an artist is displayed.

Not sure it's emby's fault if musicbrainz has him classified differently...

Link to comment
Share on other sites

Happy2Play

No idea then as I added the album Faded with all mbzids and Music Video Faded with embedded Artist tag and item was linked to Artist.

Okay with only mbzartistid it was not linked.  

But still sound like a database issue to me.

Link to comment
Share on other sites

"Okay with only mbzartistid it was not linked."

I kinda think that this proves my point.

So it looks like an embedded artist tag overrides the musicbrainz ID?

Link to comment
Share on other sites

Happy2Play

@Luke would have to say what embedded tags work on video files as Music Video it in a realm of its own (I always just applied Artist via UI without issue before testing embedded tagging).  As videos don't normally have this information.  And the orginal ts video I got was untaggable that I could see, so I converted to a mkv.

  • Like 1
Link to comment
Share on other sites

Try putting the IDs in the ID3 extended tag of the music not the video, and not added through emby. That's what I removed to fix this. 

Link to comment
Share on other sites

Happy2Play
Just now, generiq said:

Try putting the IDs in the ID3 extended tag of the music not the video, and not added through emby. That's what I removed to fix this. 

As noted my Music has extended tags.  And no I did not add Artist via UI to this Video, but I did add Artist tag to the Video.

image.thumb.png.b0a057b5c55e451520f4a841879ce342.png

 

Link to comment
Share on other sites

If you're tagging the videos, you must be using MP4. My videos are MKV. And in my case, emby doesn't identity the videos, even when I apply the IMDb ID. No results. That's unreliable anyway, as most of my video aren't in databases. So it's much easier for me to just add the artist name in emby.

The point being, that I have to rely on emby linking music to video by artist name alone. Which is why Alan Walker works when I remove the tagged IDs.

Link to comment
Share on other sites

Happy2Play
5 minutes ago, generiq said:

If you're tagging the videos, you must be using MP4. My videos are MKV.

The test video was a mkv and I dropped it into mp3tag as tagged it.

As for Identification it does not exist on a Emby Provider so on IMDBid will provide no results from TMDB or IMVDb in installed.

But I still can not reproduce your situation on multiple Windows test servers.

Link to comment
Share on other sites

 

17 minutes ago, Happy2Play said:

The test video was a mkv and I dropped it into mp3tag as tagged it.

Interesting. I'll try tagging my videos that way. I like that idea.

Link to comment
Share on other sites

Posted (edited)
1 hour ago, Luke said:

Right we support the same tags for videos as we do for audio files.

That has nothing to do with this issue. If a video isn't in any database, then it's identified solely by name...which is what I did. And Emby failed to reconcile the video to the music, with music artist identified by musicbrainz.

10 hours ago, Happy2Play said:

But I still can not reproduce your situation on multiple Windows test servers.

You already did..

20 hours ago, Happy2Play said:

Okay with only mbzartistid it was not linked.  

 

20 hours ago, jordy said:

"Okay with only mbzartistid it was not linked."

I kinda think that this proves my point.

Make no mistake, there is an error here. Whether the developers choose to see it or not.

I just took control, manually built the entries and locked the metadata. If I find other discrepancies, I will manually correct those, also.

(Please also notice that with genres attributed, there are still no suggestions)

600978187_AlanWalker4.thumb.jpg.63d5ba497edd570a64ae7ed9e21b3973.jpg

 

Edited by generiq
Link to comment
Share on other sites

Happy2Play

But it still is a matter of knowing if it is a issue with just your system or everyone systems.  If you are the only one that can reproduce it then to me it would something specific to your media or database.

Link to comment
Share on other sites

Luke
Quote

That has nothing to do with this issue. If a video isn't in any database, then it's identified solely by name...which is what I did. And Emby failed to reconcile the video to the music, with music artist identified by musicbrainz.

I'm not sure what you mean, but I was responding to the original intent of this thread - the attachment of music video to artist. That does not happen via musicbrainz. That happens, as I've said, by filling out the artist information on the music video. That could either come from you manually entering it into the metadata editor, or from the artist being tagged in the video in the same manner as an audio file.

Link to comment
Share on other sites

8 hours ago, Happy2Play said:

But it still is a matter of knowing if it is a issue with just your system or everyone systems.  If you are the only one that can reproduce it then to me it would something specific to your media or database.

You reproduced the issue!

1 hour ago, Luke said:

I'm not sure what you mean, but I was responding to the original intent of this thread - the attachment of music video to artist. That does not happen via musicbrainz. That happens, as I've said, by filling out the artist information on the music video. That could either come from you manually entering it into the metadata editor, or from the artist being tagged in the video in the same manner as an audio file.

I really don't know how more clearly I can describe this. What you're saying should work, didn't. And I've specifically shown that. It isn't my database or anything in my environment that causes it. There appears to be a blindspot that you guys can't get past. I'm going to stop reporting issues.

Link to comment
Share on other sites

Happy2Play
1 minute ago, Luke said:

How did happy2play reproduce it? I don't see him saying that in this topic.

Only issue I saw was only adding mbzartistid to video did not link video to artist.  All music if fully tagged with Artist, Album Artist, Album and all MBZids.

Link to comment
Share on other sites

1 minute ago, Luke said:

How did happy2play reproduce it? I don't see him saying that in this topic.

Seriously?

On 6/23/2021 at 1:07 AM, jordy said:

I  think everyone is missing the point here.

In the opening post, this: "MusicBrainz has him listed as a producer" and his subsequent removal of the musicbrainz ID fixing the issue imo clearly defines the problem. Emby must rely on the musicbrainz ID by default to define where and how an artist is displayed.

 

On 6/23/2021 at 1:13 AM, Happy2Play said:

No idea then as I added the album Faded with all mbzids and Music Video Faded with embedded Artist tag and item was linked to Artist.

Okay with only mbzartistid it was not linked. 

 

On 6/23/2021 at 1:24 AM, jordy said:

"Okay with only mbzartistid it was not linked."

I kinda think that this proves my point.

So it looks like an embedded artist tag overrides the musicbrainz ID?

If you guys still can't see it, then there must be some obtuseness, present. He reproduced the exact issue.

Link to comment
Share on other sites

Luke

Please continue to report your issues as we're happy to help.

If you removed the musicbrainz artist id from the music video and that caused it to obtain the relationship with the artist, then the only reason I can think of for that is that the musicbrainz id value it had may have been different then what your artist actually has in Emby.

Link to comment
Share on other sites

Ok, let's see if I can simplify this. I will try one more time...

If the videos and the music are tagged only with the artist name (no musicbrainz ID anywhere), they are linked correctly. Now simply add the musicbrainz ID to the music tag...it breaks the link. Why would that happen? The answer is, it shouldn't. Artist linking within emby should rely primarily on the artist name (if present), and then rely on musicbrainz only for extra metadata and all the frilly stuff. Identity within emby should defer to the artist name. All of my other music videos link to the music with only the artist name tagged on the music video. Alan Walker in musicbrainz is not identified as an artist, but as a producer. Emby should not use this information for identity within the Emby platform, and defer to the artist/album artist that is in emby.

If this is now not clear, there is nothing more to be said....

Link to comment
Share on other sites

cayars

What is the exact name as tagged for this in videos and music?
What MusicBrainzID did you use in music tracks?

I'll try and reproduce as well.

Link to comment
Share on other sites

1 hour ago, cayars said:

What is the exact name as tagged for this in videos and music?
What MusicBrainzID did you use in music tracks?

I'll try and reproduce as well.

*Sigh* I'm not going to keep repeating the same thing, ad nauseam. All of that information is in the first post.

Is anyone actually reading was I'm typing? I feel like I'm just wasting time. I'm just going to keep circumventing what emby is doing,  manually edit my music and lock the metadata. It's the only way this going to work. I have no more time to waste on this. 

Link to comment
Share on other sites

Happy2Play

Only way to reproduce is to know exactly what you have, minus that all was can do is test with what information we provide to the media.  And currently no issue has been found via the way we have tested besides adding only MBZArtistID to a Music Video does not link it to existing Artists.

Link to comment
Share on other sites

Fun times. I can reproduce. I have the same MV, correctly tagged

image.thumb.png.0a88d349107fdc12241debf7acdaada8.png

but for some reason emby reads that as

image.thumb.png.30010d7c9d5a1a422d73735b694455cc.png

weirder, i have another track also called Faded but by a different artist. Also tagged correctly

image.thumb.png.7da4e2d52ab764ccce8af64f79a0a0f1.png

also read wrongly by Emby as the same incorrect artist

image.thumb.png.2ba332c0d1effe53cb7eee20660b0e71.png

i don't have any MBz information in the MV tags, just what you can see in the images above and MBz is not a metadata provider for my MV library. So why has emby returned Lyves as the artist??

Edited by Spaceboy
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...