Jump to content

Alan Walker. Not recognized as musician


generiq
 Share

Recommended Posts

generiq

****DON'T READ THIS THREAD. YOU WILL BE WASTING YOUR TIME****

 

I have his music and music videos. For other artists, the videos are shown in the music library. With Alan Walker, his videos are not shown and there are no 'More like this' suggestions. The tags are correct and the videos are labeled correctly, but still I can't change how it's displayed.... I think I just figured out why. MusicBrainz has him listed as a producer, and I think Emby is not treating him like an artist....and there doesn't appear to be a way to override this. Or am I missing something? How can I get Emby to treat him like an artist, so his videos are linked in the music library?

Alan Walker

https://musicbrainz.org/artist/b0e4bc50-3062-4d31-afad-def6a6b7a8e9

1194529938_Screenshot2021-06-21202109.jpg.60800172621c0702b2e195bf6e2fc187.jpg

440731970_Screenshot2021-06-21202211.thumb.jpg.fb27302764d2efa331f3e09a75e4040e.jpg

 

Edited by generiq
Frustration
Link to comment
Share on other sites

generiq
2 hours ago, Luke said:

Hi, did you edit the metadata on the music videos to supply the artist information?

Yes, and I believe my screenshot shows that. Music videos don't use musicbrainz, so that's not possible. He is the only one I've seen, that this doesn't work with. All other music videos that I add the artist name to, show up correctly in the music library. But again, look at the music library. Emby doesn't give suggestions for more like this. Which suggests that the server isn't recognizing him as an artist.

Link to comment
Share on other sites

Luke

Your screenshot does not show that, because the second screenshot is just plain folder browsing. The folder and the artist are two different things.

If you want the music video to be attached to the artist, then you need to fill out the artist field on the music video using the metadata editor.

Link to comment
Share on other sites

Luke

Regarding More Like This, it's no surprise you're not seeing any given that the artist has no genres assigned.

Are your audio files tagged with genres?

Link to comment
Share on other sites

generiq
41 minutes ago, Luke said:

Regarding More Like This, it's no surprise you're not seeing any given that the artist has no genres assigned.

Are your audio files tagged with genres?

They were, but when there were no suggestions or music videos showing up, I started editing the metadata to try and fix this, but nothing has changed. I think I'm going to try removing the ID tags, lock the metadata, and force the server to purge that information to just use the name. I think that's the only way this is possibly going to work. Of all the combinations I've tried, nothing works, but I haven't tried that, yet. The server just isn't going to be correct, in this case.

Link to comment
Share on other sites

Luke
Quote

I started editing the metadata

Doing what exactly?

Quote

I think I'm going to try removing the ID tags

Generally speaking, the richer your embedded metadata is, the better result you'll get.

Link to comment
Share on other sites

generiq
49 minutes ago, Luke said:

Doing what exactly?

Generally speaking, the richer your embedded metadata is, the better result you'll get.

I tried changing every field. Removing information, changing information, every variation I could think of. Other than obvious things like artist name etc.

 

In this case, it might prove to be the opposite. The tagging software pulled down a lot of information. Some things need to be removed, such as composer, as I've mentioned in the other thread, emby creates an identity from that field, and other fields. So they can never be used. The other information is left in. This works without error with the other artists (as far as I can see). The server is definitely in error with Alan Walker. And the only theory I can think of, is that the server doesn't see him as an artist in the music library, but is an artist in music videos. The information is the same in both places as I verified by copying and pasting from one library to the other. I can't use the identify feature in music videos as it doesn't find any results. I don't want them identified, anyway. But again, this only happens with Alan Walker. All other artists work correctly.

Link to comment
Share on other sites

generiq

And I was correct. All I did was remove the MusicBrainz IDs from the tag(s), rescanned, and now it's correct.

1249352628_AlanWalker3.thumb.jpg.77bda33c6b61c10a1c440912c8b0d2fe.jpg

Link to comment
Share on other sites

Happy2Play

Full context of all tagging is needed as I have no issue with a Music Video with MBZids.  This m4v video had the musicbrainzartistid and populated the Artists field on the Music video.

tag.thumb.jpg.c46a2f98ae54e45d601d99888145d31a.jpg

Link to comment
Share on other sites

generiq
Posted (edited)

As I said. With other artists, the general tagging is just fine. But with Alan Walker, it doesn't work.

And for tagging music videos, there's no option to apply an MBZ ID

Edited by generiq
Link to comment
Share on other sites

Happy2Play

Minus digging in the database to see where a possible disconnect is, it is impossible to know.  As I would guess it is a issue that will only appear in your setup and media.

Link to comment
Share on other sites

generiq
2 minutes ago, Happy2Play said:

 As I would guess it is a issue that will only appear in your setup and media.

Apparently not. I've just proved the opposite. If I add the MBZ ID to the music, the music videos disappear.

Link to comment
Share on other sites

Happy2Play
4 minutes ago, generiq said:

Apparently not. I've just proved the opposite. If I add the MBZ ID to the music, the music videos disappear.

So there is a discrepancy in your database. But me doing the exact same thing still links my MV to Artist.

Link to comment
Share on other sites

generiq
1 minute ago, Happy2Play said:

So there is a discrepancy in your database. But me doing the exact same thing still links my MV to Artist.

Did you test with Alan Walker?

Link to comment
Share on other sites

Happy2Play
Just now, generiq said:

Did you test with Alan Walker?

I do not have any Alan Walker media but will look for some.

When you Search Alan Walker, What shows up?

Link to comment
Share on other sites

generiq
3 minutes ago, Happy2Play said:

When you Search Alan Walker, What shows up?

This.... but I've already found a correction for the issue.

1161179511_Screenshot2021-06-22200424.thumb.jpg.14c6d14fb73c5ebc0d2afce71d21a426.jpg

Link to comment
Share on other sites

generiq
4 minutes ago, Happy2Play said:

I do not have any Alan Walker media but will look for some.

You don't need any. Just fake it. Put together a list of files, rename them, and tag them as Alan Walker.

Link to comment
Share on other sites

Happy2Play
1 minute ago, generiq said:

This.... but I've already found a correction for the issue.

1161179511_Screenshot2021-06-22200424.thumb.jpg.14c6d14fb73c5ebc0d2afce71d21a426.jpg

That currently shows the proper linking for Alan Walker.  I assume it was not doing that before.

Link to comment
Share on other sites

generiq
Just now, Happy2Play said:

That currently shows the proper linking for Alan Walker.  I assume it was not doing that before.

I hadn't used a search prior to my correcting the issue, so I can't say what it was like before that...

Link to comment
Share on other sites

cayars

What did you do to correct the issue?

Are you all set now or still have an issue?

Link to comment
Share on other sites

generiq
1 minute ago, cayars said:

What did you do to correct the issue?

 

1 hour ago, generiq said:

And I was correct. All I did was remove the MusicBrainz IDs from the tag(s), rescanned, and now it's correct.

1249352628_AlanWalker3.thumb.jpg.77bda33c6b61c10a1c440912c8b0d2fe.jpg

 

Link to comment
Share on other sites

Happy2Play

Does the artist have a mbartistid/audiodbid?  That is the only thing I can think of that would break the linking, artist with and without ids.

Link to comment
Share on other sites

generiq
52 minutes ago, Happy2Play said:

Does the artist have a mbartistid/audiodbid?  That is the only thing I can think of that would break the linking, artist with and without ids.

Yes, there are both, MusicBrainz and AudioDB. I posted the link for MusicBrainz in the OP. As I've said, using that ID is what breaks this. 

I think I'm done here. I've clearly described everything. Emby is at fault, there is no doubt. I will continue to micromanage all entries and manually correct all errors.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...