Jump to content

Watched status not sync to Emby server


LuruiLove7V
 Share

Go to solution Solved by TeamB,

Recommended Posts

LuruiLove7V

 

Hi Emby Team and Emby Community,

I'm having a problem with the sync of the watched status from kodi to emby server.

--------------------------------------------------------

My setup

Kodi 18.9.0 based on Coreelec

EmbyCon 1.9.106 on Kodi

Emby 4.5.4.0 installed on Qnap x64

-------------------------------------------------------

After I turned to use Embycon instead of Emby on Kodi, I noticed the movied I already watched on Kodi was not marked watched in Emby side,  the wathched status wasn't recorded either.

However, any watch status in Emby side (e.g. web, iphone) will immediately sync to Kodi. It seems the sync only work in one direction : Emyb to Kodi.

 

 

 

Link to comment
Share on other sites

TeamB

Are you sure you are playing back items from EmbyCon and not old synced item Emby for Kodi had added to your local db?

Link to comment
Share on other sites

LuruiLove7V
21 hours ago, TeamB said:

Are you sure you are playing back items from EmbyCon and not old synced item Emby for Kodi had added to your local db?

Yes, I'm pretty sure, because I reset the whole local database.

What information do I need to provide you for further analysis ?

Link to comment
Share on other sites

TeamB

When you are playing something in kodi using embycon have a look at the web dashboard at the active devices and make sure that what you are playing is showing up correctly and as it progresses through the playback it shows the correct ammount played on the active device in the web dashboard.

Link to comment
Share on other sites

LuruiLove7V
On 4/29/2021 at 9:19 PM, TeamB said:

When you are playing something in kodi using embycon have a look at the web dashboard at the active devices and make sure that what you are playing is showing up correctly and as it progresses through the playback it shows the correct ammount played on the active device in the web dashboard.

I found out the cause of the problem, it was because I checked the “allow direct file playback” . If I uncheck it, the sync works well, but it will lead to a new problem, the subtitle download by plugin won’t be saved in the folder of the movie.

Do you have a solution for this problem?

 

 

 

Link to comment
Share on other sites

TeamB

Direct file playback should still track playback progress, i will have a look and see if i can replicate the problem.

Link to comment
Share on other sites

TeamB

I have tested this and can not reproduce your issue.

When you have the option:

EmbyCon Settings -> Playback -> Allow direct file playback = Enabled

And then when you play back an item in Kodi and you hit "i" for info you should see the following text at the top of the description/Synopses of the item when it is play:

image.png.15ce98804351f76d44c6ad5441b53bf3.png

 

And on the Emby Web Bashboard you should see this showing that it is DirectPlaying and that the time is progressing correctly:

image.png.d7c782f238e6f818eaf0b35bd308fb08.png

 

Link to comment
Share on other sites

LuruiLove7V
9 hours ago, TeamB said:

I have tested this and can not reproduce your issue.

When you have the option:

EmbyCon Settings -> Playback -> Allow direct file playback = Enabled

And then when you play back an item in Kodi and you hit "i" for info you should see the following text at the top of the description/Synopses of the item when it is play:

image.png.15ce98804351f76d44c6ad5441b53bf3.png

 

And on the Emby Web Bashboard you should see this showing that it is DirectPlaying and that the time is progressing correctly:

image.png.d7c782f238e6f818eaf0b35bd308fb08.png

 

My situation is different, but I found the info is different when enable allow direct file playback

info when enable direct play

image.thumb.png.b41b985fb307a827f43654033576ad0f.png

info when disable directplay

image.thumb.png.3b921b39936124ecec3084015121186b.png

Link to comment
Share on other sites

TeamB

Do you use name substitution in your paths?

Link to comment
Share on other sites

LuruiLove7V
3 hours ago, TeamB said:

Do you use name substitution in your paths?

Did you mean this?

ED1BC7A7-8361-43EF-A0DF-85FD598AA5CB.png

Link to comment
Share on other sites

TeamB

Yes, i think it used to be called path substitution.

I will have a look at this configuration and see if i can reproduce the issue.

Link to comment
Share on other sites

TeamB
9 hours ago, LuruiLove7V said:

Did you mean this?

When you are playing back that file, the one in the screen shot above what does the Emby Web Client Dashboard look like, does it show the EmbyCon client playing the item and is it showing the progress there? Show me a screen shot of the Kodi Info showing the Info "PirectPlay" and a screen shot of the Emby Web Dashboard showing the Active Device info.

Perhaps it has something to do with the path names or file name, can you try a playback of a file with NO unicode characters in the path or file name and see what happens.

Link to comment
Share on other sites

LuruiLove7V
12 hours ago, TeamB said:

When you are playing back that file, the one in the screen shot above what does the Emby Web Client Dashboard look like, does it show the EmbyCon client playing the item and is it showing the progress there? Show me a screen shot of the Kodi Info showing the Info "PirectPlay" and a screen shot of the Emby Web Dashboard showing the Active Device info.

Perhaps it has something to do with the path names or file name, can you try a playback of a file with NO unicode characters in the path or file name and see what happens.

you are right, it’s because the unicode characters.

Path has Unicode characters

72CDE974-F486-408C-A703-B8D4B6EFEA5C.thumb.png.29e87ab3eb6284071bea110e22b1b0ec.png
 

path without unicode characters 

234988B8-7B08-4470-992E-D70142C07F63.thumb.png.407d3abc26282e5add4e1d1e9474ec45.png

Link to comment
Share on other sites

  • Solution
TeamB
Posted (edited)

@LuruiLove7V

Ok found the issue I think, new version of EmbyCon released with the fix for Unicode characters in direct paths for tracking and playback status reporting.

Version: 1.9.108

This fix was only needed or Kodi 18 as Kodi 19 is now Python 3 and Python 3 is way better at strings 🙂

 

 

Edited by TeamB
Link to comment
Share on other sites

LuruiLove7V
1 hour ago, TeamB said:

@LuruiLove7V

Ok found the issue I think, new version of EmbyCon released with the fix for Unicode characters in direct paths for tracking and playback status reporting.

Version: 1.9.108

This fix was only needed or Kodi 18 as Kodi 19 is now Python 3 and Python 3 is way better at strings 🙂

 

 

Have you released the 1.9.108? The new version updated today is 1.9.107 in my side, the problem still exists. 

Link to comment
Share on other sites

TeamB
11 minutes ago, LuruiLove7V said:

Have you released the 1.9.108? The new version updated today is 1.9.107 in my side, the problem still exists. 

Yes i have released it, it can take a few hours for the distribution system to replicate to all regions.

Link to comment
Share on other sites

LuruiLove7V
23 hours ago, TeamB said:

Yes i have released it, it can take a few hours for the distribution system to replicate to all regions.

still no update avaliable, something wrong with my repository?

Snipaste_2021-05-04_09-50-34.thumb.png.d62a186edd43e56dc4aa3555869b4d57.pngaN

Link to comment
Share on other sites

TeamB
Posted (edited)
56 minutes ago, LuruiLove7V said:

still no update avaliable, something wrong with my repository?

aN

Did you go to the kodi addon area and select check for updates?

I think you have to go left to bring out the slide out menu when you are on the kodi addons list to see the check for updates item.

Edited by TeamB
Link to comment
Share on other sites

LuruiLove7V
10 minutes ago, TeamB said:

Did you go to the kodi addon area and select check for updates?

I think you have to go left to bring out the slide out menu when you are on the kodi addons list to see the check for updates item.

Update just pushed, I tested it and it works, Thanks🙂

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...