Jump to content

Won't recognize growing amount of music files.


Recommended Posts

brucesnelgrove

First off, the naming convention and structure are identical. I will have an artist with multiple albums(non-compilation). Emby will recognize some but not the others. I have multiple artists where this is occurring. I have tried reloading the music and reinstalling Emby-no luck. 

 

How is it that everything being the same, came Emby totally disregard files, and how do we fix it?

 

Thanks in Advance

Link to post
Share on other sites
Luke

Hi there, can you please go over an example? Thanks.

Link to post
Share on other sites
brucesnelgrove

Sure. Purchased multiple Holly Cole downloads from same source, 5 in all. Only 2 would be recognized. It was only after inserting a Space,hyphen,space between the track # and the track title did I finally see emby recognize. This took up way too much time.

 

Additionally I am running into outrageous amount of disk activity on Terramaster, to the point where I had disable the server. Please help.

 

Link to post
Share on other sites
  • 2 weeks later...
brucesnelgrove

I have upgraded to 4.5.4.0. Deleted the requested plugins. I have included a screen shot to show folder and file set up. As an example, there are quite a few RS albums. They are not showing up in Emby. Any feedback would be appreciated because there are alot of files suffering the same way. Thanks in Advance.

2021-03-22 16.19.10.png

embyserver.txt

Link to post
Share on other sites
brucesnelgrove

I have all of Emby's scheduled tasks turned off. I have Emby set NOT to scan when new media is added. I believe I have Emby set up to only scan through the keyboard. As you can see, It keeps scanning like it doesn't understand the files and keep trying to read them.

2021-03-22 16.40.42.png

Link to post
Share on other sites
Luke
12 minutes ago, brucesnelgrove said:

I have all of Emby's scheduled tasks turned off. I have Emby set NOT to scan when new media is added. I believe I have Emby set up to only scan through the keyboard. As you can see, It keeps scanning like it doesn't understand the files and keep trying to read them.

2021-03-22 16.40.42.png

The previous log file posted shows that the realtime monitor is still active. Try disabling it and then restarting the server.

Link to post
Share on other sites
brucesnelgrove

I have all of Emby's scheduled tasks turned off. I have Emby set NOT to scan when new media is added. I believe I have Emby set up to only scan through the keyboard. As you can see, It keeps scanning like it doesn't understand the files and keep trying to read them.

 

I swear I keep going in and turning that setting off. Here's a shot. I've included screen shots of when tried to play one of the stones albums from the "folder" section.

2021-03-22 17.47.42.png

2021-03-22 17.49.58.png

2021-03-22 17.50.07.png

2021-03-22 17.59.14.png

Link to post
Share on other sites
Luke

Then you're probably fine now in terms of the library scan running when you don't want it to.

Regarding the empty albums, have you configured any parental control settings for your emby user that might be causing the songs to be hidden? I would start by taking a look at that.

Link to post
Share on other sites
brucesnelgrove

I confirmed the parental controls as disabled completely. It is strange. Emby sees the folder itself, correctly identifies it, but chokes on the correctly formatted song files. Not only that, but the albums that are seen in folders you can't see in albums, or artist, or album artist, just in folders.

Link to post
Share on other sites
brucesnelgrove

Emby is still replacing artist name or album with what appears to be random generated names. I've included a screen shot. Let me know what you think.

2021-03-24 08.15.20.png

Link to post
Share on other sites
brucesnelgrove

This scan has been stalled for the last 20 min. Screen shot and log included. Is there any progress into what is going on? This is a series of problems that shouldn't be present in software that is so well rated. This is away to much.

2021-03-24 14.05.16.png

embyserverTues.txt

Link to post
Share on other sites
Luke

Hi, it has not stalled. I would just be patient and allow it to finish. Please let us know if this helps. Thanks.

Link to post
Share on other sites
Luke

I would just be patient and allow it to finish. Please let us know if this helps. Thanks.

Link to post
Share on other sites

Must be a large library.. Mine will zip through till about 90% you think 'Oh cool that was fast'... but it sits at that point inching slowly forward to being finished.. 

I think that it actually creates entries in the database, downloads metadata, people, backdrops and art for everything. 

At the end of this it will enlarge your metadata folder as well. 

If I am loading up a new library I usually try to do one at a time, till complete.. especially my music..

Link to post
Share on other sites

If your cruising the server it is probably loading the files.. seems like drive thrashing about.. Your AV may be scanning/accessing (even slowing down access) to all of those files. Mine I set the server up on my computer and it accesses my media on password protected network shares, mounted as network drives... I keep all of my metadata on the system with the server as it has an SSD. (Keeps read/write cycles down for EHD's; hopefully extending their long life. :P)

If you save your data to your media folders, the drive will be accessed during site/server loading.. mine still did a little of this but did stop.. eventually. I think the server will create a cache as well. Your hard drive will too be accessed this way on your computer...

I thought about trying this the way we used to before the SSD, installing the server and metadata on a RAM Drive.. to keep all of the activity down.. but there was no need for me to test it out..

Link to post
Share on other sites
brucesnelgrove

Took a good 3 hours. However, after that scan I noticed one of my custom playlists was missing. I can't have playlists disappear after every scan. We need to find out.

 

Link to post
Share on other sites
brucesnelgrove

Correction. I had a number of audio and video playlists. All the audio playlists are gone. this is a huge disappointment.

Link to post
Share on other sites

Is this actually changing your folders and files in your filesystem or is this a view from your emby server?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...