Jump to content

Won't recognize growing amount of music files.


Recommended Posts

brucesnelgrove

As far as I can tell it changes the name of the album, and sometimes the artist IN THE FILESYSTEM. Can't remember what the first album was, but the fifth album was "The Essential Lana Del Rey" . I set all these up, I know what's been changed. 

Link to post
Share on other sites

Yeah..Emby is definitely NOT supposed to have the ability to change the filesystem.. I don't even give accounts the ability to delete.. or change their passwords..

🤔

I have spent months (better part of a year) doing what I said I was going to do.. way back ( all along the way ) and thought I had done a relatively decent job along the way... but I have like 28,000 albums and over 140,000 files.. My print folder listing is what I have stopped other things to address, making sure it is the same throughout.. fine tuning album names/vinyl/singles/digital 2,800 files to fill in by hand from other sources not available in the databases.. have combed through almost every tag entry by hand making sure that it exceeds the limitations of our online resources to be correct, renaming, spell correcting, notation correcting, genre correcting... Everything the same... I have 860 adult films I am plugging in data by hand because of no databases.. and have to gather art for, and model/actors... and have worked my metadata on my movie files until my fingers bleed. Also have about 50 radio stations I am adding ( getting metadata for and art ). Currently, I have added in my movies, tv, and documentaries.. while working on the other stuff.

IF I get done with it.. I better not see that happen... LOL 

...and your sure it isn't another program accessing the files or anything... no current issues with iTunes or Apple stuff?

Your logs shown the actual album names present during the scan.. is what I found to be odd.. I did a search of the document and found Lana Del Rey.. all of the original folder names were present during the scan.. it did not show an operation to change them.. I did see two errors at the end which looked like there was a problem, but I am not well versed enough to state exactly what it was but had to do with ffprobe..

Link to post
Share on other sites
brucesnelgrove

Last night I instructed Emby to download missing metadata. That was at 10pm. At 6 am it was still going with no end in site. 

2021-03-25 06.18.58.png

embyserver.txt

Link to post
Share on other sites
brucesnelgrove

Why would I want to install Emby in Openmediavault or Dockers. I'm getting desperate. Why is Terramaster NAS such a problem child. Emby misses a vast amount of mp3 files, changes names on files randomly and sporadically. And it is still downloading metadata after 9 HOURS!!! Is there any progress??????

Link to post
Share on other sites
brucesnelgrove

Thanks for the input Hxemby001. Keep your eye for albums missing from known collections.  That's how I was alerted and it has been a nightmare. Would I be better off with desktop version? Is the NAS version not ready for primetime? This has been going on for months.

Link to post
Share on other sites

A few questions..

1. After upgrading from an older version of Emby.. did you do a fresh install after deleting all remnants of the previous version.. or did you upgrade over the top of it?

*Sometimes old installations need to be removed completely to get rid of files, sometimes even due to file permissions and installer problems as well files that are no longer used or did not upgrade if the installation was very old. A fresh install of the current is always a good idea in that instance.. I have done it myself.. especially if it was a database or metadata issue.. wiped out 15-17GB of metadata, might as well start fresh.. 

2. Is the installation for the server sitting on the NAS/computer/where? - Looked to be on an NAS.. for the data.

*Terramaster should not be too much of an issue.. if the server is installed on one of these systems, the drives are going to be accessing files which have been put into place for metadata - for the cache.. so constant drive thrashing/access.. installed on a computer with an SSD, not so bad.. but the access is to be expected. (on the system it is installed on)

3. Are you connected via network to these systems using WiFi or LAN?... had any connection issues?

*Bottlenecks in the data transfer is choked by your network connection and its bandwidth capability.. so maximums there can play in as well as two way traffic.. making a connection to the NAS for media scanning.. MAYBE during a refresh of you metadata being the case if it is installed on your computer.. while simply browsing, the local system is what is reacting and the source of the data you see.. this leaves more bandwidth available for the NAS and not so many request to the same system/cpu/ram/resources.. 2 & 3 actually go together in a lot of ways..

4. Is there any security software or protocols that could be effecting any systems involved including the NAS's? as far as having multiple programs access and/or lock the files in anyway?

*This can cause a myriad of unusual problems.. too many too list across all programs and systems.. ( including driving you nuts..LOL ) even versioning for those of who use NAS's systems which are also cloud servers.. Other programs or apps even installed on these systems that work along those same lines..

Edited by Guest
Link to post
Share on other sites
brucesnelgrove

I have uninstalled Emby via the TM OS, and then reinstalled several times. The media files and Emby are both residing on my RAID 1 server cabled  to my router. I don't have security or virus installed on server or DT. Manually run on a regular basis. Permissions have all been opened up to try and resolve missing album problem.

Link to post
Share on other sites

Does the Terramaster (TM) have a residual emby folder? IF it does I would delete it..

My advise would be to run the server on your computer if you have a stationary system.. 

My setup:

Dell 7040 Micro-Form Factor ( server is installed )... lan connected -NighthawkX6 capable of total 3.2 GBps.. lan connected.. -Netgear 316 ReadyNAS SATA III 6 GB/s transfer between drives.. max transfer of 1 GB/s over the Gigabit cards on all systems..

Windows 10 Pro/Linux-based OS on NAS

I have tried the installation in the NAS.. didn't like it..

My data archive is where everything I have is.. I will replace computers before my drives ( guaranteed for a billion read/write cycles will perish ) My archive is going to last with me throughout my life.. so protect the drives and data.. 

I use the computer with a better processor and RAM to run the server. with an SSD in place... I have more control over the installation and it only accesses as I was mentioning above in the post.. or suggesting in those 4 'questions'..lol

Your permissions... in my scenario, do not circumvent security.. I have them mounted as password protected 'or mounted' as network drives with a backup to access over SMB protocol. SO once the main system is allowed access so does the server running on it.. The password works.. and any other access does not allow or rather is not allowed. your server will deliver the data in this manner.

I worry about Linux Security sometimes.. I remember BackTrack back in the day.. I am not a Linux professional.. so I keep it secured as much as possible... even wary of android (linux based)... I am implicit on the NAS...

I would suggest approaching it in this manner... file access and permissions are going to be different.. as well as different owner/file security as it will be coming from another system and/or program.. I have not had this type of issue yet...

IF you are able to set it up this way.. I would fix your folders.. install emby without adding any libraries, then set up the server completely.. even library advanced settings first.. top to bottom.. Then with nothing else running.. add one library at a time till it completes its scanning and give it time to complete it metadata and database.

I do not store my cache, metadata, transcoding/encoding/uploads/ or other folders on the NAS but keep them in a separate EMBY folder on the computer.. with the server. but not in the installation path.. I do not have it download things to the media folders either.

Your port routing will need to be for the computer in question so don't forget.. this may also keep an attack at your system where you may have better control over security and protocols as well.. without exposing the NAS like a rack server.. with commercial level NAT configurable firewall and a team of IT around the clock..

Long.. but its my suggestion to try to see if it changes.. I think it might, including better performance out of your server. Hope this translates right to your OS... I use a lot of Windows terms.. on since windows 95 and used a Commodore 64.. also an Osborne computer back in my yute as it were.. LOL ( I used Mac and Linux too 😜 )

EDIT: Leave the security in place for the NAS and the CPU/RAM for its OS and maintenance tasks, as well as transferring and reading files.. to performs its function.. it does impact its performance and may not have the power or strength to handle everything your server is going to do. There may also be caveats or considerations to the updates, problems or issues with the way it's OS is written as well.. keep that in mind.. Strange issues and incompatibilities sometimes are unforseen until you pull apart the code and see whats going on..

Edited by Guest
Link to post
Share on other sites
brucesnelgrove

Whew!! That's a lot to consider. I'm going to take my time and consider next move. FYI- Emby is still downloading(or something) missing metadata-93% done-only taking 11 hours and counting.

Link to post
Share on other sites
brucesnelgrove

Looks fine but it's still messing up. That lana del rey album I showed you as mislabelled, I corrected it, well it now shows the artist as fishbone. Thanks Hxemby 101 for your input but with the dog's breakfast of problems I've, I don't see any solution in sight. I think I'm going to save the monthly fee and go to Kodi or Jriver. What do you think?

 

Link to post
Share on other sites
brucesnelgrove

I just checked my playlists and now my video playlists are gone-all my playlists have been removed by Emby, just because I'm trying to get it to read mp3s. I think I'm out.

Link to post
Share on other sites

I could see your point.. but it seems like your installation isn't behaving like it should.. it is abnormal.. If it is a must to have it installed on your NAS.. I would look for something that is compatible.. Plex and Kodi are both fast answers.. I would prefer Plex or Emby IMO.. I played with KODI for awhile.. it actually caused an issue for me and took a lot of custom configuring to get it to something likable... I thought Plex had a decent design, but did not offer another skin. Emby offered the best options so far for configuration, and looked the best ...

Installing them and using them yourself is probably the best answer to the problem. There have been many solutions come down the road over the years.. Emby, Plex, and KODI are probably sitting at the top three.. as you go down the list.. you loose presentation and options..

Link to post
Share on other sites
brucesnelgrove

It seems that Plex and Emby are too similar. I've used Plex and then switched to Emby for the past year. Using the both of them, on Mac and NAS, and the lack of any real solution(as you can tell from the thread) I just don't think either are ready for prime time. Seriously, all my playlists are gone, from a combination of a media scan and metadata download-wtf. The metadata download just finished-15 hours. Anyway, thanks for your input. Have great day.

Link to post
Share on other sites
  • 1 month later...
Luke

Hi there @brucesnelgrove, are you still having an issue with this? Please try again with the newly released Emby Server 4.6 release and let us know how that compares. Thanks !

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...