Jump to content

***[GUIDE]*** SETUP EMBY (with HW transcoding) ON UNRAID & REMOTE ACCESS THROUGH REVERSE PROXY USING SWAG


Recommended Posts

Mikele
On 7/2/2021 at 8:53 PM, shimmerknight said:

Worked like a charm for me.  Thanks for taking the time to do a write-up for others.  It is greatly appreciated!

Thanks a lot. Glad I could help :)

Link to post
Share on other sites
  • 2 months later...

In case this might help anyone..

 I kept getting the 502 Bad Gateway error, no matter how many times I tried to reinstall and set up and was certain I was doing it correctly. Googling away, I found something on Stack overflow(sorry, lost link) that mentioned deleting the resolver.conf located(in my instance anyway) /mnt/user/appdata/swag/nginx and restart Swag. This rebuild the resolver file and bingo, I was now in. 

Link to post
Share on other sites
nodiaque

Hello,

First off, great tutorial. I'm currently looking at building a new nas with unraid and was thinking emby or not on it, and this help me push it on the same hardware. Now my question that go with it, I see hardware transcoding using iGPU. I'm planning an AMD build (aren't sure yet) but even with an intel one, I'll use a dedicated nvidia gpu. How would someone configure for using NVENC instead?

THank you!

Link to post
Share on other sites

Hi @nodiaque,

thanks for your comment.

Before it wasn't possible to pass an external gpu to the docker as unraid didn't have the gpu driver installed (officially). With the latest Unraid build 6.9 they included the nvidia driver into the system so now it should be possible. I don't have an extra nvidia gpu card so you'll have to test this for me and let me know.

Follow this guide and you'll be able to passthrough the GPU to the docker. 

[Plugin] Nvidia-Driver - Plugin Support - Unraid

If you don't want to use this the other solution is to use a VM with emby installed and then passthrough the GPU. Have a look at spaceinvaderone youtube videos on how to do that.

Let us know how it goes. Hopefully you'll be successfull

Link to post
Share on other sites
nodiaque

Thanks a lot for the information. I changed how I'll be doing my new server which fix this issue in a way. I'll install Proxmox then truenas on it, and then spin some VM as needed. I'm still on the edge as do I install a Windows Server 2019 core for emby or a W10.

Thanks again for the information, if not me, someone else will use it

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...