Jump to content

Help!My emby service always be closed automatically with no reason.


leonscarey
 Share

Recommended Posts

leonscarey

Hello  guys!

I installed emby service at Windows10 ltsc. I hardly ever shut down this system, because this system must be available when i need it. So there is a problem that emby service will be closed automatically with no reason. And i can confirm that my memory capacity is enough. Is there anyone can find the solution for this problem?

Thanks!  

Link to comment
Share on other sites

I see shutdown requests in the log such as:

2021-01-23 20:38:23.312 Info Server: http/1.1 POST http://localhost:8096/system/shutdown. UserAgent: Go-http-client/1.1
2021-01-23 20:38:23.317 Info Server: http/1.1 Response 204 to ::1. Time: 5ms. http://localhost:8096/system/shutdown
2021-01-23 20:38:23.435 Info Main: AppHost_ShutdownRequested

I'm seeing a lot of errors and timeouts trying to communicate with outside services as well.

I don't see anything that would indicate any type of crashing.

Link to comment
Share on other sites

It looks like you or someone else is shutting down the server via the emby web interface. does that answer your question?

Link to comment
Share on other sites

leonscarey

Yes ,I did close emby.  When I find the client can not connect to my emby service, I search the reason from Task Manager. And I find the process 'emby service' is disappeared, but embytray is normal. I try to right click on the emby icon to restart emby service,but it does not work. I must shutdown the embytray and open emby service again. So there is the reason why you see the log indicated I closed the service. I just shutdown an icon. I guest that Windows 10 ltsc has some strategies to shutdown any process which use memory for a long time. I will try to reinstall the service or install as a Windows service. 

Thanks for your prompt answer.

Link to comment
Share on other sites

If you're having an issue I wouldn't complicate the issue by installing Emby as a service.

The next time you can't get a connection to connect try logging directly into the admin console.
Take note of what's going on in Task Monitor or Resource Monitor at the time.

If you can't get into the admin console, don't kill it yet, but TAIL the EmbyServer.txt log file and see if it's still working and if so what it's working on.

Emby doesn't just quit working without an environmental problem of some kind interfering with it so you need to figure out what's wrong.

Link to comment
Share on other sites

Quote

If you're having an issue I wouldn't complicate the issue by installing Emby as a service.

He didn't, which you can tell from the log, he's just referring to it as emby service.

Link to comment
Share on other sites

27 minutes ago, leonscarey said:

Yes ,I did close emby.  When I find the client can not connect to my emby service, I search the reason from Task Manager. And I find the process 'emby service' is disappeared, but embytray is normal. I try to right click on the emby icon to restart emby service,but it does not work. I must shutdown the embytray and open emby service again. So there is the reason why you see the log indicated I closed the service. I just shutdown an icon. I guest that Windows 10 ltsc has some strategies to shutdown any process which use memory for a long time. I will try to reinstall the service or install as a Windows service. 

Thanks for your prompt answer.

According to these logs everything looks normal. What you could do is check windows event viewer to see if there's any information about possible server crashes in there.

Link to comment
Share on other sites

1 minute ago, Luke said:

He didn't, which you can tell from the log, he's just referring to it as emby service.

"I will try to reinstall the service or install as a Windows service."

I took that as meaning a restall or switching to try running it as a service.  Maybe I misunderstood.

Link to comment
Share on other sites

2 minutes ago, Luke said:

According to these logs everything looks normal. What you could do is check windows event viewer to see if there's any information about possible server crashes in there.

What I'm interested in knowing is if Emby is continuing to work (logs would show this) when the client can't connect as it could be a number of environment things such as network/router/vm issues.
To Early to know right now as not enough info to work off of.

Link to comment
Share on other sites

rajurules

Sorry i read this quickly and have not had a chance to read the logs you supplied, so apologies if this suggestion is not needed. \

However first step is to check if your port forward is correct with a one time playback. If you emby is set up and playing on your device once then emby should run theoretically always like that. Next i would check your sleep system settings, I have always had my PCs with emby server software on all the time including no powering down the hard drive at all, so usually modify the power settings to do this. 

Then if emby is being run as a service in windows search for service and double check the Emby service is automatic or running, if this has stopped their might be a port conflict or service conflict. 

Or if the above is already set you can jump straight to checking the event viewer by doing action make an event error action via last 24 hours or when it happened and windows log, this will give you any red errors or unexpected issues in the windows environment. 

 

Hope these steps help. 

Link to comment
Share on other sites

streamz4k

This incident also happens to me.  emby shuts itself down spontaneously.  Machine keeps running, emby systray disappears from taskbar.  The only solution at this point, emby manual boot.  Damn tricky.

Link to comment
Share on other sites

1 hour ago, Privateyes said:

This incident also happens to me.  emby shuts itself down spontaneously.  Machine keeps running, emby systray disappears from taskbar.  The only solution at this point, emby manual boot.  Damn tricky.

Hi there, please attach the emby server log from when this happens. thanks.

Link to comment
Share on other sites

Spoiler

2021-01-26 13:23:54.286 Info Server: http/1.1 POST https://<SNIPPED.HOST>/emby/System/Restart?X-Emby-Client=Emby for Android&X-Emby-Device-Name=Mi 10T Lite&X-Emby-Device-Id=b101d453e2f2ffca&X-Emby-Client-Version=3.1.73. UserAgent: Mozilla/5.0 (Linux; Android 10; M2007J17G Build/QKQ1.200628.002; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/88.0.4324.93 Mobile Safari/537.36
2021-01-26 13:23:54.287 Info Server: http/1.1 Response 204 to <SNIPPED.HOST>. Time: 1ms. https://<SNIPPED.HOST>/emby/System/Restart?X-Emby-Client=Emby for Android&X-Emby-Device-Name=Mi 10T Lite&X-Emby-Device-Id=b101d453e2f2ffca&X-Emby-Client-Version=3.1.73
2021-01-26 13:23:54.287 Debug SessionManager: Beginning SendServerRestartNotification
2021-01-26 13:23:54.288 Info App: Calling RestartInternal
2021-01-26 13:23:54.288 Info Main: AppHost_RestartRequested
2021-01-26 13:23:54.289 Info Main: Closing tray icon
2021-01-26 13:23:54.289 Info HttpClient: POST http://127.0.0.1:8024/exit
2021-01-26 13:23:54.290 Info Main: tray icon WaitForExit

 

Someone is asking to restart it in the first log. In the second someone asked to shut it down.

The user is using this device on your server to do this: Mi 10T Lite

Edited by speechles
  • Like 2
Link to comment
Share on other sites

rbjtech

.. make sure your users are not Admins and they will not be able to shutdown the service (or do other potential damage)..

 

Link to comment
Share on other sites

streamz4k

Problem is solved. I have completely cleaned up and organized the OS disk. Now it no longer closes by itself.

Edited by Privateyes
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...