Jump to content

Prefer https over http won't automatically direct to https


vodouch17
 Share

Go to solution Solved by cayars,

Recommended Posts

vodouch17

Hi, I've been trying to solve a problem where when i go to my emby server through a Web browser then it'll go through http not https even though https is set up correctly and working. I have the preferred but not required setting and I need to keep it that way because a one of my TVs doesn't support https and there were too many problems with it. 

 

PS: sorry for my English it's not my primary language 

Link to comment
Share on other sites

Hello vodouch17,

Please wait for someone from staff support or our members to reply to you.

It's recommended to provide more info, as it explain in this thread:

Thank you.

Emby Team

Link to comment
Share on other sites

56 minutes ago, vodouch17 said:

Hi, I've been trying to solve a problem where when i go to my emby server through a Web browser then it'll go through http not https even though https is set up correctly and working. I have the preferred but not required setting and I need to keep it that way because a one of my TVs doesn't support https and there were too many problems with it. 

 

PS: sorry for my English it's not my primary language 

Hi, Have you tried changing the setting to required?

Link to comment
Share on other sites

vodouch17
2 minutes ago, cayars said:

Hi, Have you tried changing the setting to required?

As I said I can't do that. If I do, emby on my TV will stop working

Link to comment
Share on other sites

11 minutes ago, vodouch17 said:

As I said I can't do that. If I do, emby on my TV will stop working

Why? Is your TV on the same network as your server?

If so it would still have access to port 8096. Even if it wasn't it would still work assuming you have loopback on your router and using a domain name.

Link to comment
Share on other sites

vodouch17
Posted (edited)
16 minutes ago, cayars said:

Why? Is your TV on the same network as your server?

If so it would still have access to port 8096. Even if it wasn't it would still work assuming you have loopback on your router and using a domain name.

When I had https only then I wouldn't be able to log in to any of the accounts. When i set it to prefered but not required then it starts working. I think it's the Samsung tv not supporting the https certificate I use but I'm not an expert on that. 

Edited by vodouch17
Adding details
Link to comment
Share on other sites

Is the TV and your server in the same LAN?

If so just use the server IP and port 8096.

Link to comment
Share on other sites

vodouch17
3 minutes ago, cayars said:

Is the TV and your server in the same LAN?

If so just use the server IP and port 8096.

No it is not unfortunately unfortunately.

Link to comment
Share on other sites

OK, what cert are you using?

Link to comment
Share on other sites

vodouch17
Posted (edited)
6 minutes ago, cayars said:

OK, what cert are you using?

I`m using certbot and then converting it to a .pfx certificate so i can put it in emby. I couldnt find any other way since this was the first time i`ve done something like this.. If you know a better way please let me know.

Edited by vodouch17
Link to comment
Share on other sites

  • Solution

Hmm, I never heart of that cert before.
If that cert isn't recognized by your TV then yes you would have the exact problem you have, so that does seem likely.

Really the only way to "fix" this would be to switch certs or maybe put your server behind Cloudflare.
Other than that, REQUIRED couldn't be used as you already found out. 

Link to comment
Share on other sites

vodouch17
Just now, cayars said:

Hmm, I never heart of that cert before.
If that cert isn't recognized by your TV then yes you would have the exact problem you have, so that does seem likely.

Really the only way to "fix" this would be to switch certs or maybe put your server behind Cloudflare.
Other than that, REQUIRED couldn't be used as you already found out. 

Certbot is made by LetsEncrypt and everybody on the forum was mentioning how they were using letsencrypt so i tried it. I'll try cloudflare. Do you have any other suggestions? 

Link to comment
Share on other sites

Q-Droid

Unless I'm mistaken forcing https only applies to remote (WAN) connections. LAN connections (same subnet) shouldn't need or use https and local devices would not be forced to use it.

If for some reason your LAN subnet does not match what Emby "thinks" it is you can add it in the Network settings. Examples are shown right below the form field.

 

Link to comment
Share on other sites

vodouch17
1 minute ago, Q-Droid said:

Unless I'm mistaken forcing https only applies to remote (WAN) connections. LAN connections (same subnet) shouldn't need or use https and local devices would not be forced to use it.

If for some reason your LAN subnet does not match what Emby "thinks" it is you can add it in the Network settings. Examples are shown right below the form field.

 

No no. Lan is a ok. I'm talking about wan. From my Girlfriends TV to my server at home

 

Link to comment
Share on other sites

vodouch17
1 minute ago, Q-Droid said:

How old is the Samsung TV?

It's from 2020. Bought about 2 months ago

Link to comment
Share on other sites

Happy2Play

Pretty sure this issue was raised for TV.  @SamES

But without Required there will not be a redirect.

Link to comment
Share on other sites

Q-Droid

Ok. Then you shouldn't have a problem with the LetsEncrypt certs. However you might have a problem with your pfx file so let's look there.

Another thing, you don't want to rely on a redirect for apps. The browsers handle it fine but many apps choke on it. So setup the apps using host and port.

Edited by Q-Droid
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

SamES

Make sure that to connect via https your are using the correct https port

  • https://<server>:8920

And for http only (on the TV)

  • Use port 8096

This is assuming you have not changed the port numbers

Check the port numbers on the dashboard

image.png.8c0668e00a47a7cc2f1c22d9322b8a51.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...