Jump to content

Emby is not finding a media folder when I try to add a new library.


ConHom
 Share

Go to solution Solved by Luke,

Recommended Posts

Hi

Can you help?

Emby is not finding a media folder when I try to add a new library.

  1. I have three datasets in a Freenas  ZFSPool_1. These are Music, DVD_Videos, and Movies
  2. Each data set appears to be set up with the same Permissions, ACLs, and Options etc
  3. I can read and write to all datasets using W10. I am also able to access and play the media in these Emby libraries  from various devices

I have have three mount points in the Emby jail.

  1. Dataset for Music is set to the destination  /mnt/ZFSPool_1/iocage/jails/EmbyJail/root/media/Music
  2. Dataset for DVD_Videos is set to the destination /mnt/ZFSPool_1/iocage/jails/EmbyJail/root/media/DVD_Videos
  3. Dataset for Movies is set to the destination /mnt/ZFSPool_1/iocage/jails/EmbyJail/root/media/movies

In Emby I have added media libraries for Music and DVD_Videos

When I try to add a media library for Movies Emby only sees the folders media/Music and mediaDVD_Videos it does not see the folder media/movies

Entering /mnt/ZFSPool_1/iocage/jails/EmbyJail/root/media/movies in the Emby search folder box and selecting Okay results in the message “This path could not be found”

I am not an expert/familiar in this field but have a technical/science background/training so can dig a little deeper than some novices.

I have rebooted the Freenas server, deleted the movies mountpoint and remade it and compared the permission settings across all datasets and jails.  All seem to be the same but I may have missed something.

When I use the Shell in Freenas and navigate to the folder /mnt/ZFSPool_1/iocage/jails/EmbyJail/root/media/movies using cd command and then use the  ls  command to see its contents a list of the files in the dataset is displayed.

Any guidance on what may be the problem and how to fix would be appreciated

System Details

Freenas Version - FreeNAS-11.3-RELEASE

Emby Version 4.2.1.0_1

Log attached

Thanks for any help/feedback

Ray P

embyserver.txt

Edited by ConHom
no attachment added
Link to comment
Share on other sites

Hello ConHom,

Please wait for someone from staff support or our members to reply to you.

It's recommended to provide more info, as it explain in this thread:

Thank you.

Emby Team

Link to comment
Share on other sites

Hi

Thanks for quick reply.  My apologies for not using current version.  I have updated and tried to add  a movies library but the problem I am seeing is still there.

I have: 

  1. updated to Emby version 4.5.4.0
  2. rebooted Freenas
  3. Restarted Emby server
  4. Rebooted W10 PC

Updated copy of log attached

embyserver31Dec1703.txt

Link to comment
Share on other sites

Hi, are you sure it's "media/movies" and not "media/Movies"?

I ask because you used caps for DVD and for Music and that would explain why Emby doesn't see the folder.

What happens if you enter "/mnt/ZFSPool_1/iocage/jails/EmbyJail/root/media" ?  Can you browse the library from here?

Link to comment
Share on other sites

Hi

"media/movies" is correct.  

The reason for the different capitalisation between the Freenas dataset and the Emby Jail is due to my using lowercase when I created the folder "movies" under the Emby Jail "media" folder.

I have attached pictures of the

  1.  mountpoints as shown in Freenas
  2.  contents of the folder Emby Jail  media folder which I browsed to using the shell option in Freenas
  3. contents of the Emby jail folder as shown on the add mount point screen

The Freenas data set is "Movies" with capital M  the Emby jail folder is "movies" with lower case m as seen in the screen shot of the  Freenas mount points screen

Happy New Year

Ray P

ShellFolder.JPG

MountPDestinations.JPG

MountPoints.JPG

Link to comment
Share on other sites

Isn't the Movies and movies a conflict in the above picture?

Have you tried making it all "Movies" and giving it a new try?

There is obviously something different with Movies and the other two and this is clearly one difference.

Link to comment
Share on other sites

Hi

Thanks for your suggestion. I'm not sure that that is the cause of the issue. However this morning I tried something which resulted in a very crazy result.

So crazy that to my untrained eye I suspect that there might be a bug/anomaly in either the Emby code or the Freenas code. Your view would be appreciated.

What I did step 1:

  1. I deleted the Emby Jail mount point for the Freenas Dataset “Movies”
  2. I created another mount point for the Dataset “Movies” but this time created a new folder under the Emby Jail media folder called “DVD_Movies”   Picture1  attached.
  3. To make sure everything was reset I rebooted FreeNas and the Emby server

Step 2:

I then started Emby in W10 chrome and tried to add a new library. This is when things got really crazy.

When I browsed the Emby Jail Media folder I was shown three folders Music, DVD_Videos and the legacy folder movies. See Picture2.

The Emby Jail folder  “movies” was empty and could not be browsed

The new Emby Jail folder DVD_Movies  which I had set as the destination was not seen by EmbyJail

Step 3:

I used the Freenas shell to browse to the contents of the new Emby jail folder media/DVD_Movies and this confirmed that it contained my library files - see Picture3 

This confirms that the path is valid and that the folder exists.

It is just that Emby was not seeing this folder.

Step 4:

Moving on I went back to the Emby Mount points in Freenas and changed the destination for the  Freenas dataset "Movies" back to the old Emby jail folder “movies”

After rebooting etc I opened Emby in my browser and tried to add a new library.

This time Emby found three folders under the media folder Music, DVD_Videos and the new folder DVD_Movies.

It did not find the Emby Jail folder "movies" See Picture4

The Emby jail folder DVD-Movies was shown by Emby as empty and not browsable

 

This is crazy.

With 4 folders under the Emby media jail folder the Emby server only finds 3.

When the Freenas  ZFSPool_1 dataset "Movies" is mounted to the Emby Jail folder "DVD_Movies"  the Emby server will only find/show the unused  Emby Jail older  "movies"

When the Freenas ZFSPool_1 dataset "Movies" is mounted to the Emby Jail folder "movies" the Emby server will only find/show the unused  Emby Jail older  "DVD_Movies"

What is going on?

It seems to me that there is some legacy flag which is not being reset when it should.

Any help is most appreciated

New log file attached

Picture1.JPG

Picture2.JPG

Picture3.JPG

Picture4.JPG

embyserver01Jan1404).txt

Link to comment
Share on other sites

Okay thanks.  I will take a look at docs.  I have seen the Freenas user guide but may have not read it in as much detail as I should.

I'll read again this time carefully and see if I can find anything amiss with the permissions.

Otherwise my fallback is  make a fresh start

I will create a completely new Freenas dataset (probably called Films) copy the contents of the existing Movies dataset into this and then create a new Emby mount point  for this fresh dataset and then try to add a new library using this new dataset and EmbyJail mountpoint folder.

If either of these work I  will post the result

  • Like 1
Link to comment
Share on other sites

I have been unable to resolve the issue of Emby not seeing the Freenas dataset when asked to create a new library. However, I have achieved my objective by ignoring the problem. I have created a completely new Freenas dataset for my films and created a completely new mount point in the Emby jail with a new destination name.

I set the permissions to be identical to the problematic dataset/jail and the Emby Library created okay and works okay.

Ignoring the problem and starting again is the sledgehammer approach but, for me, is the quickest and most hassle free way forward. I decided to take this approach as I suspect that “fixing” the problem was not going to be straightforward.

From my reading/research I suspect that the issue could be caused by a dataset/jail destination setting deep within the code. Some texts seemed to suggest that this could be fixed by editing these settings using a code editor. This is beyond my current experience and the time needed to learn do this not justified. Hence my decision to archive the problematic dataset and jail and create new ones.

Things which were suggested as possible causes, capitalisation mismatch between dataset and jail mount point folders and permissions settings of datasets and jails did not seem to me to be the direct cause of the issues. Capitalisation because there is no requirement in the spec of Freenas for this to be the same and I have previously had jails associated with datasets where there has been a naming difference. Permissions because I have other jails/datasets working with permissions identical to the permissions of the problematic dataset/jail.

In particular when I made the new dataset and new jail I set the permissions to be identical to the problematic dataset/jail and the Emby Library created okay and works okay. At a naive level this rules out wrong permissions settings which are accessible vial the Freenas and Emby interface.

From my reading/research my guess is that the issue I am seeing is caused by a legacy jail mount point settings in Freenas which cannot be changed through the interface settings options. I believe that the problem stems from the fact that the jail mount point I was using was not “pristine” in that when I created this mount-point folder destination I originally associates it with a Freenas test dataset I had set up. I did this as part of a learning exercise. When I came to set up my actual library I created my Freenas videos dataset and used the existing Emby mount point as the destination. It is not clear from the literature if this is permissible.

Under the section of the Freenas user guide dealing with adding storage to a jail it says: Browse to an existing and empty directory within the jail to link to the Source storage area. 

https://www.ixsystems.com/documentation/freenas/11.3-U5/jails.html#creating-jails

It is not clear if, because the mount point destination directory had been previously used, it is seen as empty by the system. Indeed I did read during my research that in one version of the software used to create the Freenas jails some destination paths were not rewritten but these could be changed by editing them in the code. If this is true or not I do not know.

However, what I do knowe is that trying to use the Freenas dataset with this “pre-used” mount point does not work but scraping both the data set and the preused mount point and starting over with the same permission settings does.

It may be that I needed to set up/ create additional groups/permissions to make things work. Unfortunately I don't have the understanding to know if this is the case so the easiest path for me was to start over.

Link to comment
Share on other sites

After recreating your mount points for Emby to use, you do have it loading your media now correct?

Link to comment
Share on other sites

yes all okay and working as it should

I had to create a completely new Freenas dataset as well as new mountpoints.  Just creating new mountpoints and using these with the old dataset did not work. 

Fortunately at the time I had very few films  in the old dataset so copying them across to the new dataset was not a problem.  And making a new dataset, making new mountpoints and adding a new library was done in around 30 minutes.  Much quicker that tearing my hair out trying to find and then learn how to fix the problem!

thanks

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...