Jump to content

NFO Plugin: broken compatibility


Recommended Posts

Starting from the October release 1.34, the extra fanarts pictures (fanart1, fanart2, ...) are not more saved in the folder "extrafanart" this is required for Kodi compatibility. Moreover is not more working the option to copy extrafanart into extrathumbs. I cannot estimate exactly the release that broken the compatibility since also the plugin downgrade to the previous release is not working.   

Link to post
Share on other sites
Happy2Play
13 minutes ago, Dan64 said:

this is required for Kodi compatibility

But Kodi no longer supports them, but can't current find the other topics.

Get Extrafanart Directory Back - Windows - Powershell - Tools and Utilities - Emby Community

 

Why are "extrafanart" sub directories no longer created for New Content? - Emby Server - Emby Community

No extrafanart folder when using Emby in Docker - Linux - Emby Community  @Dan64

Edited by Happy2Play
added other links
Link to post
Share on other sites

Unfortunately I seems that the skin that I'm using (Transparency!) is not aware of this issue. I tried to downgrade the plugin till the version 1.0.11, but the pictures are still saved in movie's folder and not in the subfolder "extrafanart". Probably this feature is implemented in the emby-server, so I will try to downgrade to the previous emby version.

It would be useful to rework on the plugin settings in order to remove the very obsolete option "copy extrafanart into extrathumbs" and substitute it with a more useful option "copy in  extrafanart". In this way will be kept the compatibility with the skins which are still using the extrafanart folder.    

Link to post
Share on other sites

I downgraded to server version 4.4.3.0 and now the "extrafanart" folder is generated. I hope that in the coming new versions will added the compatibility option to still support the "extrafanart" folder.

Thanks.

Link to post
Share on other sites

Hi Luke, in this case you are the developer. Moreover the functionality of managing the folders is built in the server, which is under your management. So is up to you to decide to update the plugin. I think that this update is necessary to smooth the transition to the new standard as already happen in the past. During this transition the user will have on their storage the pictures located both on the movie's folder and the extrafanart subfolder. Kodi or the skins supporting them should be able to support both the standards, probably this will happen with the rollout of stable version of Kodi 19. But currently the stable version is Kodi 18.9 and the skins are supporting only the extrafanart folder. It is necessary also to consider that not all the users are able or willing to move to the latest software version and this transition could takes more than expected.  

Link to post
Share on other sites
  • 5 months later...
Dan64

Hi Luke, I'd like to know if with the new Emby Version 4.6.0.5 has been added the compatibility update for managing the "extrafanart". I recently tested Kodi 19, but the decision of remove the support to python 2.0 has broken the compatibility with a lot of plugins and themes. At the moment the support by the external developers to Kodi 19 is so low that I was forced to rollback to Kodi 18, and probably I will stay with this version for a lot of time. Given this situation the compatibility update for managing the "extrafanart" is even more necessary (actually since previously it was available it is just a rollback not a new development and should require less time).

Thanks     

Link to post
Share on other sites
Luke
3 hours ago, Dan64 said:

Hi Luke, I'd like to know if with the new Emby Version 4.6.0.5 has been added the compatibility update for managing the "extrafanart". I recently tested Kodi 19, but the decision of remove the support to python 2.0 has broken the compatibility with a lot of plugins and themes. At the moment the support by the external developers to Kodi 19 is so low that I was forced to rollback to Kodi 18, and probably I will stay with this version for a lot of time. Given this situation the compatibility update for managing the "extrafanart" is even more necessary (actually since previously it was available it is just a rollback not a new development and should require less time).

Thanks     

I don't have anything new to report at this time. Thanks.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...