Jump to content

Subtitles broken on update to Apple tvOS 14


NigelG
 Share

Recommended Posts

Your server will need to be accessible remotely. You can either create a user and send me the username/password in a DM or create a user and invite me via Emby Connect.

Link to comment
Share on other sites

  • 2 weeks later...

Thanks everyone!

This was driving me nuts! I've been watching a tv series in x265 (which required transcoding) and srt subtitles were working fine. Then I switched shows to a h264 and no subtitles (after I spent the evening loading up the correct subtitles).... I must have tried every option available on the server side to try and figure this out. Switched to MPV playback and everything is working. I knew the subtitles were there, as they were working on my phone, (iphone), the browser, & fire TV.

Link to comment
Share on other sites

stevenb@gmail.com

I have a curious scenario that subtitles work with .mkv files (auto populated when mediafile is added to folder) but not with mp4 files. All AppleTVs are the same version 14.2.  It didn’t bother us previously but some new series we’re getting from ShowRSS is only offering mp4 files. I’ve looked but can’t find mkv. 

Link to comment
Share on other sites

9 minutes ago, stevenb@gmail.com said:

I have a curious scenario that subtitles work with .mkv files (auto populated when mediafile is added to folder) but not with mp4 files. All AppleTVs are the same version 14.2.  It didn’t bother us previously but some new series we’re getting from ShowRSS is only offering mp4 files. I’ve looked but can’t find mkv. 

Are they internal subrip subtitles inside the MP4 that do not play? But they do play inside MKV?

 

If so this is the same problem as the Roku which is that textual subtitles (ASS, SSA, SUBRIP/SRT, MOV_TXT, etc) cannot be used embedded within an MP4.

 

Edited by speechles
Link to comment
Share on other sites

stevenb@gmail.com

The file structure is the same for mp4 and mkv files. I use the opensubtitles plug in to download subs as bittorrent adds the series to each folder on my NAS. I just tried Emby on my iPad and I’m able to play mp4 files with subtitles. It’s something specific to Apple TV and subtitles with mp4 files. 

Link to comment
Share on other sites

  • 2 weeks later...

I have very similar problem on my emby for tv app on my Apple TV. I was very happy with my emby server on my MacBook Pro and emby for tv app on. my Apple TV recently my .srt subtitles are not loaded on the emby for tv app. when I watch the same movie on the emby client on safari I don't have any issue. I have latest versions of both the server and the client for Apple TV. What should I do to solve this problem? (I also attached the latest log if it would help you to understand my issue)

embyserver.txt

Link to comment
Share on other sites

22 hours ago, metincan1907 said:

I have very similar problem on my emby for tv app on my Apple TV. I was very happy with my emby server on my MacBook Pro and emby for tv app on. my Apple TV recently my .srt subtitles are not loaded on the emby for tv app. when I watch the same movie on the emby client on safari I don't have any issue. I have latest versions of both the server and the client for Apple TV. What should I do to solve this problem? (I also attached the latest log if it would help you to understand my issue)

embyserver.txt 340.33 kB · 0 downloads

HI, we'll take a look at this. Thanks for reporting.

Link to comment
Share on other sites

If anyone can grant me access to their server and provide the steps to replicate I’ll take a look. I’ve not been able to repeat this issue on my setup. 

Link to comment
Share on other sites

17 hours ago, corey said:

If anyone can grant me access to their server and provide the steps to replicate I’ll take a look. I’ve not been able to repeat this issue on my setup. 

to be honest I don't think there is an issue on my server. I think there is something wrong with Emby for TV app for Apple TV because when I watch the same show (using the same emby server) from emby for iOS, the subtitle loaded successfully and I can watch it without any problem. If you still think it is necessary for you to connect remotely to my server then pls tell me what I should do to provide you the access. 

Link to comment
Share on other sites

3 hours ago, metincan1907 said:

to be honest I don't think there is an issue on my server. I think there is something wrong with Emby for TV app for Apple TV because when I watch the same show (using the same emby server) from emby for iOS, the subtitle loaded successfully and I can watch it without any problem. If you still think it is necessary for you to connect remotely to my server then pls tell me what I should do to provide you the access. 

I can use subtitles Subrip an SRT using both players (Native and MPV). Can you post the media info?

447900661_Capturadepantalla2020-12-03145958.thumb.png.731b7ae4483b7fedfa6928512fc07a19.png

Link to comment
Share on other sites

3 hours ago, metincan1907 said:

to be honest I don't think there is an issue on my server

Hi.  He isn't suggesting there is a problem on your server.  We just need to be able to reproduce a problem before we can fix it and using the exact content you know causes the problem is a sure fire way to do that.

Thanks.

Link to comment
Share on other sites

21 hours ago, corey said:

If anyone can grant me access to their server and provide the steps to replicate I’ll take a look. I’ve not been able to repeat this issue on my setup. 

 

21 minutes ago, vdatanet said:

I can use subtitles Subrip an SRT using both players (Native and MPV). Can you post the media info?

447900661_Capturadepantalla2020-12-03145958.thumb.png.731b7ae4483b7fedfa6928512fc07a19.png

 

Screen Shot 2020-12-03 at 17.19.05.png

Link to comment
Share on other sites

1 minute ago, ebr said:

Hi.  He isn't suggesting there is a problem on your server.  We just need to be able to reproduce a problem before we can fix it and using the exact content you know causes the problem is a sure fire way to do that.

Thanks.

ok if you need to connect to my server just tell me what should I do. How can I get you connected to my emby server. 

Link to comment
Share on other sites

1 hour ago, metincan1907 said:

ok if you need to connect to my server just tell me what should I do. How can I get you connected to my emby server. 

Your server needs to be accessible to the Internet. Then you can either create a user and DM/PM me the details (IP, user, password) or invite me via Emby Connect.

Edited by corey
Link to comment
Share on other sites

4 hours ago, vdatanet said:

I can use subtitles Subrip an SRT using both players (Native and MPV). Can you post the media info?

447900661_Capturadepantalla2020-12-03145958.thumb.png.731b7ae4483b7fedfa6928512fc07a19.png

@vdatanet what OS is your server on?

Link to comment
Share on other sites

  • 4 months later...

Unfortunately there has been no change from my original post that started this thread. To recap: With the native player mp4 files with external .srt files do not display the subtitles, a "subtitles loading" message is very briefly displayed upon opening the film and when skipping forward or backwards during playback, but nothing else (the "subtitles loading" message is incorrect!). The MPV player shows the subtitles correctly (except that the display does not follow the Apple TV settings regarding font and size (i.e. the subtitle display cannot be altered in font or size).

Following a post from stevenb in this thread I tried an MKV film with an external .srt file in the native player (and the MPV player) and this displayed they subtitles correctly.

Additional: I have just created a version of a film with embedded srt subtitles, this displays the subtitles correctly with the native player. Hoping this helps in narrowing down the problem.

So the problem (for me) is with .mp4 files with external .srt subtitles.

Edited by NigelG
Link to comment
Share on other sites

stevenb@gmail.com

Hi,

I can now confirm that subs are working correctly with both .mkv and .mp4 files.  I've attached a file structure that works for all series.  Since commenting a few months ago all Apple TVs have had both OS and Emby TV app upgrades....as well as an upgrade to Emby server.  Thanks Emby team for sticking with this one. 

File Structure.jpg

Link to comment
Share on other sites

  • 3 weeks later...
I come from Infuse to Emby and I use subtitles a lot. All of my films have srt subtitles.
Server: Synology NAS Player: Apple TV
I missed the feature to change color, size and background so badly. I prefer yellow captions and a black, transparent background.
Here is the solution:
I converted all of my subtitles to ssa. So I can change color, etc. It works fine with both players!

Maybe that will help someone.

 
Link to comment
Share on other sites

On 5/10/2021 at 12:15 PM, TomTom26 said:

I come from Infuse to Emby and I use subtitles a lot. All of my films have srt subtitles.
Server: Synology NAS Player: Apple TV
I missed the feature to change color, size and background so badly. I prefer yellow captions and a black, transparent background.
Here is the solution:
I converted all of my subtitles to ssa. So I can change color, etc. It works fine with both players!

Maybe that will help someone.

 

Hi, yes we'll look at supporting this in the Apple TV app. Thanks for the feedback.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...