Jump to content

Remote (WAN) access is not working for some reason


xd003
 Share

Go to solution Solved by cayars,

Recommended Posts

As the title implies , the Remote (WAN) access doesnt work for me .After some searches , i found this article and followed everything mentioned in there - https://support.emby.media/support/solutions/articles/44001849007-connectivity .

1) Firstly the In-Home ( LAN ) access is working fine , no issues there

2) I made sure that the ip address showing up in WAN access is indeed the correct one .

wget -qO- ifconfig.me/ip

This when ran inside terminal does returns the same ip mentioned in WAN Access so thats fine as far as i can tell.

3) Lastly i did setup port forwarding on my tp link router .  In Forwarding -  i added a virtual server as follows :

Service Port - 8096

Internal Port - 8096

IP Address - "Added my In-Home LAN access IP here"  (192.xx.xx.x)

Protocol - TCP ( options available - TCP ,UDP and All )

Common Service Port - "left blank"  ( options available - DNS, FTP, GOPHER, HTTP, NNTP, POP3, PPTP, SMTP, SOCK, TELNET )

4) I did checked if port 8096 is opened according to https://canyouseeme.org

It outputs the below error :

Error: I could not see your service on XXX.XX.XX.XX on port (8096)
Reason: Connection timed out

The IP address showing in canyouseeme.org is also the very same ip showing alongside in wan access in emby dashboard which again is same with my actual external ip ( I don't think issue is with IP mismatch in any way )

PS / This is my first time using any media server at all so i haven't tried WAN access on any different media server ,to be able to tell if it works with some different service . 

In my laptop ,i am connected to the internet through my home wifi . I haven't up any proxy , vpn or firewall in my machine locally or at router level . In fact just of curiosity - being connected to the very same wifi network in my android device.  I tried emby server for android app and started emby server from there but wan access is still not working

OS - Arch Linux ( x86_64)

Emby Server v4.4.3.0

 

Edited by xd003
Link to comment
Share on other sites

Hi,

That would indicate you didn't get the port forwarding correct OR possible you are being a cgnat (carrier grade network address translation)..

Do you see the same IP listed in Emby as you see at the Canyouseeme site?

Link to comment
Share on other sites

1 hour ago, cayars said:

Hi,

That would indicate you didn't get the port forwarding correct OR possible you are being a cgnat (carrier grade network address translation)..

Do you see the same IP listed in Emby as you see at the Canyouseeme site?

Thanks for replyingI .I have posted the port forwarding settings that i have added in my router ,i wonder if something is wrong there . Don't really know what cgnat means ,will try searching about it

Yes , the very same WAN Access IP is showing in canyouseeme.org as well

Edited by xd003
Link to comment
Share on other sites

sooty234

Something to consider, I'm not sure if this is related, but... After the server update I lost remote access. I have a pfsense router that I have an OpenVPN client and an interface for that. To disable it I've always just disabled the interface, and emby would switch back to using my ISP IP. Something must have changed, because even with the interface disabled, the server pulled the IP from the client. And with the interface disabled, portforwarding can't work, nor would pfsense router to that IP as it wasn't using it, because it was disabled. I had to disable the client and restart the server. So emby is now choosing other IPs that it didn't before. 

Edited by sooty234
Link to comment
Share on other sites

6 hours ago, Q-Droid said:

Are you sure that selecting Common Service Port: HTTP did not set your forwarding ports back to 80?

Check it again on your router.

 

Yes correct , selecting common service port as HTTP at end did changed service and internal port back to 80 , although before saving the forwarding settings , i changed the ports back to 8096 again

I also tried leaving the common service port option blank and rest settings same but to no avail

Edited by xd003
Link to comment
Share on other sites

Q-Droid

Common Service Port should be left unselected if using custom ports. Do you have other ports forwarded that are working or is Emby the only service? As far as I know Arch does not have a firewall enabled by default. Is your LAN access using discovery or by entering the same IP address used for the port forwarding destination?

 

Link to comment
Share on other sites

2 hours ago, Q-Droid said:

Common Service Port should be left unselected if using custom ports. Do you have other ports forwarded that are working or is Emby the only service? As far as I know Arch does not have a firewall enabled by default. Is your LAN access using discovery or by entering the same IP address used for the port forwarding destination?

 

Alright noted that 

Nope , any other port is not being forwarded , 8096 is the only entry currently . I haven't ever tried port forwarding in past

I an entering the same ip from lan access in my port forwarding settings 

I will try checking in Arch and disable the firewall if found any ( although i don't think there is any firewall active ) 

Also i have edited my post to include some additional info :

Just of curiosity - being connected to the very same wifi network in my android device.  I tried emby server for android app and started emby server from there but wan access is still not working

Edited by xd003
Link to comment
Share on other sites

41 minutes ago, Q-Droid said:

A second Emby server on Android? Did you change the IP or router forwarding rules for that one?

Have you tried restarting your router?

i didnt opened it along with the emby server on laptop , i first closed the one laptop and opened the server through android app while being connected to the very same wifi router

yes , i have tried restarting my router but that hasnt helped

Link to comment
Share on other sites

Q-Droid

Each device running Emby server would have its own IP addr. Forwarding rules are specified to an IP addr. Starting a server on another device will not have WAN access unless the device or the forwarding rule is changed to match. 

Link to comment
Share on other sites

At this point , i am almost convinced that it might be a ISP level block

I will take this issue up with my ISP and hopefully they will unblock the ports from their end , i will update once here if i get success

In the meantime , i have hosted the emby server on a vps .My final aim indeed was to host it on vps , i was just hosting locally to get familiar with emby being a first time user . 

Thanks everyone

Link to comment
Share on other sites

Did you not get my PM I sent you?  I'm almost positive it's a cgnat imposed by your ISP based on Google comments from others with the same ISP.

Link to comment
Share on other sites

7 hours ago, cayars said:

Did you not get my PM I sent you?  I'm almost positive it's a cgnat imposed by your ISP based on Google comments from others with the same ISP.

No haven't received anything yet after i mentioned my ISP name

Edited by xd003
Link to comment
Share on other sites

No need now. I had tried to TeamView in and remote didn't work to his Linux install.  Then we tried Anydesk and that did the same thing (no desktop updates).  Then we traded pics in PM so I could see router setup, etc and we worked through to figuring out he's behind a cgnat.

The cgnat was also confirmed with some google results for his ISP by name.  So would need to try to get a static IP, get a public VPN with dedicated IP and port or host Emby outside that ISP network.

  • Like 1
Link to comment
Share on other sites

Q-Droid
1 hour ago, cayars said:

No need now. I had tried to TeamView in and remote didn't work to his Linux install.  Then we tried Anydesk and that did the same thing (no desktop updates).  Then we traded pics in PM so I could see router setup, etc and we worked through to figuring out he's behind a cgnat.

The cgnat was also confirmed with some google results for his ISP by name.  So would need to try to get a static IP, get a public VPN with dedicated IP and port or host Emby outside that ISP network.

If you're able add it then this check should be included in the connectivity knowledge base article for external access. To make sure the router WAN IP address matches the one reported by canyouseeme.org and the Emby dashboard. In the case of a public domain name then it should resolve to the same IP as above. For those using external proxies it's more involved but you have to expect they've figured out the basics.

 

  • Like 1
Link to comment
Share on other sites

I'm going to add this plus a couple other things as well like doing a trace route and looking at your second/third hops to see if they are non-routable IPs (ie 10.x range).

I am going to rewrite that page anyway shortly and will likely change up the diagnostic steps.   Likely one page just for diagnostic stuff like this.

Should make it easier as it's own page linked from other sections. Better one page for setup and one page for diagnostic steps.

  • Like 2
Link to comment
Share on other sites

Hello guys , firsly i appreciate the community for being quite helpful and involving

so i have been reading a bit and it has come to my knowledge that if i setup something called nginx reverse proxy with cloudfare using my domain , I won't need to open any ports on my IP ? .Not only that i also heard it is lot more secure as it doesn't expose our IP and resolves peering issues if any ( in case emby server is hosted on a vps )

is this thing true ? That would be great because i do have a domain name with me . Although I have zero idea how to do this process  , i did searched for half hour and couldn't really find any starter guide on how would i do it . I would probably make a new post focusing on this if someone confirms this is indeed possible . So that later it can be added in guides and tutorials section in a comprehensive manner

Edited by xd003
Link to comment
Share on other sites

  • Solution

No, nginx, cloudflare or a typical user outside your network still need to be able to get to your server.  That requires a true IP on the internet.  Once you have a true IP on the internet you need to open up the port for it to use so that it can pass through your router.

If you are behind a cgnat you do NOT have a real IP that is directly visible on the Internet so none of this can be done without playing tricks.

One way to play a trick and by-pass your ISP is to use a VPN service that offers the ability to do port forwarding.  About 1/2 of VPN providers offer this these days.  Some VPN services will give you a dedicated IP/Port combo that is always your when you connect to a specific server.  <-- This ideally is what you want.

If you have a router that allows setting up VPN use that's better than on the Emby Server typically but not required.

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...