Jump to content

Chromecast freezes (loading circle) when playing content from DS418play


draaideur

Recommended Posts

First of all I love all the work that has been done for this great product and I’ve been using Emby for 2 months without a hitch.

However, yesterday I noticed Emby server was only sending stereo audio to my chromecast where surround sound with a range of different transcoded codecs always worked before. I could not find an easy fix, I had the feeling it was ffmpeg related but no errors occurred and software I believe was not updated. However, the Emby logs said it was sending out a stereo signal. I reinstalled Emby Server and everything works except when Emby is casting, the chromecast freezes (loading circle) when I play a movie. I tried a range of files with different audio codecs and containers, AC3, AAC stereo, DTS, Dolby, DTS-HD etc. It keeps freezing

What works:

  • Other apps cast fine to the chromecast including surround sound.
  • Casting is initialised by Emby through the android app and the item metadata appears on the casted screen.
  • Emby server plays the items perfectly on my android phone or Mac laptop.
  • Everything worked perfectly until some change somewhere this week.

What doesn't work:

  • Once I press play the chromecast shows the circle loading icon over the Emby interface and nothing happens.

Hardware/Software:

- Chromecast, Firmware 1.42.172094

- Synology DS418play, DSM 6.2.3-25426

- Emby Server (4.4.3)

- Emby Client Android (3.1.23)

- Marantz SR6006

I believe it has something to do with ffmpeg but don't know why this would just change from one day to another. I attached the log files where the embyserver.txt log ends with the chromecast freezing.

Any tips would be highly appreciated.

hardware_detection-63735854706.txt embyserver.txt

Edited by draaideur
Link to post
Share on other sites
  • 2 weeks later...

It is working again with surround sound. I don't know exactly what did it, it was really weird. Anyhow all automatic updates are now switched off since it seems stable.

I tried the following things:

- (Re)installing Emby server Beta (V 4.5.0.29)

- Reinstalling Mono (to my understanding shouldn't make a difference)

- Reinstalling ffmpeg (to my understanding shouldn't make a difference)

- Rebooting the NAS a few times with the previous changes.

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...