Jump to content
nosachov

Thumbnails and cache OpenSUSE

Recommended Posts

nosachov

Hi Everyone.

Problem:

  • I got a trial emby on an OpenSUSE server. All looks good except the thumbnails usage. Every time I enter some folder thumbnail images are downloading again and it causes a 100% or high CPU usage. Already looked for a solution on the forum but can't find it.

VM Hardware:

  • 4 CPU Cores.
  • 2 GB RAM.
  • External mounted NAS with photos and videos of high resolution (~1TB).

Also I use Nginx. Config:

server {
        listen 80;
        server_name media.domain.com;

        root /var/www/html;

        return 301 https://$server_name$request_uri;
}

server {
        listen 443 ssl http2;
        server_name media.domain.com;

        root /var/www/html/emby;

        ssl_certificate     /etc/nginx/ssl.crt/some.crt;
        ssl_certificate_key /etc/nginx/ssl.crt/some.key;

        location / {
                try_files $uri $uri/ @backend;
        }

        location @backend {
                proxy_pass http://127.0.0.1:8096;

                # Allow WebSocket connections via HTTP 201
                proxy_http_version 1.1;
                proxy_set_header   Upgrade    $http_upgrade;
                proxy_set_header   Connection "upgrade";

                proxy_set_header X-Forwarded-Host   $host;
                proxy_set_header X-Forwarded-Server $host;
                proxy_set_header X-Forwarded-For    $proxy_add_x_forwarded_for;
                proxy_set_header X-Real-IP          $remote_addr;

                proxy_redirect off;
        }
}

No errors in nginx log.

/var/lib/emby/logs/embyserver.txt:

2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 8000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 300000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 600000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 900000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 1200000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 1500000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 1800000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 2100000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 2400000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 2700000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 3000000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 3300000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 3600000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 3900000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 4200000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 4500000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 4800000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 5100000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 5400000ms.
2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013,  at 5700000ms.

37M     /media/cache/

3.0G    /media/metadata/

image.thumb.png.a846932aa3944c569d4a974544bf2118.png

image.thumb.png.94ebf490a06c6fc2253ccf9d10d6bdf6.png

Please kindly help me. And let me know if you need any information additionally.

Thank you in advance.

KN

Share this post


Link to post
Share on other sites
Luke

Hi, what exactly do you mean by images are downloading again?

Share this post


Link to post
Share on other sites
nosachov

Hi Luke!

I mean a thumbnails should be downloaded by users from the previously generated thumbnails in a server cache. But for some reason,  every time I look into the media folders with photos, thumbnails are downloads very slowly and it causes CPU usage, so I suppose a thumbnails are generated every time from the beginning .

Thank you.

KN

Edited by nosachov

Share this post


Link to post
Share on other sites
Luke

Thumbnails are downloading from where, to where?

Share this post


Link to post
Share on other sites
nosachov

I have edited my last comment, please review once again.

Thanks.

Share this post


Link to post
Share on other sites
nosachov

Luke, is this information enough for you, or I can search for something else?

Share this post


Link to post
Share on other sites
nosachov

Hi Luke!

I mean a thumbnails should be downloaded by users from the previously generated thumbnails in a server cache. But for some reason,  every time I look into the media folders with photos, thumbnails are downloads very slowly and it causes CPU usage, so I suppose a thumbnails are generated every time from the beginning .

Thank you.

KN

Share this post


Link to post
Share on other sites
nosachov

Any updates here? Still didn't get how to fix that.

Thanks.

KN

Share this post


Link to post
Share on other sites
nosachov

Any updates here? Still didn't get how to fix that.

Thanks.

KN

Share this post


Link to post
Share on other sites
Luke

Hi, can you please attach the emby server log from when this happened? Thanks.

Share this post


Link to post
Share on other sites
nosachov

Hi Luke, it's already attached and makes no sense for me.

 

Or should I look for another one log file?

 

Thanks.

KN

Share this post


Link to post
Share on other sites
Luke

Hi, I see that you've attached a snippet of a log file, which has nothing to do with Emby apps downloading image files from your Emby Server. That's from the library scan trying to create chapter thumbnails. Please attach the complete emby server log. thanks.

Share this post


Link to post
Share on other sites
nosachov

Hi, please find the full log in attachment.

And one more question. Do you have some tutorial which helps bypass a login page for a first time visitor and let him surf the media server on behalf of Guest user by default?

Also my server now has 4 CPU and 6 GB of RAM, because of out of memory fails and 350% CPU Usage. This happen when I opened few  tabs in a browser and tried to load a few photo folders at the same time. Can we limit a RAM/CPU usage somehow so the server won't answer with 502 any more? 

My nginx config has changed too.

proxy_cache_path /media/cache/n_cache levels=1:2 keys_zone=ast_zone:10m inactive=3M use_temp_path=off;
proxy_cache_key "$scheme$request_method$host$request_uri";

server {
        listen [::]:80;
        listen 80;
        server_name media.server.com;

        root /var/www/html;

        return 301 https://$server_name$request_uri;

# Expire rules for static content

# cache.appcache, your document html and data
location ~* \.(?:manifest|appcache|html?|xml|json)$ {
  expires -1;
}

# Feed
location ~* \.(?:rss|atom)$ {
  expires 1h;
  add_header Cache-Control "public";
}

# Media: images, icons, video, audio, HTC
location ~* \.(?:jpg|jpeg|gif|png|ico|cur|gz|svg|svgz|mp4|ogg|ogv|webm|htc)$ {
  expires 3M;
  access_log off;
  add_header Cache-Control "public";
}

# CSS and Javascript
location ~* \.(?:css|js)$ {
  expires 1y;
  access_log off;
  add_header Cache-Control "public";
  add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";
  add_header X-Content-Type-Options nosniff;
  add_header X-Frame-Options "SAMEORIGIN";
  add_header X-XSS-Protection "1; mode=block";
  add_header X-Robots-Tag none;
}

}

server {
        listen [::]:443 ssl http2;
        listen 443 ssl http2;

        server_name media.server.com;

        root /var/www/html;

        ssl_certificate     /etc/nginx/ssl.crt/star.server.crt;
        ssl_certificate_key /etc/nginx/ssl.crt/star.server.key;

        gzip on;
        gzip_disable "msie6";

        gzip_comp_level 6;
        gzip_min_length 1100;
        gzip_buffers 16 8k;
        gzip_proxied any;
        gzip_types
        text/plain
        text/css
        text/js
        text/xml
        text/javascript
        application/javascript
        application/x-javascript
        application/json
        application/xml
        application/rss+xml
        image/svg+xml;

        location / {
                try_files $uri $uri/ @backend;
        }

        location @backend {

                proxy_cache ast_zone;
                add_header X-Proxy-Cache $upstream_cache_status;

                proxy_pass http://127.0.0.1:8096;

                # Allow WebSocket connections via HTTP 201
                proxy_http_version 1.1;
                proxy_set_header   Upgrade    $http_upgrade;
                proxy_set_header   Connection "upgrade";

                proxy_set_header X-Forwarded-Host   $host;
                proxy_set_header X-Forwarded-Server $host;
                proxy_set_header X-Forwarded-For    $proxy_add_x_forwarded_for;
                proxy_set_header X-Real-IP          $remote_addr;
                proxy_read_timeout 3600;

                proxy_redirect off;
        }

}

Thank you Luke.

Best Regards

KN

embyserver.txt

Edited by nosachov

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...