Jump to content

CoverArt, Indicator Overlay Issue, Emby Server

DarkKniyt (John)

Recommended Posts

DarkKniyt (John)

Bit of a long post here.
I am having issues with CoverArt as well (I think) from Emby Server.
Example of issue;

I have a movie - Alita in 1080. 4K & 3D.
All 3 versions reside in the same folder allowing to have one movie entry with 3 versions listed to select from.
In the case of my 3D movies, I have them located in a separate folder, along with their other versions, from my non-3d movies.
I do this so I am able to set CoverArt to add the 3D indicator to the Poster.
Here's the catch;
The 3D indicator won't appear on the poster UNLESS I go into the metadata and add the 3D Format to it.
Once that is done and I re-select the poster image the 3d indicator is applied.
BUT, this causes another issue.
When I do the above, the Version drop-down to select which version to watch changes the "3D' to "3D/3D" for an option.
I am uploading screen shots to help explain the issue.
Appreciate any help that can be provided!

Folder structure.


Movie Version selection and NO 3D indicator.


Metadata without the 3D format selected.



I select the 3D format and save the metadata



I edited images and selected my poster preference.
This is the new display. 3D indicator shows but now the versions is "3D\3D"


Link to comment
Share on other sites

DarkKniyt (John)

"12 Years a Slave (2013) \12 Years a Slave (2013) - Bluray.mp4"

Link to comment
Share on other sites


@Luke I believe this is normal for 3D as using the support naming does the same.

    /300 (2006) - 3d-hsbs.mp4
    /300 (2006) - 3d.hsbs.mp4
    /300 (2006) - 3d.mvc.mp4



At the same time 3D indicator will only work if the 3D item happens to be the first item in a multi-version environment.  So indicators are somewhat irrelevant in a multi-version environment since the indicators do not change when you change versions.

Also the UI does not show specific version metadata so setting it to 3D may not be setting the correct nfo file either.

Edited by Happy2Play
Link to comment
Share on other sites


When I do the above, the Version drop-down to select which version to watch changes the "3D' to "3D/3D" for an option.

This will be resolved for the next release, thanks.

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...