Jump to content
ChoromPotro

Can not get discreete graphics to work under Docker

Recommended Posts

ChoromPotro

Context :

I am using a very old laptop running pop OS 20.04 and docker . I have a 3rd gen i7 on this and an nvidia 740m GPU. I installed graphics driver from ubuntu repository and my discreet GPU works (image attached for clarity) because I can see kodi picking up the discreet GPU.

 

Problem :

I installed emby beta 4.5.0.20 from dockerhub and installed nvidia container runtime and loaded the systemd module on it :

nirjhor@pop-os ~/Downloads [1]> sudo cat /etc/systemd/system/docker.service.d/override.conf
[Service]
ExecStart=
ExecStart=/usr/bin/dockerd --host=fd:// --add-runtime=nvidia=/usr/bin/nvidia-container-runtime
nirjhor@pop-os ~/Downloads>

 

Now when I load emby I see my intel processor but not nvidia (image attached)

 

Docker command I used :

 

sudo docker run -d --volume /home/nirjhor/emby/config:/config --volume /home/nirjhor/Videos/Movies:/media/movies  --volume /home/nirjhor/Videos/TV:/media/tv --net=host --device /dev/dri:/dev/dri --runtime=nvidia --publish 8096:8096 --publish 8920:8920 --env UID=1000 --env GID=100 --env GIDLIST=100,44,106 emby/embyserver:beta

I get the value of render and graphics by this :

nirjhor@pop-os ~/Downloads> getent group video | cut -d: -f3
44
nirjhor@pop-os ~/Downloads> getent group render | cut -d: -f3
106
nirjhor@pop-os ~/Downloads> 

 

Now my question is, how do I get this nvidia card to work? I took a look at linuxserver.io and I believe they expose nvidia somehow differently, which I did not understand quite well. Adding embyserver log for good measure.

 

Goes without saying, I have premier.

 

For what it's worth, in my desktop computer running arch linux I followed this exact steps and now have nvidia NVENC working. So I am even more clueless as to what I might be doing wrong. Please help.

Screenshot from 2020-08-19 22-06-35.png

Screenshot from 2020-08-19 22-06-10.png

Screenshot from 2020-08-19 22-12-23.png

embyserver.txt

Share this post


Link to post
Share on other sites
Luke

Hi, have you taken a look at this?

 

Share this post


Link to post
Share on other sites
ChoromPotro
8 minutes ago, Luke said:

Hi, have you taken a look at this?

 

I think for all intent and purposes both our processes are same except for , Should I try with this ?

    --env NVIDIA_VISIBLE_DEVICES=all \
    --env NVIDIA_DRIVER_CAPABILITIES=compute,utility,video \

Share this post


Link to post
Share on other sites
ChoromPotro
Posted (edited)

@Luke I tried and it's exactly the same result. Here are my docker environment variables and runtime. I posted another image from my desktop where it works, it looks exactly the same. I think the problem that is happening is the command is returning intel ID instead of nvidia, I am doing this from the official instruction, so I dont know what else to do.

getent group render | cut -d: -f3

Screenshot_2020-08-20 Portainer(1).png

Screenshot_2020-08-20 Portainer.png

Screenshot_2020-08-20 Portainer.png

Edited by ChoromPotro
more image

Share this post


Link to post
Share on other sites
Luke

Hardware transcoding on docker is something we only consider expiremental. It can work but will require setup on your part, so I don't have the answer right now as to what your exact issue is. 

Can you please attach the emby server and hardware detection logs? Thanks.

Share this post


Link to post
Share on other sites
ChoromPotro
11 minutes ago, Luke said:

Hardware transcoding on docker is something we only consider expiremental. It can work but will require setup on your part, so I don't have the answer right now as to what your exact issue is. 

Can you please attach the emby server and hardware detection logs? Thanks.

i did the setup to a tee on two different machine. One picks up nvidia one picks up the built in intel , why ?

 

attached.

embyserver(1).txt hardware_detection-63733816919.txt

Share this post


Link to post
Share on other sites
Luke

What are the differences in setup between the two?

Share this post


Link to post
Share on other sites
ChoromPotro
10 hours ago, Luke said:

What are the differences in setup between the two?

One is a desktop one is a laptop.

Share this post


Link to post
Share on other sites
ChoromPotro
10 hours ago, Luke said:

What are the differences in setup between the two?

I shared the screenshot in the previous post :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...