Jump to content
Mohammednt0

New Problem: Every 2 hours or so , emby stop working !

Recommended Posts

cayars

@wsramahi Crashs are nearly always hardware or OS related and there will be information contained in Windows Event Viewer for the crash.  Since issues like this are usually always different I'd ask you to start your own thread.  That will make helping you easier.

Share this post


Link to post
Share on other sites
wsramahi

I did started and you can find it on my profile.

Just to confirm, today we had crash rush on the same server with the same network socket error only can be found on the event viewer.

Im using a third-party app that runs emby server every time it crashed.

Server is fresh installed Windows server 2019 and up to date running on a supermicro server and 10g interface.

Unfortunately we couldn't find any hardware fault or OS issues.

Share this post


Link to post
Share on other sites
Mohammednt0
15 hours ago, wsramahi said:

Hello,

This issue is an old one which we are still facing with no proper solution from emby team, most likely if a network socket was active on a failing network card with a bad driver it keeps happening, this is happening all the time on our Enterprise network  when ever a user pause a stream and left it for a long time then emby server becomes crazy crashing.

currently 1 server out of 3 keep doing this all the time, even not a single log for which user session caused it, which make tracing the issue is impossible.

if its a hardware fault and there is no blame on emby server , at least this error or an generic error handler should be implemented to prevent a complete crash for emby!

 

i noticed that, whenever i stop using emby for some period of time, the problem will become worse, but if i keep using emby (Keep watching) the crashing will be less !

one more thing, i'm using laptop, i changed the power options to high performance, and the crashing become less !!, before, it was like 20 times every day, Now like 3 Times every day

if its possible, can you try this solution, and see if the crashing become less ! your feedback would be appreciated

Share this post


Link to post
Share on other sites
Mohammednt0
22 hours ago, cayars said:

Ideally, you shouldn't be getting any errors.

just trying to cover everything, is there any settings that need to be adjust here ?

OptionalFeatures_TCXHmpTd58.jpg.f688d451e5f98c4b2b60c9ee70ede8db.jpg

Share this post


Link to post
Share on other sites
Mohammednt0
4 hours ago, wsramahi said:

I did started and you can find it on my profile.

Just to confirm, today we had crash rush on the same server with the same network socket error only can be found on the event viewer.

Im using a third-party app that runs emby server every time it crashed.

Server is fresh installed Windows server 2019 and up to date running on a supermicro server and 10g interface.

Unfortunately we couldn't find any hardware fault or OS issues.

what is the name of the third-party app, i tried to use windows scheduled tasks but it won't keep up with emby, because emby was crashing too much,
i'll be waiting, thanks

Share this post


Link to post
Share on other sites
cayars

Those windows features are fine.

Share this post


Link to post
Share on other sites
wsramahi
9 hours ago, Mohammednt0 said:

what is the name of the third-party app, i tried to use windows scheduled tasks but it won't keep up with emby, because emby was crashing too much,
i'll be waiting, thanks

the app is restart-on-crash, and i don't think playing with windows registry might help if you are using the latest windows 10/server 2019 with the latest .Net framework.

Apparently the issue is a network related and it might be a TLS related issue between the client and the server, we are running wire-shark at the time being trying to identify what kind of traffic is causing this issue, on Microsoft website the claim is about some traffic might be going from HTTP to HTTPS or vise versa, strangely we are are not using or enabled secured connection on Emby.

Share this post


Link to post
Share on other sites
cayars
Posted (edited)

@wsramahi Is your installation in a corporate environment?  Nothing wrong with that, just asking.

If so is there any way we could login via maybe TeamViewer to your machine for a remote session and we could review the setup and chat quickly about the setup/environment?

Totally get if this isn't allowed or if it needs to be done "after hours" to not affect work loads.

I'd love to do a remote session with you and could be available EST from roughly 6 am to 12 am midnight if this would work for you. I could do other time frames as well with notice and scheduled session.

We/Emby would love to help you get this fixed.

Carlo

 

Edited by cayars

Share this post


Link to post
Share on other sites
Trunk
Posted (edited)

I have seen similar situation ("An existing connection was forcibly closed by the remote host") when inbound TCP/IP connections goes over the limit in windows ( ~20 concurrent clients / connections) for Windows 10. Emby process crashed a few times in that situation. Not sure if it's related.

There may be lingering connections that are not being closed so the available pool is exhausted (other applications than Emby can also be the reason like p2p).

Have posted a workaround for this here: 

 

Edited by Trunk

Share this post


Link to post
Share on other sites
Mohammednt0
Just now, Trunk said:

I have seen similar situation ("An existing connection was forcibly closed by the remote host") when inbound TCP/IP connections goes over the limit in windows ( ~20 concurrent clients / connections) for Windows 10. Emby process crashed a few times in that situation. Not sure if it's related.

There may be lingering connections that are not being closed so the available pool is exhausted (other applications than Emby can also be the reason like p2p).

Have posted a workaround for this here: 

 

thanks for your feedback, i will try your solution and see if it will fix the problem

Share this post


Link to post
Share on other sites
Mohammednt0
18 minutes ago, wsramahi said:

the app is restart-on-crash, and i don't think playing with windows registry might help if you are using the latest windows 10/server 2019 with the latest .Net framework.

Apparently the issue is a network related and it might be a TLS related issue between the client and the server, we are running wire-shark at the time being trying to identify what kind of traffic is causing this issue, on Microsoft website the claim is about some traffic might be going from HTTP to HTTPS or vise versa, strangely we are are not using or enabled secured connection on Emby.

thanks for the feedback, whenever you identify what causing the issue please let us know, and thanks for the app link

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...