Jump to content

New CentOS/Emby install works - locally only


Go to solution Solved by Q-Droid,

Recommended Posts

So, I've taken the plunge.  After years of running Emby on Windows, I've decided to create a Linux VM to be a dedicated Emby server.  I chose and successfully installed CentOS 8 on my newly minted ESXi host, and got Emby installed using the instructions on the install page https://emby.media/linux-server.html with limited difficulties.  A few maddening hours later fighting with Samba and Windows 10 TLS incompatibilities and after finally getting my remote SMB shares mapped to a local mount point with the appropriate permissions in place, I created my first media library.  Success!  Amazing!  Everything working perfectly.

Until I switched from my VM to my main PC's browser.  Nothing.  Nada.  Zip.  Zilch.  The big zero.

Situation is this.  I've got default Emby port settings, and using FireFox inside the VM, I can connect to Emby server using IP:8096 or localhost:8096.  The correct IP address and port shows up on the Emby Dashboard under "In-Home (LAN) access", but none of my other machines (on the same class c subnet, btw) can see the new CentOS Emby server.  Using a port scanner, I do not see 8096 as an open port on that machine.  The same scanner does see port 8096 open on my Windows Emby server.

Now, I know that port is open, at least on the loopback adapter, because Emby is working just fine using a browser on the Emby Server machine, just can't get to it externally.  After multiple attempts at changing settings on the Network page and restarting Emby Server with no luck, I started looking at networking. At one reference, I found the command "netstat -na | grep <port>" to find out of there was anything listening on a port, so I tried, and got this:

tcp6    0    0    :::8096    :::*    LISTEN
tcp6    0    0    ::1:41350    ::1:8096    ESTABLISHED
tcp6    0    0    ::1:8096    ::1:41350    ESTABLISHED

Now, I'm more of an old-school networking guy, but I *think* this means that Emby has set itself up in the OS to listen to IPv6 ports only?  maybe?  As I said above, the Emby Dashboard shows the correct IP address and port for internal...the correct IPv4 address.  I tried using the IPv6 address in my main machine's browser to verify, but was unable to get that to work.  Pinging by IPv6 works, so  At this point, I'm at an impasse.  Not sure how to proceed from here, so any help/pointers/RTFM would be greatly appreciated.  :)

Link to comment
Share on other sites

  • Solution

Firewalld is likely enabled by default and blocking everything.

Check to see if it's running:

systemctl status firewalld

Stop firewalld to test external connections:

systemctl stop firewalld

You can disable it altogether but if you want to keep firewalld running then allow the ports for Emby.



Link to comment
Share on other sites

Thanks, Q-Droid.  You got it in 1.  Firewalld was enabled and stoppying it rectified the connection problem.  That is exactly what I would've tried on Windows...disabling Windows Firewall and/or opening ports, I just didn't know where to find that or what to look for in CentOS.  Probably should've mentioned I checked 'iptables -L' and found no rules listed so thought firewall was ok.  Thanks very much for the pointer!

Now, I need to figure out firewalld, and figure out how to get my watched video list over to the new server, and and and and....

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...