Jump to content
RobertDi

J4105-ITX GPU Transcoding

Recommended Posts

RobertDi
Posted (edited)

Hallo liebes Forum,

 

Ich habe Emby-Server auf dem ASRock J4105-ITX laufen, nativ unter Debian Buster. (Integrated Intel® UHD Graphics 600)

Umstieg von der Docker Variante um die GraKa das Transkoding durchführen zu lassen.

Leider musste ich feststellen das mit aktivem Hardwaretranskoding nahezu kein Film mehr im Browser darstellbar ist.

Alles viel zu langsam und nur Aussetzer. Folgende Ansätze brachten leider keinen Erfolg:

 

#1 RAM der GraKa auf 512 MB hoch

# 2 Intel non-free Treiber

 

Hat jemand noch eine Idee oder ist die interne GraKa einfach zu schlecht?

Mittels Software Transkoding funktioniert die Wiedergabe, allerdings mit entsprechender CPU Last.

 

Spezifikationen Board:

https://www.asrock.com/mb/Intel/J4105-ITX/#Specification

 

Gruß Robert

emby1.png

emby2.png

Edited by RobertDi

Share this post


Link to post
Share on other sites
Luke

Hi there, please attach the emby server and ffmpeg logs from an example. thanks !

Share this post


Link to post
Share on other sites
Luke

Is this only happening with avi files?

Share this post


Link to post
Share on other sites
RobertDi
Posted (edited)

no tried with avi and multiple mkv - both file types are effected. not even 420kbps is working 😞

Edited by RobertDi

Share this post


Link to post
Share on other sites
RobertDi
Posted (edited)

is there any parameter to use my installed ffmpeg instead of packaged one or might it work if I replace file with symbolic link to my version? (ffmpeg version 4.1.4-1~deb10u1)

[Edit] symbolic link is not working

Edited by RobertDi

Share this post


Link to post
Share on other sites
Luke

Can you provide log files from an mkv example?

Share this post


Link to post
Share on other sites
Luke

Ok @softworkz will take a look at this. Thanks.

Share this post


Link to post
Share on other sites
RobertDi

Thanks

Share this post


Link to post
Share on other sites
softworkz

@RobertDi -

  • What's your CPU model?
  • Could you please post the hw detection log?
  • Could you please try the following two playback attempts using MKV file
    (playback from the start and without subtiltes)
    1. With the VAAPI HW Decoder disabled and the HW Encoder enabled
    2. The other way round (Decoder enabled, encoder disabed)

Thanks

 

Share this post


Link to post
Share on other sites
Luke
1 minute ago, RobertDi said:

Hi,

https://www.asrock.com/mb/Intel/J4105-ITX/

Where can I find the hw detection log?

I will try the playbacks and give feedback here in a few minutes.

In the same folder as the main emby server log.

Share this post


Link to post
Share on other sites
RobertDi

I have unchecked the box with subtitle extraction and hw for decoding only, playback is starting but it lacks every few seconds. CPU is fine, 1 core 100% and the other ones nearly 20%.

much better than before

ffmpeg-transcode-5ca20903-abb5-4a3c-8ed1-1e19a2c9249b_1.txt

Share this post


Link to post
Share on other sites
RobertDi
Posted (edited)

is graphic card to bad? I have choosen this board because of hw encoding/decoding support and power consumption...

btw I have tried with a different client (cable connected) with same result

graphics.png

Edited by RobertDi

Share this post


Link to post
Share on other sites
Luke
29 minutes ago, RobertDi said:

I have unchecked the box with subtitle extraction and hw for decoding only, playback is starting but it lacks every few seconds. CPU is fine, 1 core 100% and the other ones nearly 20%.

much better than before

ffmpeg-transcode-5ca20903-abb5-4a3c-8ed1-1e19a2c9249b_1.txt 72 kB · 0 downloads

It's burning in subtitles due to you unchecking that box. Please see our notes about that in our hardware acceleration guide:

https://support.emby.media/support/solutions/articles/44001160148-hardware-acceleration-overview

It's at the bottom in the troubleshooting section.

Share this post


Link to post
Share on other sites
RobertDi
Posted (edited)

checked or unchecked does not make a difference, playback lacks in both cases - I don't think that CPU is the problem... when using software transcoding everything works and all cores are at 100% - I have tried two streams in parallel and it worked. but with hw encoding or decoding the playback lacks...

Edited by RobertDi

Share this post


Link to post
Share on other sites
Luke
10 minutes ago, RobertDi said:

checked or unchecked does not make a difference, playback lacks in both cases - I don't think that CPU is the problem... when using software transcoding everything works and all cores are at 100% - I have tried two streams in parallel and it worked. but with hw encoding or decoding the playback lacks...

Did you see what I linked to above about subtitles?

Share this post


Link to post
Share on other sites
RobertDi
Posted (edited)

yes, but I don't understand how this should help. Subtitle is showing off (started playback, set to off, stopped playback, switched to home and started playback now with off) but playback still lacks...

I just want to use my graphics hardware as it should be able to transcode better than my CPU, in case CPU is required for whatever I'm fine with this. 

But actually no movie could be watched with hardware transcoding feature, it lacks every few sec.

Edited by RobertDi

Share this post


Link to post
Share on other sites
softworkz

Could you please post an ffmpeg log with subtitles off, hw decoder off and hw encoder on?

Share this post


Link to post
Share on other sites
softworkz

OK, thanks.

It appears to be an issue with the installed graphics driver and what we are delivering.

Could you please show the output of 'vainfo' and post the hardware detection log?

Share this post


Link to post
Share on other sites
RobertDi
Posted (edited)

emby3.png

emby4.png

Edited by RobertDi

Share this post


Link to post
Share on other sites
RobertDi

I have tried backports and newest kernel without success - will try with latest ubuntu server instead and let you know the reuslt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...