Jump to content

Subtitle Search not working (Auto or Manual)


victor@vialy.com
 Share

Recommended Posts

victor@vialy.com

Subtitle search has not been working for about 6 months for me now.

I have tried reinstalling opensubs plugin, Addic7ed, etc. But still do not work. Emby says "No results found. Have you configured subtitle downloading?"  

I have tried searching subtitles for titles that where automatically found before. 

Attached is my server log.

embyserver.txt

Link to comment
Share on other sites

Have you configured OpenSubtitles or one of the other plug-ins with the proper information?

Link to comment
Share on other sites

vra1974

Hi. Of course. Tried with adic7ed and opensubs account and plugins with the same results.

Enviado desde mi ELE-L04 mediante Tapatalk

Link to comment
Share on other sites

victor@vialy.com

The movies are being identified correctly automatically. But no subtitles being downloaded.
I just click on "More" - "Edit Subtitles" and leave blank the hash and forced subtitle check. 
And it says No results found. Have you configured...
I have tested this selecting English subtitles with the same result. No subtitles are being found on any language or plugin.

Attached you will find another log file 

embyserver2.txt

Link to comment
Share on other sites

Quote

leave blank the hash and forced subtitle check

The subtitle websites probably do not have any subtitles meeting these criteria. Did you consider that?

Link to comment
Share on other sites

vra1974
leave blank the hash and forced subtitle check
The subtitle websites probably do not have any subtitles meeting these criteria. Did you consider that?
As I wrote, I have tried even with movies that emby found the subtitles automatically before (about 6 moths ago) and as I wrote, I leave blank the hash and forced check. Also tried searching for English subtitles with the same results. Emby does not find subtitles on anything. Even on content with subtitles that exist on opensubtitles. I have to browse to opensubtitles and download them myself.

Enviado desde mi ELE-L04 mediante Tapatalk

Link to comment
Share on other sites

On 6/21/2020 at 12:38 PM, vra1974 said:

The subtitle websites probably do not have any subtitles meeting these criteria. Did you consider that?
As I wrote, I have tried even with movies that emby found the subtitles automatically before (about 6 moths ago) and as I wrote, I leave blank the hash and forced check. Also tried searching for English subtitles with the same results. Emby does not find subtitles on anything. Even on content with subtitles that exist on opensubtitles. I have to browse to opensubtitles and download them myself.

Enviado desde mi ELE-L04 mediante Tapatalk
 

What movie? It seems to be working just fine in my testing.

Link to comment
Share on other sites

vra1974

Dont worry. I got it running.

-Deleted opensubtitles plugin from dashboard

-stopped emby server

-removed the opensubtitles .DLL file from emby installl directory

- reinstalled opensubtitles plugin

- Entered my opensubtitles login and password ONCE on plugin settings.

- saved my opensubtitles data and went back to check if my login and password was saved correctly. It did not. My password was changed to some random characters. But I did not changed anything nowhere. Justo went back to the mover collection and everything works ok now.

I hope this helps someone else. Forma some reason my emby displays random characters as password but uses the right one to get into subtitles sites.

Edited by vra1974
Misspelling
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

Sorry for the stupid question, but how do you search manuel for subtitles in Emby?? i've been looking like crazy for that button, and searched the web...

Link to comment
Share on other sites

3 hours ago, blj said:

Sorry for the stupid question, but how do you search manuel for subtitles in Emby?? i've been looking like crazy for that button, and searched the web...

Try clicking the 3-dot button on a movie or episode, then click Edit Subtitles. @cayars can link you to our knowledge base article on it.

Link to comment
Share on other sites

25 minutes ago, blj said:

I dont have that possibility in my emby... Tried to reinstall opensubs plugin.

 

image.png.0e0cbfc197cdfb3ba987e25c14426232.png

Check the permissions for your Emby user and ensure it has permissions to edit subtitles.

  • Like 1
Link to comment
Share on other sites

  • 7 months later...
AlecTheDalek

Hi, I thought I would reply to this topic instead of starting a new one. Subtitles seem completely broken in my new server.

I have OpenSubtitles plugin installed, and I have an account.

I open a movie - the first time - and Edit subtitles, I can find a list.

But then if I preview - the page just hangs forever.

if I download - I get 'there was an error processing the request, please try later'

If I then try another movie or show, I get the 'no results found'  error described earlier in this thread, where search does not even return a list.

If I uninstall and reinstall OpenSubtitles plugin, I will get another one-shot at a subtitle list before it breaks again.

However some movies and shows already have subtitles available and they work fine.

Any ideas? I've been Premiere for exactly one day so I may have misconfigured something :)

Log attached, thanks!

embyserver.txt

Link to comment
Share on other sites

9 minutes ago, AlecTheDalek said:

Hi, I thought I would reply to this topic instead of starting a new one. Subtitles seem completely broken in my new server.

I have OpenSubtitles plugin installed, and I have an account.

I open a movie - the first time - and Edit subtitles, I can find a list.

But then if I preview - the page just hangs forever.

if I download - I get 'there was an error processing the request, please try later'

If I then try another movie or show, I get the 'no results found'  error described earlier in this thread, where search does not even return a list.

If I uninstall and reinstall OpenSubtitles plugin, I will get another one-shot at a subtitle list before it breaks again.

However some movies and shows already have subtitles available and they work fine.

Any ideas? I've been Premiere for exactly one day so I may have misconfigured something :)

Log attached, thanks!

embyserver.txt 84.86 kB · 0 downloads

OpenSubtitles rate limit reached

Hi, you've reached your daily open subtitles limit.

Link to comment
Share on other sites

AlecTheDalek

Well, darn. 

Guess maybe I should finally spring for the VIP membership :)

Thanks for the fast reply!

Edit: Bought OpenSubtitles VIP, restarted Emby server and now subtitle preview/download working like a dream 👍

Edited by AlecTheDalek
update, its working now :)
  • Like 1
Link to comment
Share on other sites

Thanks for the feedback. If you're using the automated scheduled task I do plan to add some options to that to control how often it will search for subtitles for any given video. This way you may have the task run every day but you'd be able to do something like limit searches for any given video to be once every three days or something like that.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...