Jump to content
kumaheiyama

ANSWERED Trouble playing media

Recommended Posts

kumaheiyama
Posted (edited)

Hi,

 

I'm having trouble playing media from my Synology DS218+ NAS, but only certain videos and only on my desktop computer. The same files works without a hitch on my iPad and my Android phone.

The server is available for browsing, just not playback. I've tried in the latest Chrome and Firefox.

 

Strangely the only media that doesn't want to play is The Walking Dead season 10, previous seasons have worked fine. So it looks like there is some problem with those specific files, but that doesn't explain why they work on the other devices. The files are .mkv.

 

To complicate matters I can't access the server log. When going to /logs I get the following error message "Unable to find the specified file."

I'm unable to get the logs via my Synology since the Emby Server menu item only links to the Emby server URL.

 

I'm using port forwarding to access my server from the outside, and I've changed the default port to avoid the server being obvious. No problems reaching it from other devices, but when going to the same URL on the desktop it is not available, I have to reach it by going to the 192.168.1.x IP address. The same problem occurs whether or not I use a VPN.

Related? Still this doesn't explain why certain media works and others not.

 

/K

Edited by kumaheiyama

Share this post


Link to post
Share on other sites
Luke

Updated log after new try.

 

Hi there, can you please attach the ffmpeg log as well? Thanks.

Share this post


Link to post
Share on other sites
kumaheiyama
awkdk

The files you are having problems with are encoded in HEVC.

 

The Android and iOS players can play HEVC videos directly, while the web player has to have them transcoded.

 

The simple solution is to use Emby Theater for Windows on your computer (assuming you are using Windows), since it can play HEVC video without transcoding.

  • Like 1

Share this post


Link to post
Share on other sites
kumaheiyama

Thanks, worked like a charm! However I have to have a Emby premier subscription to fully use it.

 

I might have completely misunderstood, but isn't the server on my NAS supposed to do the transcoding for me?

Share this post


Link to post
Share on other sites
awkdk

Thanks, worked like a charm! However I have to have a Emby premier subscription to fully use it.

 

I might have completely misunderstood, but isn't the server on my NAS supposed to do the transcoding for me?

 

 

Yes, that's why I said Emby Theater for Windows is the simple solution.

 

There is something wrong in your setup that makes transcoding not work, but I will let smarter people than me answer that.

Share this post


Link to post
Share on other sites
Luke

Sorry for the slow reply. Here are all the ffmpeg files I found.

 

Hi, which one is from the problematic example that we should look at? What file were you playing? Thanks !

Share this post


Link to post
Share on other sites
kumaheiyama

Hi,

I was trying to play The Walking Dead, so any one of these files (attached above):

ffmpeg-transcode-74a6f622-51c9-4571-9223-a5b50a689317_1.txt

ffmpeg-transcode-50823685-683c-4a4d-b417-31a01f203dc1_1.txt

ffmpeg-transcode-a50f2124-6faa-4530-adc6-43e902dc1097_1.txt

ffmpeg-transcode-dee30967-8f93-4df2-a6bc-fdff8f1385e8_1.txt

ffmpeg-transcode-e6600cf6-a48c-435f-9367-2f2973df0822_1.txt

Share this post


Link to post
Share on other sites
Luke

Is this only an issue with mpeg4 input?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...