Jump to content
ThreeFiveLeft

Live TV M3U Streaming Drop Out

Recommended Posts

ThreeFiveLeft

Hi guys,

I'm having trouble with live TV M3U streams regularly dropping out while watching via Emby-stream stops and the user is placed back on the guide screen.

It occurs on all devices, regularly but at sporadic timing (anywhere from 30 seconds to an hour) and does not occur when direct streaming the source link with VLC.

 

I have attached associated server and ffmpeg log files, any help would be much appreciated!

 

ffmpeg-transcode-b56fc0a1-1543-4f46-a4ec-8a7768bebc71_1.txt

embyserver.txt

Share this post


Link to post
Share on other sites
Luke

Hi, just for testing purposes, if you disable hardware trancoding in the server transcoding settings, does that help?

Share this post


Link to post
Share on other sites
Luke

Is it consistent?

Share this post


Link to post
Share on other sites
Luke

Please try lowering the in-app quality setting in the android tv app and see if that helps. thanks.

Share this post


Link to post
Share on other sites
Luke

@@ThreeFiveLeft are you still running into this?

Share this post


Link to post
Share on other sites
ThreeFiveLeft

Hi @@Luke, yeah we're still having problems with it

Share this post


Link to post
Share on other sites
Luke

Ok, @@softworkz will look at this. Thanks.

Share this post


Link to post
Share on other sites
softworkz

Ok, @@softworkz will look at this. Thanks.

 

@@Luke - I'm not familiar with that area. Any ideas?

rror processing request	*** Error Report ***
	Version: 4.4.2.0
	Command line: C:\Users\Emby\AppData\Roaming\Emby-Server\system\EmbyServer.dll -service
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///C:/Users/Emby/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	System.Environment.Version: 3.1.3
	Processor count: 4
	Program data path: C:\Users\Emby\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\Emby\AppData\Roaming\Emby-Server\system
	System.IO.IOException: System.IO.IOException: The supplied user buffer is not valid for the requested operation.
	   at Emby.Server.Implementations.IO.StreamHelper.CopyToAsync(Stream source, Stream destination, Int32 bufferSize, Int32 emptyReadLimit, CancellationToken cancellationToken)
	   at Emby.LiveTV.TunerHosts.LiveStream.CopyFile(String path, Boolean seekFile, Int32 emptyReadLimit, Stream stream, IFileSystem fileSystem, IStreamHelper streamHelper, CancellationToken cancellationToken)
	   at Emby.LiveTV.TunerHosts.LiveStream.CopyToAsync(Stream stream, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
	Source: System.Private.CoreLib
	TargetSite: Void Throw()

Share this post


Link to post
Share on other sites
Luke

@ThreeFiveLeft are you still running into this with Emby Server 4.4.3?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...