Jump to content

Episodes not showing


jerren
 Share

Go to solution Solved by Luke,

Recommended Posts

jerren

Hey

 

I recently finished watching season 14 of supernatural and wanted to watch season 15 but emby isn't showing these episodes even though there in the season 15 folder. That is to say emby shows 1 and it's a special not even an episode of season 15. 

 

I tried using the scan library files on the supernatural series, i tried doing an entire series library file scan. No luck. The tvdb & moviedb both have episodes in their list for season 15 aswell.

 

I added screenshots & the serverlog.

post-78695-0-49263300-1588182898_thumb.jpg

post-78695-0-27438600-1588182906_thumb.jpg

embyserver.txt

Link to comment
Share on other sites

Hi there, can you please show the complete file and folder naming for the series? thanks.

Link to comment
Share on other sites

jerren

Series folder just has a bunch of folders in it from each individual show. Checked to make sure and there aren't even any hidden items in there.

Link to comment
Share on other sites

Happy2Play

On the series if you select Edit Metadata, what External IDs are listed for the series?

Edited by Happy2Play
Link to comment
Share on other sites

jerren

It has IMDB - TheMovieDb - TheTVDB & Zap2it

 

Checked all the links to be sure and besides zap2it they all have all seasons & episodes, zap2it just didn't load but it's the last in the list so it shouldn't matter i think.

I did notice that the 1 episode being shown as special in season 15 is actually episode nr4 of season 15, no idea if that helps any. I also checked and season 15 episodes have the same naming scheme as all other seasons.

 

Checked season metadata of the show and only see a possibility for a TVDB id but it's empty and couldn't find a link for season on it, appearantly they stopped doing that for seasons according to what i could find online.

Link to comment
Share on other sites

Happy2Play

Minus a database issue I am not seeing anything wrong.

 

If you created a new folder and pointed a new library to that folder and added this issue item, does it work?

Link to comment
Share on other sites

jerren

Ok Just tried it and when i put the supernatural folder as a library folder i get no images (Only backdrop & episode previews that emby renders from the episode) but it did show all episodes in season 15 (didn't think to check the others). But when i put it in an extra folder (test\supernatural) then it only shows the special episode like it did before. Thought i would check since atm it's in a folder structure "series\supernatural" and i would like to keep it with the rest of the series.

 

Also just noticed that in next up no season 15 episode is being shown, not even the incorrect "special episode" that's actually episode nr4.

Edited by jerren
Link to comment
Share on other sites

Happy2Play

Not sure the as I have no issues with series in my "\TV Series" folder library, (\TV Series\Supernatural (2005)\Season 15).

 

Only other variable I see is language, but that should only apply to metadata, not series presentation.

 

Are there any differences in Metadata Manager or Folders Tab?

Link to comment
Share on other sites

jerren

Don't see a difference at the moment but that's to be expected since it shows the same as before.

 

I did make the show it's own library now to check the metadata, sadly you can't see that in librarysettings it seems. Got screens to show that it does show the episodes. I can't seem to put metadata on that show if it's a library though.

post-78695-0-16769800-1588304056_thumb.jpg

post-78695-0-93225900-1588304063_thumb.jpg

Edited by jerren
Link to comment
Share on other sites

Don't see a difference at the moment but that's to be expected since it shows the same as before.

 

I did make the show it's own library now to check the metadata, sadly you can't see that in librarysettings it seems. Got screens to show that it does show the episodes. I can't seem to put metadata on that show if it's a library though.

Did you create a library based on a series folder?

Link to comment
Share on other sites

jerren

Attempt 1: Don't see a difference at the moment but that's to be expected since it shows the same as before.

 

Attempt 2: I did make the show it's own library now to check the metadata, sadly you can't see that in librarysettings it seems. Got screens to show that it does show the episodes. I can't seem to put metadata on that show if it's a library though.

 

I adjusted what i did in the quotes there, i can see how it's a bit unclear. So yeah in attempt 2 i did, just to see what it would do, clearly nothing, it just showed the contents of each folder and since none were an actual show it couldn't fetch any metadata i get that. I just wanted to try it and atleast it verified that the files in the folder are visible to emby even if it couldn't load metadata for it in the normal folder structure.

 

And to clarify attempt 1: i made a library with a folder structure like this --- test/seriesname/seasonx  ---- It showed every season and the episodes of every season except season 15 just like the situation that i had posted about originally

Link to comment
Share on other sites

jerren

As i showed in my previous post, i made 2 attempts with that.

 

Attempt 1: i did testfolder/seriesfolder/seasonfolders

 

Attempt 2: I did seriesfolder/seasonfolders

 

So attempt 1 gave me the same result/view as i had originally, namely that in season 15 only a "special" episode was being shown (while it was actually episode nr4 of that season and no other episodes. Metadata linked to the correct id's just like in my normal series library.

 

Attempt 2; i saw the folder for each folder in the library. As in i could click the test library but since that was linked to the seriesfolder it took me straight to a view of every season. So i saw 15 folders/tiles and in season 15 i could see every episode, shown with the filenames they have.

 

So to me that shows that emby can see the episodes, but for some reason when it has to put metadata on  season 15 episodes it doesn't do what it's supposed to. I thought it might have been because of bad metadata but checking all the metadata links that emby provides itself for the show check out and actually offers the correct links.

Link to comment
Share on other sites

Happy2Play

@@Luke why are these being parsed and fetched as Season 0, episode 0?  Is something with the naming?

 

 

 

2020-04-29 05:20:07.526 Info MediaProbeManager: ProcessRun 'ffprobe' Execute: C:\Users\Media\AppData\Roaming\Emby-Server\system\ffprobe.exe -i file:"F:\Series\Supernatural\Seizoen 15\Supernatural.S15E04.Atomic.Monsters.1080p.AMZN.WEB-DL.DDP5.1.H.264-NTG.mkv" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data
2020-04-29 05:20:07.631 Info MediaProbeManager: ProcessRun 'ffprobe' Process exited with code 0
2020-04-29 05:20:07.726 Info HttpClient: GET https://api.themoviedb.org/3/tv/1622/season/0/episode/0?api_key=f6bd687ffa63cd282b6ff2c6877f2669&append_to_response=images,external_ids,credits,videos&language=nl&include_image_language=nl,null,en

 

As for testing above you will not get desired results pointing a library to a Series folder, as all the seasons folder become Series instead of seasons.

Link to comment
Share on other sites

Those should not be so I'm not sure. Is there an nfo file for it?

Link to comment
Share on other sites

Happy2Play
<displayorder>dvd</displayorder> 

@@Luke I can't remember, did you change TVDB plugin to use DVD info or is it still using Combined?  If so this could explain the Season 0 Episode 0.

 <Episode>
    <id>7241296</id>
    <Combined_episodenumber>1</Combined_episodenumber>
    <Combined_season>15</Combined_season>
    <DVD_chapter>0</DVD_chapter>
    <DVD_discid/>
    <DVD_episodenumber>0</DVD_episodenumber>
    <DVD_season>0</DVD_season>
    <Director>|John F. Showalter|</Director>
    <EpImgFlag/>
    <EpisodeName>Back and to the Future</EpisodeName>
    <EpisodeNumber>1</EpisodeNumber>
    <FirstAired>2019-10-10</FirstAired>
    <GuestStars/>
    <IMDB_ID>tt9695548</IMDB_ID>
    <Language>nl</Language>
    <Overview/>
    <ProductionCode/>
    <Rating>7</Rating>
    <RatingCount>22</RatingCount>
    <SeasonNumber>15</SeasonNumber>
    <Writer>|Andrew Dabb|</Writer>
    <absolute_number>308</absolute_number>
    <airsafter_season>0</airsafter_season>
    <airsbefore_episode>0</airsbefore_episode>
    <airsbefore_season>0</airsbefore_season>
    <filename>episodes/78901/7241296.jpg</filename>
    <lastupdated>1570109946</lastupdated>
    <seasonid>815181</seasonid>
    <seriesid>78901</seriesid>
    <thumb_added>2019-11-13 12:10:10</thumb_added>
    <thumb_height>360</thumb_height>
    <thumb_width>640</thumb_width>
  </Episode>
Edited by Happy2Play
Link to comment
Share on other sites

I did, although I thought it double checks against zero values. I'll have to check that.

Link to comment
Share on other sites

RobinM

I have similar issue, all episodes are on disk. Refreshing metadata or identifying it again does not help.

5eb458aa9e443_episodesnotvisible.jpg

Edited by RobinM
Link to comment
Share on other sites

RobinM

I have found for me it was related to somehow having 2 times Fear the walking dead on disk. 

 

Fear the Walking Dead

Fear The Walking Dead,

 

Both folders had Season 5 folder, but only 1 contained actual files.

 

Have now corrected it.

Edited by RobinM
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...