Jump to content
jordy

Internet bitrate limit limiting LAN traffic

Recommended Posts

jordy
Posted (edited)

Hi @@ebr,

 

Android TV stats show that this movie is transcoding due to "Video Bitrate Exceeds Limit"

Audio was expected to transcode due to playback through TV/headphones

Playback rate set at Auto in ATV app

Home Network Quality set to 4k - 120Mbps

User Transcoding: Audio and Video Allowed

Ethernet connection

An ffmpg "Transcoding" log was produced which suggests Video encoding happened when it shouldn't have as the shield is capable of Direct Playback of this video - as proven when Video Trancoding is turned OFF

 

As a test, I set Video transcoding  = Not allowed and ATV Playback rate to 100Mbps

This time, an ffmpg "Remux" log was produced - for the Audio i presume.

Playback still worked fine but ATV Stats still show "Video Bitrate Exceeds Limit"

 

Not sure why - Bug?

 

Attached: 2*Server logs, 2*ffmpg logs, MediaInfo, image of ATV stats for the test playback

embyserver-Original Playback.txt

ffmpeg-transcode-Original playback.txt

embyserver-Test Playback.txt

ffmpeg-remux-Test palyback.txt

post-196-0-34343600-1587915681_thumb.png

post-196-0-64087700-1587915719_thumb.jpg

Edited by jordy

Share this post


Link to post
Share on other sites
ebr

The log shows that the requested bitrate was 4.6Mb/s.  The item is 5.4Mb/s.  That is why it transcoded.

Share this post


Link to post
Share on other sites
jordy
Posted (edited)

Ok, So, Can you tell where the requested rate of 4.6Mbps is set? afaik, I have either everything set on Auto or the best rate in the list...

 

EDIT:

I think I found it, but I'm a little confused. I went through every page and one by one checked all bitrate settings that i could find. The only one low enough to provide a "requested rate of 4.6Mbps was my User - Internet Streaming Bitrate Limit. It was set to 5Mbps (slow upload speed). As a test, I set it to an arbitrary 30Mpbs.

 

I then tested playback on the shield with my highest 10bit, HEVC bitrate movie with AAC audio - some 15.49kbps. it played "Direct"  I then reset the User - Internet Streaming Bitrate Limit back to 5Mbps and tested again with the same movie - It transcoded to 4.6Mbps...

 

Why should/does this setting affect playback on my Internal, Ethernet, LAN connected Shield? The setting title CLEARLY states Internet Streaming Bitrate Limit. Last time I checked, "Internet" meant External WAN ie NOT part of my "in House" LAN...

 

thanks.

 

EDIT 2: and before you ask, the shield is connected to Emby server using its internal IP address 10.0.0.45:8096

Edited by jordy

Share this post


Link to post
Share on other sites
ebr

Hi. Do you have a proxy or something else that can be fooling your server into thinking the client is remote?

Share this post


Link to post
Share on other sites
jordy
Posted (edited)

yes, I run Caddy and a VPN. Not sure that it is the problem though. Whilst looking through the server for Bitrate settings I also noted that the same titled setting "Internet Streaming Bitrate Limit" appears in the Network tab/page, and that was also set at 5Mbps - and it still is. It obviously has no impact on internal network bitrates (as I haven't changed it), assuming that their identical titles mean that they both mean/do the same thing - the Network setting being Global (Total Allowed Internet bitrate) whilst the User settings are sub settings that spread it around evenly.

 

I would think that if the Caddy proxy and/or VPN affects one then surely it should affect both? Perhaps it is just an issue with the user setting that is causing this.

Edited by jordy

Share this post


Link to post
Share on other sites
jordy

@@Luke? Are you looking at this? An acknowledgement would be nice...

Share this post


Link to post
Share on other sites
rbjtech

Under Server > Network > force the bind to the local (10.0.0.0/8) address of emby.  It may be picking up the VPN address, thus adhering to the Internet bitrate limit ?

Share this post


Link to post
Share on other sites
jordy

Under Server > Network > force the bind to the local (10.0.0.0/8) address of emby.  It may be picking up the VPN address, thus adhering to the Internet bitrate limit ?

Thanks for the suggestion. I already have that set due to emby showing the wrong LAN IP on the dashboard.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...