Jump to content


Photo

Server not auto-scanning for new media


  • Please log in to reply
8 replies to this topic

#1 Sizzlebox OFFLINE  

Sizzlebox

    Advanced Member

  • Members
  • 70 posts
  • Local time: 08:05 AM

Posted 07 April 2020 - 07:28 PM

I have a fresh install of the newest version of emby on my QNAP 451+. Before I transfer over all of my files to my NAS for emby, I am doing some tests. I am not able to get emby to recognize new media when it is transferred or downloaded into library files. I even set up a recurring task to check for new media, it is also not working.

If I click the "tv" -> scan for new media, it does work. It seems to be the only way.

 

Am I missing something?

Attached Files



#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 19145 posts
  • Local time: 06:05 AM
  • LocationWashington State

Posted 07 April 2020 - 07:56 PM

Seems to be a theme here across different systems.  Have you verified permissions?

 

https://emby.media/c...an-movies-empty

https://emby.media/c...n-movie-folder/



#3 Sizzlebox OFFLINE  

Sizzlebox

    Advanced Member

  • Members
  • 70 posts
  • Local time: 08:05 AM

Posted 07 April 2020 - 08:19 PM

I thought maybe it would be a permissions issue. I made sure guest access has full read, write, and delete privileges. I do not see an "emby server" user anywhere to customize their access. I am currently logging in and running as the admin user.



#4 Sizzlebox OFFLINE  

Sizzlebox

    Advanced Member

  • Members
  • 70 posts
  • Local time: 08:05 AM

Posted 07 April 2020 - 08:24 PM

Would the "@recently-snapshot" name cause a server error because of the special character?



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:05 AM

Posted 08 April 2020 - 01:06 PM

What do you mean by recently snapshot?

#6 Sizzlebox OFFLINE  

Sizzlebox

    Advanced Member

  • Members
  • 70 posts
  • Local time: 08:05 AM

Posted 08 April 2020 - 01:30 PM

What do you mean by recently snapshot?

This is the name of a folder inside of all of the folders that QNAP creates. Screenshot attached. I assume it is for creating snapshots to revert back to.

5e8e0a2c9fb90_ScreenShot20200408at122910

They are only created inside of folders QNAP makes. When Sonarr or Radarr creates a folder, it does not add a @Recently-Snapshot folder.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:05 AM

Posted 09 April 2020 - 01:00 AM

No that won't cause an error. I wonder if it's just not supported with this file system. Emby Server is built with .NET core which uses INotify for the realtime monitor function. So in order for this to work in Emby, INotify has to support it.

 

 

 

I even set up a recurring task to check for new media, it is also not working.

This will work just fine. Please allow the scan to finish before checking.



#8 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 4297 posts
  • Local time: 02:05 PM
  • LocationWarrington,UK

Posted 09 April 2020 - 03:34 AM

For Info - RTM works fine on my QNAP



#9 Sizzlebox OFFLINE  

Sizzlebox

    Advanced Member

  • Members
  • 70 posts
  • Local time: 08:05 AM

Posted 10 April 2020 - 07:39 PM

Forcing Emby to search every 15 minutes worked.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users