Jump to content


Photo

DNLA - No transcode (not applying user config) // Only direct play on mp4

Freebox mp4 dlna

  • Please log in to reply
9 replies to this topic

#1 Topper69 OFFLINE  

Topper69

    Newbie

  • Members
  • 8 posts
  • Local time: 07:35 PM

Posted 28 March 2020 - 03:15 AM

Hi all,

 

My internet TV box ISP's has recently introduced a bug when playing mp4 format encoded by  "mp4creator 1.6.1d" (other encoders are fine).

 

Long story short, to fix this issue i want to transcode .mp4 files to another format. I tryed many templated, none of them worked. Always on direct play.

Played also with DirectPlayProfile, TranscodingProfile, ContainerProfile & Conditions, CodecProfile & Condition, etc.. and i never try to transcode when playing .mp4 files through DLNA.

 

DNLA is configured to match (successfully):

	DeviceDescription:
	FriendlyName:Freebox Player
	Manufacturer:Freebox SAS
	ManufacturerUrl:http://www.freebox.fr
	ModelDescription:Freebox UPnP Renderer
	ModelName:Freebox
	ModelNumber:6
	ModelUrl:http://www.freebox.fr
	SerialNumber:0

On web browser everything is fine and transcoded.

 

On the current FREEBOX.xml DLNA profile, you see that mp4 direct play profile is missing, so should trancode when playing one. But didn't.

 

I have only 1 user configured and have all access to transcode / recode rights.

 

emby version : 4.4.0.40

dlna version plugin : 1.0.37.0

 

See attached:

-media metada of mp4 file working file

-media metada of mp4 with issue

-embyserver logs with dlna when playing mp4 file (with issue)

-embyserver logs with web browser with no issue

-my user DLNA config file "FREEBOX"

 

I don't fully understand the use of "ProtocolInfo". Could you clarify what it is for and what needs to be added?

 

Could you help?

 

Thx & Greetings

Attached Files


Edited by Topper69, 28 March 2020 - 03:22 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156697 posts
  • Local time: 02:35 PM

Posted 31 March 2020 - 01:11 PM

Hi, did you edit the dlna profile using the web interface, or by editing the file?



#3 Topper69 OFFLINE  

Topper69

    Newbie

  • Members
  • 8 posts
  • Local time: 07:35 PM

Posted 31 March 2020 - 01:16 PM

Hi,

 

I try both.
When i direct edit the file, then i restart emby (sudo service emby-server restart)

 

Thanks.

 

Regards



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156697 posts
  • Local time: 02:35 PM

Posted 31 March 2020 - 01:21 PM

So maybe it's not getting matched to that profile then?



#5 Topper69 OFFLINE  

Topper69

    Newbie

  • Members
  • 8 posts
  • Local time: 07:35 PM

Posted 31 March 2020 - 01:23 PM

I think it is because on the log we see that "Info Dlna: DLNA Session created for Freebox Player - Freebox" : it match and load it.



#6 level10 OFFLINE  

level10

    Newbie

  • Members
  • 6 posts
  • Local time: 09:35 PM

Posted 07 April 2020 - 05:12 AM

Hi all,
 
@Topper69,  reading your appeal, I think your knowledge is enough to help me solve the problem described in this appeal - https://emby.media/c...-to-describe-it -correctly /
To be brief, there are two Samsung TVs on the local network:
-TV Samsung UE40H5303 - directly reproduces most popular formats, everything is OK with it;
-TV Samsung UE55RU8000 - does not directly reproduce, at least, sound in dts format. It requires a separate user DLNA profile with transcoding.
 EMBY Server has a pre-installed DLNA profile "Samsung Smart TV", which indicates only one identification parameter: 
<Identification>
    <ModelUrl> samsung.com </ModelUrl>


When creating a user profile for Samsung UE55RU8000 TV with more precise matching parameters, EMBY Server in each case selects the pre-installed DLNA profile "Samsung Smart TV" (probably, as the profile with the widest match)
 
All attempts to edit the pre-installed DLNA profile "Samsung Smart TV" lead to the creation of a new user profile, and the profile "Samsung Smart TV" remains unchanged.
 
DNLA is configured to match (unsuccessfully)
<Name>Samsung 8 Series</Name>
  <Identification>
    <FriendlyName>Samsung 8 Series</FriendlyName>
    <ModelNumber>UE55RU8000UXUA</ModelNumber>
    <SerialNumber />
    <ModelName>Samsung 8 Series (55)</ModelName>
    <DeviceDescription />
    <ModelUrl>samsung.com</ModelUrl>
    <Manufacturer />
    <ManufacturerUrl />
 
 
 
Logs
 
2020-04-06 01:18:07.156 Debug Dlna: Dlna Device.Start
2020-04-06 01:18:07.161 Debug HttpServer: HTTP Response 200 to 192.168.1.12. Time: 12ms. http://192.168.1.177:8096/dlna/180de1ec9dc44c75af102096f51c9012/contentdirectory/contentdirectory.xml
2020-04-06 01:18:07.169 Debug Dlna: Found matching device profile: Samsung Smart TV
2020-04-06 01:18:07.186 Info Dlna: DLNA Session created for [TV] Samsung 8 Series (55) - UE55RU8000UXUA
2020-04-06 01:18:07.188 Debug Dlna: Attempting to create PlayToController from location http://192.168.1.92:9197/dmr
 
 
How can I “convince” EMBY Server to use its own DLNA profile for the Samsung UE55RU8000 TV?
 
Sorry to ask questions in your topic.
Could you help?
Thx 


#7 Topper69 OFFLINE  

Topper69

    Newbie

  • Members
  • 8 posts
  • Local time: 07:35 PM

Posted 07 April 2020 - 05:44 AM

Hi,

 

@level10 i think you could try this

1) remove the generic Samsung Smart TV from the template (save it in backup somewhere else). If you're in debian base distro, they are in "/var/lib/emby/config/dlna/system/Samsung Smart TV.xml"

2) create a specific template for each of your TV (fill all data as FriendlyName ModelNumber SerialNumber ModelName DeviceDescription ModelUrl Manufacturer ManufacturerUrl)

 

In this case, emby will select always the specific profile for each of your TV.



#8 level10 OFFLINE  

level10

    Newbie

  • Members
  • 6 posts
  • Local time: 09:35 PM

Posted 07 April 2020 - 05:54 AM

Thanks for the quick response, @Topper69
I already tried to do this - unsuccessfully.
I have Win, the path to the templates is 
c: \ Users \ AppData \ Roaming \ Emby-Server \ programdata \ config \ dlna \ system \
When I delete the DLNA profile “Samsung Smart TV” from this folder, after rebooting, the ”EMBY Server - profile“ Samsung Smart TV ”is back there.
 
 
I also tried to rename the Samsung Smart TV.xml file, after rebooting EMBY Server - two files appear in the folder: the renamed and the new Samsung Smart TV.xml file.

Edited by level10, 07 April 2020 - 06:01 AM.


#9 Topper69 OFFLINE  

Topper69

    Newbie

  • Members
  • 8 posts
  • Local time: 07:35 PM

Posted 07 April 2020 - 05:58 AM

Ok then try :

 

 

 

open the "Samsung Smart TV.xml" and edit the inside with one of your TVs config. Then reboot emby. Open again with notepad to see if the file is overwritten or not.



#10 level10 OFFLINE  

level10

    Newbie

  • Members
  • 6 posts
  • Local time: 09:35 PM

Posted 07 April 2020 - 06:47 AM

I already tried to do this - unsuccessfully.
After rebooting, the file is in its original form.
You wrote: "I have only 1 user configured and have all access to transcode / recode rights."
I have several users, but I make all attempts with the admin user.
Perhaps the problem is here somewhere?
 
Anyway, thanks for the tips.






Also tagged with one or more of these keywords: Freebox mp4, dlna

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users