Jump to content

DLNA cast to Naim Unity Atoms don't work


Sysyphus_
 Share

Recommended Posts

Sysyphus_

Hello,

First thank you for the great work done in Emby. I wrote this post about a problem I have when I cast music to my Naim Unit Atom amplifier in the WebUI.

If I play an album there is a few problems :

  • No play bottom bar appea
  • Only the first track is played
  • When I click on the cast button on the upper right, and select "Control", in the new screen nothing appear (only the main controls)
  • I can't control the volume

 

I attach the log file with DLNA Debug info check in server parameters (server restarted), but there is nothing relevant I think (a UPnPError with Transition not available only), do I check the wrong file ?

Note that DLNA works fine in WebUI for an another system of the same brand (a Naim MuSo). And note that problem is the same with DLNA in the Android App but Goggle Cast work.

Notice that for all my DLNA hardware, volume control have a lot of lag and is very difficult to control with the slider not accurate. But it's an another problem...

I have by a lifetime subscription because I love Emby, I think the team make a great job and I want to support the new developments. DLNA control is for me, one of the most import feature and I hope I can help to solve the problem with my hardware.

 

 

Thank you in advance for your help.

 

PS: I'm an confirmed C# developer so you can use advanced technical language if it's help

PS2: Sorry for my english...

embyserver.txt

Edited by Sysyphus_
Link to comment
Share on other sites

Hi, can you enable debug logging under logs, then try again and attach a new log? thanks.

Link to comment
Share on other sites

Sysyphus_

Hello,

 

Thank for you're attention. Sorry I missed the other debug option to active.

I have attach a new log file with debug and DLNA debug ON. I have started the server with a fresh file (already logged before) and just click on play all to an album view and stop the server after the second track doesn't play.

 

embyserver.zip

Link to comment
Share on other sites

Well now I'm really not sure because the first log had this:

2020-03-24 20:07:44.796 Error HttpClient: <?xml version="1.0"?><s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>UPnPError</faultstring><detail><UPnPError xmlns="urn:schemas-upnp-org:control-1-0"><errorCode>701</errorCode><errorDescription>Transition not available</errorDescription></UPnPError></detail></s:Fault></s:Body></s:Envelope>

But nothing like that in the second one.

Link to comment
Share on other sites

The reason I wanted to see the debug log was to find out the events that happened just prior to that.

Link to comment
Share on other sites

Right now I'm not sure yet. I think it's not recognizing that the first track ended.

Link to comment
Share on other sites

Sysyphus_

I think the first problem is that when I play the track, the play bar at the bottom don't appear. It's like the Naim Atom's take the inputs from Kodi but respond in an incorrect manner or there is no responses.

Excuse me if I say wrong things, I don't know how DLNA and UPNP protocol works exactly.

Keep me informed if you want others try or logs, It will be very nice if DLNA work my Naim Atom.

 

An another thank to yours responses.

Edited by Sysyphus_
Link to comment
Share on other sites

Sysyphus_

Hello,

 

Do you have any news ?

May I hope that the issue is taken into account ?

Do I need to open an issue on the GitHub ?

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...
Sysyphus_

Thank,

But is there a chance that the problem will be taken in account ? DLNA, It's for me a major feature. And all other applications can't cast because of this problem.

I contact Naim also and post a ticket for the problem but I have only a few information to give to them.

 

Is there a special support for Lifetime Premium member or a thing like that ?

 

Best regard

Edited by Sysyphus_
Link to comment
Share on other sites

Hi, I'd have to get a Naim Unity Atoms device in order to test this and find out what's going on. Thanks.

Link to comment
Share on other sites

Sysyphus_

It will be problematic it's high price device... But I just have a response from Naim's customer support and it's a technical response.

I forward to you the response :

 

 

I had a look at Emby and it seems to be a bit incomplete in implementation:

  • It doesn’t use the SetNextTransportURI api (see screenshot), so is dependent on listening to the right events to appreciated track is finishing to queue the next track. From wiresharking the comms its not doing it properly so will be very delicate if it works or not. See screenshot attached.

  • On Volume I couldn’t replicate the issue you report. I’m using the Win x64 version of the app, but it sends out the correct API calls and Atom is responding. For reference on exercising API compliance tools see: https://www.meshcommander.com/upnptools

For reference we have used Audirvarna’s interpretation of the UPnP spec for gapless playback (and play queues that don’t randomly stall due to control device sleeping), as there is huge variation of how to use the API’s so we decided to sync up with Aurirvana who more focus around a high end experience.

 

5ea694e9d018a_naimspic.png

 

With regards

Steve Harris
Software Director
Naim Audio Ltd.

 

 

 

I have a full professional .net environment installed on my personal computer. If you want I can pull a fix branch from GitHub and test the correction you want. I can implement the correction to if you say to me what to do.

 

Hopes we can find a solution together.

Thank you for helping me and your response.

 

 

 

 

 

 

 

Link to comment
Share on other sites

Well yes that's true, but we still need the events because the user could add to the play queue after playback has started.

 

Can you get more information on the events?

Link to comment
Share on other sites

Sysyphus_

Hello,

 

what's you need exactly, the event send by the Naims ? I will try to explain to Naim's expert.

Thank you for the help.

Link to comment
Share on other sites

  • 2 weeks later...

 

 

Can I help you to find events of Atom's send, perhaps using WireShark ?

Yes that would be great, thanks !

Link to comment
Share on other sites

  • 2 weeks later...
Sysyphus_

Hello,

 

Sorry for the late. I do not abandon the DLNA compatibilty. I have received a response from Naims but I think it don't help. I don't have DLNA event from us...

So I will proceed reverse engineering the Atoms, sniffing the LAN.

 

What kind of trace do you want ? I play an album and I send the traffic between Emby server and amplifier, normally it will stop after the first song ? Only TCP ? I capture Emby DLNA debug log to ?

 

Thank for the help, it's very appreciated.

Link to comment
Share on other sites

  • 2 weeks later...
Sysyphus_

Ok, I will try to do this as soon as possible, I'm a little busy with the takeover after the COVID19 shutdown.

Thank for your response

Link to comment
Share on other sites

  • 1 month later...
Sysyphus_

Hello,

 

Sorry for the wait time. I have made a capture of the traffic with Wireshark and with Emby logs. How I can send it to you privately ?

Thank you for the help

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...