Jump to content


Photo

DLNA cast to Naim Unity Atoms don't work

DLNA Music Naim

  • Please log in to reply
8 replies to this topic

#1 Sysyphus_ OFFLINE  

Sysyphus_

    Newbie

  • Members
  • 9 posts
  • Local time: 04:21 AM

Posted 24 March 2020 - 03:35 PM

Hello,

First thank you for the great work done in Emby. I wrote this post about a problem I have when I cast music to my Naim Unit Atom amplifier in the WebUI.

If I play an album there is a few problems :

  • No play bottom bar appea
  • Only the first track is played
  • When I click on the cast button on the upper right, and select "Control", in the new screen nothing appear (only the main controls)
  • I can't control the volume

 

I attach the log file with DLNA Debug info check in server parameters (server restarted), but there is nothing relevant I think (a UPnPError with Transition not available only), do I check the wrong file ?

Note that DLNA works fine in WebUI for an another system of the same brand (a Naim MuSo). And note that problem is the same with DLNA in the Android App but Goggle Cast work.

Notice that for all my DLNA hardware, volume control have a lot of lag and is very difficult to control with the slider not accurate. But it's an another problem...

I have by a lifetime subscription because I love Emby, I think the team make a great job and I want to support the new developments. DLNA control is for me, one of the most import feature and I hope I can help to solve the problem with my hardware.

 

 

Thank you in advance for your help.

 

PS: I'm an confirmed C# developer so you can use advanced technical language if it's help

PS2: Sorry for my english...

Attached Files


Edited by Sysyphus_, 24 March 2020 - 03:36 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:21 PM

Posted 24 March 2020 - 05:36 PM

Hi, can you enable debug logging under logs, then try again and attach a new log? thanks.



#3 Sysyphus_ OFFLINE  

Sysyphus_

    Newbie

  • Members
  • 9 posts
  • Local time: 04:21 AM

Posted 25 March 2020 - 02:48 PM

Hello,

 

Thank for you're attention. Sorry I missed the other debug option to active.

I have attach a new log file with debug and DLNA debug ON. I have started the server with a fresh file (already logged before) and just click on play all to an album view and stop the server after the second track doesn't play.

 

Attached Files



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:21 PM

Posted 25 March 2020 - 09:09 PM

Well now I'm really not sure because the first log had this:

2020-03-24 20:07:44.796 Error HttpClient: <?xml version="1.0"?><s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>UPnPError</faultstring><detail><UPnPError xmlns="urn:schemas-upnp-org:control-1-0"><errorCode>701</errorCode><errorDescription>Transition not available</errorDescription></UPnPError></detail></s:Fault></s:Body></s:Envelope>

But nothing like that in the second one.



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:21 PM

Posted 25 March 2020 - 09:09 PM

The reason I wanted to see the debug log was to find out the events that happened just prior to that.



#6 Sysyphus_ OFFLINE  

Sysyphus_

    Newbie

  • Members
  • 9 posts
  • Local time: 04:21 AM

Posted 26 March 2020 - 05:36 AM

How can I help you ?



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:21 PM

Posted 26 March 2020 - 10:08 AM

Right now I'm not sure yet. I think it's not recognizing that the first track ended.

#8 Sysyphus_ OFFLINE  

Sysyphus_

    Newbie

  • Members
  • 9 posts
  • Local time: 04:21 AM

Posted 26 March 2020 - 01:49 PM

I think the first problem is that when I play the track, the play bar at the bottom don't appear. It's like the Naim Atom's take the inputs from Kodi but respond in an incorrect manner or there is no responses.

Excuse me if I say wrong things, I don't know how DLNA and UPNP protocol works exactly.

Keep me informed if you want others try or logs, It will be very nice if DLNA work my Naim Atom.

 

An another thank to yours responses.


Edited by Sysyphus_, 26 March 2020 - 01:56 PM.


#9 Sysyphus_ OFFLINE  

Sysyphus_

    Newbie

  • Members
  • 9 posts
  • Local time: 04:21 AM

Posted 30 March 2020 - 05:27 AM

Hello,

 

Do you have any news ?

May I hope that the issue is taken into account ?

Do I need to open an issue on the GitHub ?







Also tagged with one or more of these keywords: DLNA, Music, Naim

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users