Jump to content

New Plugin - Samsung SmartThings


chef
 Share

Recommended Posts

Any chance of writing on new Samsung SmartThings plug in for Vera?

 

Sent from my SM-G960U1 using Tapatalk

I'm sorry @@Sammy, I'm not very good with writing vera plugins. You might have to ask someone from their community to write something like that.

Link to comment
Share on other sites

Do you have a link to the API?

 

Sent from my SM-G960U1 using Tapatalk

What would you like to have happen between vera and smart things?

 

 

The vera api docs can be found in their site. I can never remember the exact place, but if you Google "Vera http rest API" it'll take you right to the page.

 

There is a guy in the Vera forms "rigpapa". He is a master of vera plugins.

 

FYI, they're all written in Lua code. That is why I didn't really grasp the whole thing.

Link to comment
Share on other sites

What would you like to have happen between vera and smart things?

 

 

The vera api docs can be found in their site. I can never remember the exact place, but if you Google "Vera http rest API" it'll take you right to the page.

 

There is a guy in the Vera forms "rigpapa". He is a master of vera plugins.

 

FYI, they're all written in Lua code. That is why I didn't really grasp the whole thing.

 

Does Smart Things have an API? I'll post in the Vera Forums or maybe ask Patrick (rigpapa) directly. Thanks.

Link to comment
Share on other sites

  • 3 weeks later...

Thanks for this @@chef!

 

I’m going to be moving soon and will have a combination of hardwired pot lights on z-wave switches and my Hue lights and was wondering how I was going to combine them to still work with Emby events. Your time if is perfect!

Link to comment
Share on other sites

@@chef, dont have a Smartthings hub yet but wanted to check out the plugin to see how its set up. Running into an issue using a Mac on Safari where you cant scroll down past the Live TV configuration section. Screenshot attached. Note that this does work correctly using Chrome.

 

post-45887-0-89271000-1585312832_thumb.png

  • Like 1
Link to comment
Share on other sites

I have updated the plugin. P{lease let me know if you still experience layout issues on OSX :)

Link to comment
Share on other sites

I have updated the plugin. P{lease let me know if you still experience layout issues on OSX :)

 

Afraid that made things worse. Can’t even scroll past the movie settings section now. Safari on a Mac and an iPad. Chrome still works though.

  • Like 1
Link to comment
Share on other sites

Okay. Sorry that happened. I will take another look at the dialog and see how I can fix.

Link to comment
Share on other sites

  • 2 weeks later...

I have Smartthings set up to turn off the light during playback then turn on the light after playback ends.  It works great when playing one video. However, if I have a playlist running, the light then turns on and off between episodes.  Would it be possible to suppress this behavior?

Link to comment
Share on other sites

I have Smartthings set up to turn off the light during playback then turn on the light after playback ends. It works great when playing one video. However, if I have a playlist running, the light then turns on and off between episodes. Would it be possible to suppress this behavior?

The side effect of this will be that the lights won't turn on right away after a complete stop of media playback. There will be a pause while the plugin waits to see if something else plays.

 

If this is okay, then I will add the functionality.

Link to comment
Share on other sites

The side effect of this will be that the lights won't turn on right away after a complete stop of media playback. There will be a pause while the plugin waits to see if something else plays.

 

If this is okay, then I will add the functionality.

PLEASE dont make it operate this way by default!  :(  Sitting there in the dark after a video stops would be very distracting. You would alway be wondering "did the plugin just failed" every time a movie ends. If you do decide to add this, can you add it as a togglable option?

Edited by hstamas
  • Like 1
Link to comment
Share on other sites

Oooh I dont like that if I get any vote :( Sitting there in the dark after a video stops would be very distracting and would make you wondering if the plugin failed. PLEASE, if you add it make it a selectable option.

Will do. Not to worry, I can make this optional. I didn't start work on it yet because I wanted to see what people had to say about it.

 

Just needed one person to ask for it to be optional.

Edited by chef
Link to comment
Share on other sites

Sounds good to me if it's optional.  Thanks for the quick feedback.

Edited by nnylray
Link to comment
Share on other sites

Hi Chef,

 

Thanks for the plugin!

Oh my goodness! Is that you fanataxp7!!!! Amazing!

  • Like 1
Link to comment
Share on other sites

Oh my goodness! Is that you fanataxp7!!!! Amazing!

hahaha I've been a ghost. Had to say hello as I happened to have a need for this plugin and certainly recognized the dev  :)

Link to comment
Share on other sites

Chef, thanks for the great plugin, something that all of us with dedicated media rooms can use. A feature request to go with this plugin, I'm assuming Emby gets metadata that lets it know how long a movie run time is? Currently when I bring the movie up to play it, I can see what time the movie will end. Do you have any way to make an option that we can choose to run another scene in Smartthings at a designated time before a movie ends? ie: I run a Smartthings scene about 3-5 minutes out from the movies run time end, when the credits are showing that will bring all of my lighting back up to 100% over a 3 minute time frame. An option to do that would fully automate watching a movie experience.

Link to comment
Share on other sites

  • 4 weeks later...

Hi @@chef.

 

Ran into a small glitch with the pause part of the plugin. When you hit pause, the pause scene triggers but then it sort of glitches and turns off all the lights. If you unpause then pause again, the correct scene triggers and then works properly until you pause again.

 

Let me know what I can do to help trouble shoot if you have the time to look at it.

 

Thanks.

Link to comment
Share on other sites

Chef, did you ever post the update you had me test back in April? That one seems to work for the most part, haven’t had time to test the “Credits” scene again. I did send the log to you in the last test I did.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...