Jump to content
refos

Reading a http/mp3 strm link end up in "no comptatible flux is available" in firefox

Recommended Posts

refos

Hi,

 

I have this Music media structure dedicated to radios:

 

/Radios/

 

Using:

 

/Radios/france-musique% cat france-musique.strm
http://icecast.radiofrance.fr/francemusique-midfi.mp3
 

I've got the mentioned error (translated).

 

The server logs give me this:

 

2020-01-20 11:26:21.896 Info HttpServer: HTTP Response 400 to 172.27.101.2. Time: 297ms. https://emby.unix4.home:8920/Audio/29454/universal?UserId=aa4788bcec544393a7a5570eb27943eb&DeviceId=TW96aWxsYS81LjAgKFgxMTsgRmVkb3JhOyBMaW51eCB4ODZfNjQ7IHJ2OjYzLjApIEdlY2tvLzIwMTAwMTAxIEZpcmVmb3gvNjMuMHwxNTQyNTQ2NDIxOTM4&MaxStreamingBitrate=140000000&Container=opus,mp3|mp3,aac|aac,m4a|aac,flac,webma,webm,wav,ogg&TranscodingContainer=aac&TranscodingProtocol=hls&AudioCodec=aac&PlaySessionId=1579514075523&StartTimeTicks=0&EnableRedirection=true&EnableRemoteMedia=false
2020-01-20 11:26:21.927 Info HttpServer: HTTP GET https://emby.unix4.home:8920/Audio/29454/universal?UserId=aa4788bcec544393a7a5570eb27943eb&DeviceId=TW96aWxsYS81LjAgKFgxMTsgRmVkb3JhOyBMaW51eCB4ODZfNjQ7IHJ2OjYzLjApIEdlY2tvLzIwMTAwMTAxIEZpcmVmb3gvNjMuMHwxNTQyNTQ2NDIxOTM4&MaxStreamingBitrate=140000000&Container=opus,mp3|mp3,aac|aac,m4a|aac,flac,webma,webm,wav,ogg&TranscodingContainer=aac&TranscodingProtocol=hls&AudioCodec=aac&PlaySessionId=1579514075523&StartTimeTicks=0&EnableRedirection=true&EnableRemoteMedia=false.UserAgent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0
2020-01-20 11:26:21.930 Info App: User policy for *****. EnableAudioPlaybackTranscoding: True
2020-01-20 11:26:21.932 Info HttpClient: HttpClientManager GET: http://icecast.radiofrance.fr/francemusique-midfi.mp3
2020-01-20 11:26:22.007 Error HttpServer: Error processing request
    *** Error Report ***
    Version: 4.2.1.0
    Command line: /usr/local/lib/emby-server/system/EmbyServer.exe -os freebsd -ffmpeg /usr/local/bin/ffmpeg -ffprobe /usr/local/bin/ffprobe -programdata /var/db/emby-server -updatepackage emby-server-freebsd_{version}_amd64.txz
    Operating system: Unix 11.2.0.0
    64-Bit OS: True
    64-Bit Process: True
    User Interactive: False
    Mono: 5.10.1.57 (5.10.1.57 Wed Sep 11 19:29:31 UTC 2019)
    Runtime: file:///usr/local/lib/mono/4.5/mscorlib.dll
    Processor count: 4
    Program data path: /var/db/emby-server
    Application directory: /usr/local/lib/emby-server/system
    System.ArgumentOutOfRangeException: System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
    Parameter name: net_clsmall
     at SocketHttpListener.Net.HttpListenerResponse.set_ContentLength64 (System.Int64 value) [0x00020] in <c737a5c2d7354c39a86e2c84e6c5728f>:0
     at EmbyServer.SocketSharp.WebSocketSharpResponse.SetContentLength (System.Int64 contentLength) [0x00000] in <1d14099c168e47498b4f25ef015de5f5>:0
     at Emby.Server.Implementations.Services.ResponseHelper.WriteToResponse (Emby.Server.Implementations.HttpServer.HttpListenerHost httpListenerHost, MediaBrowser.Model.Services.IResponse response, MediaBrowser.Model.Services.IRequest request, System.Object result, System.Threading.CancellationToken cancellationToken) [0x000d3] in <450b368eae8f4cb8ab4853f8ffe89952>:0
     at Emby.Server.Implementations.Services.ServiceHandler+<ProcessRequestAsync>d__4.MoveNext () [0x001f4] in <450b368eae8f4cb8ab4853f8ffe89952>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <0e06830de9a44394a7e366951eabca52>:0
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <0e06830de9a44394a7e366951eabca52>:0
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <0e06830de9a44394a7e366951eabca52>:0
     at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <0e06830de9a44394a7e366951eabca52>:0
     at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () [0x00000] in <0e06830de9a44394a7e366951eabca52>:0
     at Emby.Server.Implementations.HttpServer.HttpListenerHost+<RequestHandler>d__51.MoveNext () [0x00bd3] in <450b368eae8f4cb8ab4853f8ffe89952>:0
    Source: mscorlib
    TargetSite: Void Throw()
   

 

Reading either:

 - http://icecast.radiofrance.fr/francemusique-midfi.mp3

 - http://direct.francemusique.fr/live/francemusique-midfi.mp3

 

from the browser works fine.

 

Testing connectivity from the server works fine as well:

 

france-musique% curl -v -o /dev/null http://icecast.radiofrance.fr/francemusique-midfi.mp3
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying 99.86.88.73...
* TCP_NODELAY set
* Connected to icecast.radiofrance.fr (99.86.88.73) port 80 (#0)
> GET /francemusique-midfi.mp3 HTTP/1.1
> Host: icecast.radiofrance.fr
> User-Agent: curl/7.59.0
> Accept: */*
>
< HTTP/1.1 200 OK
< Content-Type: audio/mpeg
< Transfer-Encoding: chunked
< Connection: keep-alive
< Date: Mon, 20 Jan 2020 10:41:48 GMT
< icy-br: 128
< ice-audio-info: channels=2;samplerate=48000;bitrate=128
< icy-br: 128
< icy-name: francemusique-midfi.mp3
< icy-pub: 1
< Server: Icecast 2.4.0-kh12
< Cache-Control: no-cache, no-store
< Access-Control-Allow-Origin: *
< Access-Control-Allow-Headers: Origin, Accept, X-Requested-With, Content-Type
< Access-Control-Allow-Methods: GET, OPTIONS, HEAD
< Expires: Mon, 26 Jul 1997 05:00:00 GMT
< X-Cache: Miss from cloudfront
< Via: 1.1 7f5d5e89cfaceb195913fbae292db88a.cloudfront.net (CloudFront)
< X-Amz-Cf-Pop: CDG50-C1
< X-Amz-Cf-Id: AvC1RImReUSCgc8ljaJlBQUu0nlr9-mBANUJYqPJHWu4brBgk8ZNWw==
<
{ [8036 bytes data]
100  151k    0  151k    0     0  39985      0 --:--:--  0:00:03 --:--:-- 39975^C

 

Am I doing something wrong here, or is that a bug ?

 

Regards,
 

Edited by refos

Share this post


Link to post
Share on other sites
Luke

Hi there, can you please attach the complete emby server log? Thanks.

Share this post


Link to post
Share on other sites
Luke

And also can you update to Emby Server 4.3.1?

Share this post


Link to post
Share on other sites
Luke

Why are you installing this way instead of just installing via the freenas web interface? These manual installation packages are really only meant for those who want to beta test. I think you're going to have to follow all of the beta install instructions here:

https://emby.media/freebsd-server.html

 

Or do a new install using the freenas interface.

Share this post


Link to post
Share on other sites
refos

Why are you installing this way instead of just installing via the freenas web interface?

 

Because running the usual pkg update/upgrade didn't bring me the latest 4.3.1 so I fetch it from your release.  I installed it through the freenas plugins originally.  Now why I didn't get the latest through the web interface ... is maybe another topic.

 

 

Or do a new install using the freenas interface.

 

As I put it, it was installed that way, never used the direct package from github.  Now the "consistent" error could be a pointer that something is wrong and maybe it's not my installation.  Everything else is (was) working fine.

 

Now, reproducing this should be easy enough.  You could maybe test it with the url provided and let me know if it works as expected for you.  Then I'll go through more trouble to "re-install" everything and understand why it didn't work through the usual channel.

 

WDYT ?

Share this post


Link to post
Share on other sites
Luke

You can no longer use the 4.3.1 downloadable package because by now freebsd system libs have been updated, therefore you need an updated Emby server package to match. That means the beta server just like I mentioned, or going back to a new install using the FreeNas web interface. Once you jump on the train of using the downloadable packages, you will always need to be on the latest because as your freebsd system updates, the previous packages will no longer be compatible. So we're essentially back to the instructions in my previous posting.

Share this post


Link to post
Share on other sites
refos

Hi,

 

so I've followed the beta setup.

 

pkg install mono libass fontconfig freetype2 fribidi gnutls iconv opus samba48 sqlite3 libtheora libva libvpx libvorbis webp libx264 x265 dav1d libzvbi libraw ImageMagick6

 

resulted in nothing new installed.

 

Note that you have a typo in that line.  It should be "libiconv", not "iconv" as "iconv" resulted in:

 

pkg: No packages available to install matching 'iconv' have been found in the repositories

 

In any case now I'm on 4.4.0.9 and .... drums rolling ... I still have exactly the same issue.

 

Can we go back to my issue and check why it's not working.  For instance can you reproduce the error or not ?  Here is a example of how the "radio" related file looks like:

 

 

root@emby:~ # cat /mnt/radios/fip/fip.strm                                                                                                                                                                         
http://direct.fipradio.fr/live/fip-midfi.mp3
 

the media mount point in emby is /mnt/radios.

 

 

 

Attached latest logs.

 

Regards,

 

PS: I usually update emby through the plugins only but this time it didn't go to 4.3** and stayed at 4.2 that's why I used the 4.3 package from github.  Now I have a snapshot of it before the update.  I will revert at some point, and will open a new issue as why 4.2 doesn't update to 4.3 the normal way.

 

PPS: I have a premiere key in case it changes anything.

Share this post


Link to post
Share on other sites
Luke

Did you follow all of the beta instructions?

Share this post


Link to post
Share on other sites
Luke

Is your FreeBSD system configured for latest packages?

Share this post


Link to post
Share on other sites
refos

This is a freenas plugin default configuration.  Did a iocage update emby (name of the jail that has emby server in it)  It didn't bring me something newer than 4.2.X.

 

I'm not sure what you mean by "Is your FreeBSD system configured for latest packages?" can you be more explicit ?

 

Before I push the side of "my configuration is totally screw up and I need to spend 3 hours on it while it always worked as expected except that the strm doesn't work" could you please tell me if those strm file are working properly on some freenas (even non-freenas, non-freebsd, non linux, whatever) system ?

 

At least tell me why you think why my installation is foobar (again while everything else is working properly ?)

 

Thanks,

Share this post


Link to post
Share on other sites
refos

Maybe you mean that I should update by base jail, I haven't done this in a long time.  Will check this at some point during this week. 

 

In the meantime, if you cloud confirm that you've got emby working on those strm file that would be awesome.

 

Thanks,

Share this post


Link to post
Share on other sites
refos

Hi,

 

Ok, so as I wrote earlier I end up reverting back to my official plugin FreeNAS install snapshot the one I took before I went trying to follow the sentence "And also can you update to Emby Server 4.3.1?"

 

So, currently, no I can't, FreeNAS official plugin is still at 4.2.1.0_1[1] and I really don't want to mess around too much.

 

I guess that until freenas update to 4.3.1 I won't listen to radio in emby.  I'll re-open at that moment.

 

Thanks,

 

[1] see https://github.com/freenas/iocage-ix-plugins/blob/master/emby.json which point to http://pkg.cdn.trueos.org/iocage/unstable/All/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...